Inicijalna prilagodba paketa za Debian.
authorDragan Dosen <ddosen@ffzg.hr>
Fri, 26 Mar 2010 16:34:14 +0000 (17:34 +0100)
committerDragan Dosen <ddosen@ffzg.hr>
Fri, 26 Mar 2010 16:34:14 +0000 (17:34 +0100)
debian/README.Debian [new file with mode: 0644]
debian/changelog [new file with mode: 0644]
debian/compat [new file with mode: 0644]
debian/control [new file with mode: 0644]
debian/copyright [new file with mode: 0644]
debian/dirs [new file with mode: 0644]
debian/docs [new file with mode: 0644]
debian/examples [new file with mode: 0644]
debian/links [new file with mode: 0644]
debian/postrm [new file with mode: 0644]
debian/rules [new file with mode: 0755]

diff --git a/debian/README.Debian b/debian/README.Debian
new file mode 100644 (file)
index 0000000..b75b502
--- /dev/null
@@ -0,0 +1,8 @@
+change_pass 3.0
+
+Make sure to have configured plugin in the configuration file
+/etc/squirrelmail/config_change_pass.php.  The plugin is NOT
+enabled in SquirrelMail by default.  See the plugin's README
+file for details.
+
+ -- Dragan Dosen <ddosen@ffzg.hr>  Fri, 26 Mar 2010 14:47:41 +0100
diff --git a/debian/changelog b/debian/changelog
new file mode 100644 (file)
index 0000000..b575a9d
--- /dev/null
@@ -0,0 +1,5 @@
+squirrelmail-change-pass (3.0-1) stable; urgency=low
+
+  * Initial release.
+
+ -- Dragan Dosen <ddosen@ffzg.hr>  Fri, 26 Mar 2010 14:47:41 +0100
diff --git a/debian/compat b/debian/compat
new file mode 100644 (file)
index 0000000..1e8b314
--- /dev/null
@@ -0,0 +1 @@
+6
diff --git a/debian/control b/debian/control
new file mode 100644 (file)
index 0000000..db31560
--- /dev/null
@@ -0,0 +1,16 @@
+Source: squirrelmail-change-pass
+Section: web
+Priority: optional
+Maintainer: Dragan Dosen <ddosen@ffzg.hr>
+Build-Depends: debhelper (>= 6)
+Standards-Version: 3.7.3
+
+Package: squirrelmail-change-pass
+Architecture: all
+Depends: squirrelmail (>= 2:1.4), squirrelmail-compatibility (>= 2.0.12-1), debconf (>= 1.4.69)
+Homepage: http://www.squirrelmail.org/plugin_view.php?id=21
+Description: SquirrelMail plugin: Change Password
+ Change passwords using a poppass daemon.
+ .
+ SquirrelMail is a standards-based webmail package written in PHP. It runs on
+ top of any IMAP server.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644 (file)
index 0000000..4464c1f
--- /dev/null
@@ -0,0 +1,30 @@
+Original source may be found at: http://www.squirrelmail.org/plugin_view.php?id=21
+
+Files: *
+Copyright: © 2001-2009 Ritchie Low, Tyler Akins, Seth Randall
+License: GPL-2+
+ This package is free software; you can redistribute it and/or modify it under
+ the terms of the GNU General Public License as published by the Free Software
+ Foundation; either version 2 of the License, or (at your option) any later
+ version.
+
+Files: index.php
+Copyright: © 1999-2008 The SquirrelMail Project Team
+License: GPL-2+
+ This package is free software; you can redistribute it and/or modify it under
+ the terms of the GNU General Public License as published by the Free Software
+ Foundation; either version 2 of the License, or (at your option) any later
+ version.
+
+Files: debian/*
+Copyright: © 2010 Dragan Dosen <ddosen@ffzg.hr>
+License: GPL-2+
+ This package is free software; you can redistribute it and/or modify it under
+ the terms of the GNU General Public License as published by the Free Software
+ Foundation; either version 2 of the License, or (at your option) any later
+ version.
+
+On Debian systems, the complete text of the GNU General Public License
+can be found in file "/usr/share/common-licenses/GPL-2". Possible later
+versions are found within the same directory (e.g.
+"/usr/share/common-licenses/GPL-3").
diff --git a/debian/dirs b/debian/dirs
new file mode 100644 (file)
index 0000000..f4a306c
--- /dev/null
@@ -0,0 +1,2 @@
+usr/share/squirrelmail/plugins/change_pass
+etc/squirrelmail
diff --git a/debian/docs b/debian/docs
new file mode 100644 (file)
index 0000000..fac849c
--- /dev/null
@@ -0,0 +1,4 @@
+doc/ChangeLog
+doc/FAQ
+doc/INSTALL
+doc/README
diff --git a/debian/examples b/debian/examples
new file mode 100644 (file)
index 0000000..3cf428d
--- /dev/null
@@ -0,0 +1 @@
+config_example.php
diff --git a/debian/links b/debian/links
new file mode 100644 (file)
index 0000000..1121a75
--- /dev/null
@@ -0,0 +1 @@
+etc/squirrelmail/config_change_pass.php usr/share/squirrelmail/plugins/change_pass/config.php
diff --git a/debian/postrm b/debian/postrm
new file mode 100644 (file)
index 0000000..a48df6e
--- /dev/null
@@ -0,0 +1,16 @@
+#!/bin/sh -e
+
+# Source debconf library.
+case "$1" in
+       remove)
+               if [ -x /usr/sbin/squirrelmail-configure ]; then
+                       /usr/sbin/squirrelmail-configure --remove-plugin change_pass
+               fi
+       ;;
+       *)
+       ;;
+esac
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..e8ca15f
--- /dev/null
@@ -0,0 +1,47 @@
+#!/usr/bin/make -f
+
+PACKAGE = $(shell dh_listpackages)
+TMP     = $(CURDIR)/debian/$(PACKAGE)
+
+build:
+
+clean:
+       dh_testdir
+       dh_testroot
+       dh_clean
+       rm -f install-stamp
+
+install: build install-stamp
+install-stamp:
+       dh_testdir
+       dh_testroot
+       dh_clean
+       dh_installdirs
+       find . -type f -not \( \
+               -path '*/debian/*' -or \
+               -path '*/doc/*' -or \
+               -path '*/.git/*' -or \
+               -name 'README' -or \
+               -name 'config_example.php' \
+               \) -exec install -D --mode=644 {} $(TMP)/usr/share/squirrelmail/plugins/change_pass/{} \;
+       install -D --mode=644 config_example.php $(TMP)/etc/squirrelmail/config_change_pass.php
+       touch install-stamp
+
+binary-arch: build install
+
+binary-indep: build install
+       dh_testdir
+       dh_testroot
+       dh_installdocs
+       dh_installchangelogs
+       dh_installexamples
+       dh_link
+       dh_compress
+       dh_fixperms
+       dh_installdeb
+       dh_installdebconf
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+binary: binary-indep binary-arch