From: Dinko Korunic <Dinko.Korunic@CARNet.hr>
Date: Wed, 24 Oct 2007 09:57:25 +0000 (+0000)
Subject: r1: [svn-inject] Installing original source of munin-cn
X-Git-Tag: v1.4.5~4
X-Git-Url: http://ftp.carnet.hr/carnet-debian/scm?a=commitdiff_plain;h=1ec33625fe662e96ea0ca158b899e49117b4e39f;p=munin-cn.git

r1: [svn-inject] Installing original source of munin-cn
---

1ec33625fe662e96ea0ca158b899e49117b4e39f
diff --git a/README.CARNet b/README.CARNet
new file mode 100644
index 0000000..dde7e5d
--- /dev/null
+++ b/README.CARNet
@@ -0,0 +1,7 @@
+munin--cn
+~~~~~~~~~
+
+Paket donosi neke (minimalne) rekonfiguracije za uskladjivanje sa ostalim
+CARNet paketima i distribucijom.
+
+ -- Dinko Korunic <kreator@carnet.hr>  Wed, 24 Oct 2007 11:53:15 +0200
diff --git a/changelog.CARNet b/changelog.CARNet
new file mode 120000
index 0000000..194579e
--- /dev/null
+++ b/changelog.CARNet
@@ -0,0 +1 @@
+changelog.Debian
\ No newline at end of file
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..53ad63c
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,6 @@
+munin-cn (1.2.3-1) stable; urgency=low
+
+  * inicijalna verzija paketa -- za sada samo postavlja ispravni hostname u
+    munin konfiguracije
+
+ -- Dinko Korunic <kreator@carnet.hr>  Wed, 24 Oct 2007 11:45:56 +0200
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..b8626c4
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+4
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..c6ea2ae
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,32 @@
+Source: munin-cn
+Section: net
+Priority: optional
+Maintainer: Dinko Korunic <kreator@carnet.hr>
+Build-Depends: debhelper (>= 4)
+Standards-Version: 3.7.2
+
+Package: munin-cn
+Architecture: all
+Depends: munin (>= 1.2.3-1), munin-node (>= 1.2.3-1), libdate-manip-perl (>= 5.42a-3), libnet-snmp-perl (>= 5.0.1-1)
+Description: network-wide graphing framework (grapher/gatherer)
+ Munin is a highly flexible and powerful solution used to create graphs of
+ virtually everything imaginable throughout your network, while still
+ maintaining a rattling ease of installation and configuration.
+ .
+ This package contains the grapher/gatherer. You will only need one
+ instance of it in your network. It will periodically poll all the nodes
+ in your network it's aware of for data, which it in turn will use to
+ create graphs and HTML pages, suitable for viewing with your graphical
+ web browser of choice.
+ .
+ It is also able to alert you if any value is outside of a preset
+ boundary, useful if you want to be alerted if a filesystem is about to
+ grow full, for instance.  You can do this by making Munin run an
+ arbitrary command when you need to be alert it, or make use of the
+ intrinsic Nagios support.
+ .
+ Munin is written in Perl, and relies heavily on Tobi Oetiker's excellent
+ RRDtool. To see a real example of Munin in action, take a peek at
+ <http://www.linpro.no/projects/munin/example/>.
+ .
+ This package brings CARNet-related configuration.
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..ef5ce6c
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1,2 @@
+changelog.CARNet
+README.CARNet
diff --git a/debian/postinst b/debian/postinst
new file mode 100755
index 0000000..456919a
--- /dev/null
+++ b/debian/postinst
@@ -0,0 +1,57 @@
+#!/bin/sh
+# postinst script for bind9-cn
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+#        * <postinst> `configure' <most-recently-configured-version>
+#        * <old-postinst> `abort-upgrade' <new version>
+#        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
+#          <new-version>
+#        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
+#          <failed-install-package> <version> `removing'
+#          <conflicting-package> <version>
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+#
+
+case "$1" in
+    configure|reconfigure)
+      # continue below
+    ;;
+
+    *)
+        exit 0
+    ;;
+esac
+
+# import CN-functions
+. /usr/share/carnet-tools/functions.sh
+
+# variables
+CARNET_HOSTNAME=`hostname`
+CARNET_DOMAINNAME=`hostname --domain`
+
+# fix the hostname in munin/munin-node configuration
+cp_check_and_sed 'localhost.localdomain' \
+    "s/localhost.localdomain/$CARNET_HOSTNAME.$CARNET_DOMAINNAME/g" \
+    /etc/munin/munin.conf || true
+cp_check_and_sed 'localhost.localdomain' \
+    "s/localhost.localdomain/$CARNET_HOSTNAME.$CARNET_DOMAINNAME/g" \
+    /etc/munin/munin-node.conf || true
+
+# restart the services
+if [ -x "`which invoke-rc.d 2>/dev/null`" ]; then
+	invoke-rc.d munin-node restart || exit $?
+else
+	/etc/init.d/munin-node restart || exit $?
+fi
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..ec73f03
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,73 @@
+#!/usr/bin/make -f
+# Sample debian/rules that uses debhelper. 
+# This file is public domain software, originally written by Joey Hess.
+#
+# This version is for packages that are architecture independent.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+build: build-stamp
+build-stamp:
+	dh_testdir
+
+	# Add here commands to compile the package.
+	#$(MAKE)
+
+	touch build-stamp
+
+clean:
+	dh_testdir
+	dh_testroot
+	rm -f build-stamp
+
+	# Add here commands to clean up after the build process.
+	#-$(MAKE) clean
+	#-$(MAKE) distclean
+
+	dh_clean
+
+install: build
+	dh_testdir
+	dh_testroot
+	dh_clean -k
+	dh_installdirs
+
+	# Add here commands to install the package into debian/<packagename>.
+	#$(MAKE) prefix=`pwd`/debian/`dh_listpackages`/usr install
+
+# Build architecture-independent files here.
+binary-indep: build install
+	dh_testdir
+	dh_testroot
+	dh_installchangelogs
+	dh_installdocs
+#	dh_installexamples
+#	dh_installmenu
+#	dh_installdebconf
+#	dh_installlogrotate
+#	dh_installemacsen
+#	dh_installcatalogs
+#	dh_installpam
+#	dh_installmime
+#	dh_installinit
+#	dh_installcron
+#	dh_installinfo
+#	dh_undocumented
+	dh_installman
+	dh_link
+	dh_compress
+	dh_fixperms
+#	dh_perl
+#	dh_python
+	dh_installdeb
+	dh_gencontrol
+	dh_md5sums
+	dh_builddeb
+
+# Build architecture-dependent files here.
+binary-arch: build install
+# We have nothing to do by default.
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install