brisanje starih conffileova
authorIvan Rako <irako@nekkar.carnet.hr>
Tue, 5 Nov 2013 11:55:48 +0000 (12:55 +0100)
committerIvan Rako <irako@nekkar.carnet.hr>
Tue, 5 Nov 2013 11:55:48 +0000 (12:55 +0100)
debian/changelog
debian/postinst

index c71773a..e3c0be3 100644 (file)
@@ -1,3 +1,13 @@
+amavisd-cn (3:2.7.1~cn1) stable; urgency=low
+
+  * Brisanje zaostalih konfiguracijskih datoteka:
+    /etc/logcheck/violations.ignore.d/amavisd-new
+    /etc/logcheck/ignore.d.server/amavisd-new
+    /etc/logcheck/ignore.d.workstation/amavisd-new
+    /etc/cron.daily/amavisd-new
+
+ -- Ivan Rako <Ivan.Rako@CARNet.hr>  Tue, 05 Nov 2013 12:51:57 +0100
+
 amavisd-cn (3:2.7.1~cn0) stable; urgency=low
 
   * Prva verzija za wheezy
index 32c46bb..b7fba03 100755 (executable)
@@ -215,6 +215,15 @@ if [ -n "$2" -a -z "$changed_config" ] && \
   cp_echo "    perl -pi -e 's/_CN_DOMAIN_/$domain/g' $ACONF"
 fi
 
+# Delete old conffiles...
+for conffile in /etc/logcheck/violations.ignore.d/amavisd-new \
+         /etc/logcheck/ignore.d.server/amavisd-new \
+         /etc/logcheck/ignore.d.workstation/amavisd-new \
+         /etc/cron.daily/amavisd-new; do
+  cp_echo "CN: Deleting old conffile ${conffile}..."
+  rm -f ${conffile}
+done
+
 cp_mail $PKG $VERSION
 
 exit 0