Avoid using carnet-tools-cn in debian/config (RT#90912).
authorValentin Vidic <Valentin.Vidic@CARNet.hr>
Mon, 24 Sep 2012 11:36:43 +0000 (13:36 +0200)
committerValentin Vidic <Valentin.Vidic@CARNet.hr>
Mon, 24 Sep 2012 11:38:28 +0000 (13:38 +0200)
debian/config
debian/control

index 1fe6e1f..73c4f4c 100644 (file)
@@ -11,12 +11,19 @@ if [ -z "$RET" ]; then
 fi
 
 # Guess default ip
-. /usr/share/carnet-tools/functions.sh
-cp_get_ifaddr
-IP=$RET
 db_get bacula-cn/ip || true
 if [ -z "$RET" ]; then
-    db_set bacula-cn/ip "$IP"
+    # default via 161.53.55.1 dev eth0
+    DEV=$( ip route show to exact 0/0 \
+           | awk '$1 == "default" && $4 == "dev" { print $5; nextfile }' )
+    if [ "$DEV" ]; then
+        # inet 161.53.55.202/24 brd 161.53.55.255 scope global eth0
+        IP=$( ip address show dev $DEV scope global \
+              | awk '$1 == "inet" { sub("/[^ ]+", ""); print $2; nextfile }' )
+        if [ "$IP" ]; then
+            db_set bacula-cn/ip "$IP"
+        fi
+    fi
 fi
 
 # Sample contact
index bba884a..1c070d9 100644 (file)
@@ -12,7 +12,7 @@ Vcs-Browser: http://ftp.carnet.hr/carnet-debian/scm/?p=bacula-cn.git;a=summary
 Package: bacula-cn
 Architecture: all
 Depends: bacula-fd (>= 5), bacula-console (>= 5), openssl, gnupg,
- debconf (>= 0.5) | debconf-2.0, carnet-tools-cn, ${misc:Depends}
+ debconf (>= 0.5) | debconf-2.0, ${misc:Depends}
 Suggests: mysql-client, postgresql-client-common, mail-transport-agent
 Description: Network backup configuration for CARNet members
  This package install Bacula client daemon and configures it for use