r1: [svn-inject] Installing original source of carnet-debian
authorGrupa za izradu paketa <paketi@carnet.hr>
Tue, 23 Oct 2007 10:26:10 +0000 (10:26 +0000)
committerGrupa za izradu paketa <paketi@carnet.hr>
Tue, 23 Oct 2007 10:26:10 +0000 (10:26 +0000)
14 files changed:
README.CARNet [new file with mode: 0644]
changelog.CARNet [new symlink]
debian/changelog [new file with mode: 0644]
debian/compat [new file with mode: 0644]
debian/config [new file with mode: 0755]
debian/control [new file with mode: 0644]
debian/dirs [new file with mode: 0644]
debian/docs [new file with mode: 0644]
debian/install [new file with mode: 0644]
debian/postinst [new file with mode: 0755]
debian/postrm [new file with mode: 0755]
debian/rules [new file with mode: 0755]
debian/templates [new file with mode: 0644]
install-carnet-debian [new file with mode: 0644]

diff --git a/README.CARNet b/README.CARNet
new file mode 100644 (file)
index 0000000..e7f7b4c
--- /dev/null
@@ -0,0 +1,6 @@
+carnet-debian
++-----------+
+
+Paket sluzi za laksu instalaciju CARNet Debian paketa.
+
+ -- Ivan Rako <Ivan.Rako@CARNet.hr>  Tue, 23 Oct 2007 12:04:42 +0200
diff --git a/changelog.CARNet b/changelog.CARNet
new file mode 120000 (symlink)
index 0000000..194579e
--- /dev/null
@@ -0,0 +1 @@
+changelog.Debian
\ No newline at end of file
diff --git a/debian/changelog b/debian/changelog
new file mode 100644 (file)
index 0000000..e186171
--- /dev/null
@@ -0,0 +1,5 @@
+carnet-debian (3.0.0) carnet-etch; urgency=medium
+
+  * Prva verzija za Etch
+
+ -- Ivan Rako <Ivan.Rako@CARNet.hr>  Mon, 22 Oct 2007 00:00:10 +0200
diff --git a/debian/compat b/debian/compat
new file mode 100644 (file)
index 0000000..b8626c4
--- /dev/null
@@ -0,0 +1 @@
+4
diff --git a/debian/config b/debian/config
new file mode 100755 (executable)
index 0000000..e5e9855
--- /dev/null
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+set -e
+
+# Load debconf
+. /usr/share/debconf/confmodule
+
+db_input critical carnet-debian/packages || true
+
+db_go || true
+db_stop || true
diff --git a/debian/control b/debian/control
new file mode 100644 (file)
index 0000000..c411f8c
--- /dev/null
@@ -0,0 +1,12 @@
+Source: carnet-debian
+Section: carnet
+Priority: optional
+Maintainer: Ivan Rako <Ivan.Rako@CARNet.hr>
+Build-Depends: debhelper (>= 4.0.0)
+Standards-Version: 3.6.1
+
+Package: carnet-debian
+Provides: carnet-debian-cn
+Architecture: all
+Depends: debconf
+Description: Installer for CARNet Debian packages
diff --git a/debian/dirs b/debian/dirs
new file mode 100644 (file)
index 0000000..236670a
--- /dev/null
@@ -0,0 +1 @@
+usr/sbin
diff --git a/debian/docs b/debian/docs
new file mode 100644 (file)
index 0000000..d92e2d1
--- /dev/null
@@ -0,0 +1,2 @@
+README.CARNet
+changelog.CARNet
diff --git a/debian/install b/debian/install
new file mode 100644 (file)
index 0000000..512664e
--- /dev/null
@@ -0,0 +1 @@
+install-carnet-debian usr/sbin
diff --git a/debian/postinst b/debian/postinst
new file mode 100755 (executable)
index 0000000..c842623
--- /dev/null
@@ -0,0 +1,8 @@
+#!/bin/sh
+
+set -e
+
+[ "$1" = "configure" ] || exit 0
+
+echo "CN: You can run for install CARNet Debian packages:"
+echo "CN:   # install-carnet-debian"
diff --git a/debian/postrm b/debian/postrm
new file mode 100755 (executable)
index 0000000..b6dcb1f
--- /dev/null
@@ -0,0 +1,10 @@
+#!/bin/sh -e
+
+set -e
+
+[ "$1" = "purge" ] || exit 0
+
+# Load debconf
+. /usr/share/debconf/confmodule
+
+db_purge || true
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..7a40028
--- /dev/null
@@ -0,0 +1,86 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+configure: configure-stamp
+configure-stamp:
+       dh_testdir
+       # Add here commands to configure the package.
+
+       touch configure-stamp
+
+
+build: build-stamp
+
+build-stamp: configure-stamp 
+       dh_testdir
+
+       # Add here commands to compile the package.
+       # $(MAKE)
+
+       touch build-stamp
+
+clean:
+       dh_testdir
+       dh_testroot
+       rm -f build-stamp configure-stamp
+
+       # Add here commands to clean up after the build process.
+       # -$(MAKE) clean
+
+       dh_clean 
+
+install: build
+       dh_testdir
+       dh_testroot
+       dh_clean -k 
+       dh_installdirs
+
+       # Add here commands to install the package into debian/carnet-debian.
+       # $(MAKE) install DESTDIR=$(CURDIR)/debian/carnet-debian
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+       dh_testdir
+       dh_testroot
+       dh_installchangelogs -k
+       dh_installdocs
+#      dh_installexamples
+       dh_install
+#      dh_installmenu
+       dh_installdebconf       
+#      dh_installlogrotate
+#      dh_installemacsen
+#      dh_installpam
+#      dh_installmime
+#      dh_installinit
+       dh_installcron
+#      dh_installinfo
+       dh_installman
+#      dh_link
+#      dh_strip
+#      dh_compress
+       dh_fixperms
+#      dh_perl
+#      dh_python
+#      dh_makeshlibs
+       dh_installdeb
+#      dh_shlibdeps
+       dh_gencontrol
+       dh_md5sums
+       dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install configure
diff --git a/debian/templates b/debian/templates
new file mode 100644 (file)
index 0000000..7ab2b53
--- /dev/null
@@ -0,0 +1,7 @@
+Template: carnet-debian/packages
+Type: multiselect
+Choices: amavisd-cn, amavis-stats-cn, apache2-cn, apt-cn, bind9-cn, carnet-tools-cn, clamav-cn, dovecot-cn, jre-cn, mailman-cn, monit-cn, munin-cn, mysql-cn, ntp-cn, openssh-cn, phpbb2-cn, pine-cn, postfix-cn, samba-cn, vsftpd-cn
+Description: Koje pakete zelite?
+ CARNet Debian donosi pakete za laksu konfiguraciju servisa na CARNetovom
+ cvornom racunalu.
+
diff --git a/install-carnet-debian b/install-carnet-debian
new file mode 100644 (file)
index 0000000..459ae5f
--- /dev/null
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+set -e
+
+. /usr/share/debconf/confmodule
+
+db_get carnet-packages/packages || true
+packages="$RET"
+
+apt-get install $packages