novi copyright, novi debian/rules
authorIvan Rako <irako@nekkar.carnet.hr>
Fri, 22 Apr 2011 10:54:34 +0000 (12:54 +0200)
committerIvan Rako <irako@nekkar.carnet.hr>
Fri, 22 Apr 2011 10:54:34 +0000 (12:54 +0200)
debian/copyright
debian/postinst
debian/prerm
debian/rules

index e3933e7..28add9f 100644 (file)
@@ -1,7 +1,7 @@
-This package is copyright (c) by CARNet <paketi@carnet.hr>.
+Copyright 2006 CARNet <paketi@carnet.hr>
 
-You are free to distribute this software under the terms of
-the GNU General Public License.
+You are free to distribute this software package under the terms of the
+GNU General Public License.
 
 On Debian systems, the complete text of the GNU General Public
 License can be found in the file /usr/share/common-licenses/GPL.
index 0d37f03..3e25c92 100644 (file)
@@ -1,5 +1,7 @@
 #!/bin/sh
 
+set -e
+
 if [ -x /usr/bin/apt-key ]; then
-    /usr/bin/apt-key add /usr/share/keyrings/carnet-keyring.gpg
+    apt-key add /usr/share/keyrings/carnet-keyring.gpg
 fi
index 0a0d36b..8b43449 100644 (file)
@@ -1,9 +1,11 @@
 #!/bin/sh
 
+set -e
+
 case "$1" in
     remove|purge)
        if [ -x /usr/bin/apt-key ]; then
-               /usr/bin/apt-key del EC72006A
+               apt-key del EC72006A
        fi
        ;;
 esac
index ffb469e..cbe925d 100755 (executable)
@@ -1,61 +1,3 @@
 #!/usr/bin/make -f
-# debian/rules file - for debian/keyring
-# Based on sample debian/rules file - for GNU Hello (1.3).
-# Copyright 1994,1995 by Ian Jackson.
-# Copyright 1998-2003 James Troup
-# I hereby give you perpetual unlimited permission to copy,
-# modify and relicense this file, provided that you do not remove
-# my name from the file itself.  (I assert my moral right of
-# paternity under the Copyright, Designs and Patents Act 1988.)
-# This file may have to be extensively modified
-
-install_dir=install -d -m 755
-install_file=install -m 644
-install_script=install -m 755
-install_binary=install -m 755 -s
-
-VERSION := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
-
-build:
-
-clean:
-       $(checkdir)
-       -rm -f foo foo.asc *.bak *~ */*~ debian/files* debian/*substvars
-       -rm -rf debian/tmp
-
-binary-indep: checkroot
-       $(checkdir)
-       -rm -rf debian/tmp
-       $(install_dir) debian/tmp/DEBIAN/
-       $(install_script) debian/postinst debian/tmp/DEBIAN/
-       $(install_script) debian/prerm debian/tmp/DEBIAN/
-
-       $(install_dir) debian/tmp/usr/share/keyrings/
-       $(install_file) keyrings/carnet-keyring.gpg debian/tmp/usr/share/keyrings/
-       $(install_file) keyrings/carnet-removed-keys.gpg debian/tmp/usr/share/keyrings/
-
-       $(install_dir) debian/tmp/usr/share/doc/carnet-keyring/
-       $(install_file) debian/changelog debian/tmp/usr/share/doc/carnet-keyring/changelog
-
-       dh_installdocs
-       dpkg-gencontrol -pcarnet-keyring -isp
-       chown -R root.root debian/tmp
-       chmod -R go=rX debian/tmp
-       dpkg --build debian/tmp ..
-
-binary-arch:
-
-#define checkdir
-#      test -f keyrings/carnet-keyring.gpg
-#      test -f keyrings/carnet-removed-keys.gpg
-#endef
-
-# Below here is fairly generic really
-
-binary:                binary-indep binary-arch
-
-checkroot:
-       $(checkdir)
-       test root = "`whoami`"
-
-.PHONY: binary binary-arch binary-indep clean checkroot
+%:
+       dh $@