r1: [svn-inject] Installing original source of carnet-keyring
authorIvan Rako <Ivan.Rako@CARNet.hr>
Sun, 28 Oct 2007 13:14:15 +0000 (13:14 +0000)
committerIvan Rako <Ivan.Rako@CARNet.hr>
Sun, 28 Oct 2007 13:14:15 +0000 (13:14 +0000)
README.CARNet [new file with mode: 0644]
changelog.CARNet [new symlink]
debian/changelog [new file with mode: 0644]
debian/control [new file with mode: 0644]
debian/docs [new file with mode: 0644]
debian/postinst [new file with mode: 0644]
debian/prerm [new file with mode: 0644]
debian/rules [new file with mode: 0755]
keyrings/carnet-keyring.gpg [new file with mode: 0644]
keyrings/carnet-removed-keys.gpg [new file with mode: 0644]

diff --git a/README.CARNet b/README.CARNet
new file mode 100644 (file)
index 0000000..442c606
--- /dev/null
@@ -0,0 +1,6 @@
+carnet-keyring
++------------+
+
+Paket donosi keyring repozitorija paketa za CARNet Debian 3.0.
+
+ -- Ivan Rako <Ivan.Rako@CARNet.hr>  Sun, 28 Oct 2007 14:13:16 +0100
diff --git a/changelog.CARNet b/changelog.CARNet
new file mode 120000 (symlink)
index 0000000..6a28af6
--- /dev/null
@@ -0,0 +1 @@
+changelog
\ No newline at end of file
diff --git a/debian/changelog b/debian/changelog
new file mode 100644 (file)
index 0000000..c5d9b57
--- /dev/null
@@ -0,0 +1,5 @@
+carnet-keyring (2007.10.28) stable; urgency=low
+
+  * Inicijalna verzija
+
+ -- Ivan Rako <Ivan.Rako@CARNet.hr>  Sun, 28 Oct 2007 14:04:34 +0100
diff --git a/debian/control b/debian/control
new file mode 100644 (file)
index 0000000..3f0f01e
--- /dev/null
@@ -0,0 +1,13 @@
+Source: carnet-keyring
+Section: misc
+Maintainer: Ivan Rako <Ivan.Rako@CARNet.hr>
+Standards-Version: 3.7.2
+
+Package: carnet-keyring
+Priority: important
+Provides: carnet-keyring-cn
+Architecture: all
+Depends: gnupg (>= 1.0.6-4)
+Description: GnuPG archive key of the CARNet packages repository
+ The CARNet packages repository digitally signs its Release files. This
+ package contains the repository key used for that.
diff --git a/debian/docs b/debian/docs
new file mode 100644 (file)
index 0000000..d92e2d1
--- /dev/null
@@ -0,0 +1,2 @@
+README.CARNet
+changelog.CARNet
diff --git a/debian/postinst b/debian/postinst
new file mode 100644 (file)
index 0000000..0d37f03
--- /dev/null
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+if [ -x /usr/bin/apt-key ]; then
+    /usr/bin/apt-key add /usr/share/keyrings/carnet-keyring.gpg
+fi
diff --git a/debian/prerm b/debian/prerm
new file mode 100644 (file)
index 0000000..6fa4535
--- /dev/null
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+case "$1" in
+    remove|purge)
+       if [ -x /usr/bin/apt-key ]; then
+               /usr/bin/apt-key del 4DF89685
+       fi
+       ;;
+esac
diff --git a/debian/rules b/debian/rules
new file mode 100755 (executable)
index 0000000..ddcd466
--- /dev/null
@@ -0,0 +1,60 @@
+#!/usr/bin/make -f
+# debian/rules file - for debian/keyring
+# Based on sample debian/rules file - for GNU Hello (1.3).
+# Copyright 1994,1995 by Ian Jackson.
+# Copyright 1998-2003 James Troup
+# I hereby give you perpetual unlimited permission to copy,
+# modify and relicense this file, provided that you do not remove
+# my name from the file itself.  (I assert my moral right of
+# paternity under the Copyright, Designs and Patents Act 1988.)
+# This file may have to be extensively modified
+
+install_dir=install -d -m 755
+install_file=install -m 644
+install_script=install -m 755
+install_binary=install -m 755 -s
+
+VERSION := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
+
+build:
+
+clean:
+       $(checkdir)
+       -rm -f foo foo.asc *.bak *~ */*~ debian/files* debian/*substvars
+       -rm -rf debian/tmp
+
+binary-indep: checkroot
+       $(checkdir)
+       -rm -rf debian/tmp
+       $(install_dir) debian/tmp/DEBIAN/
+       $(install_script) debian/postinst debian/tmp/DEBIAN/
+       $(install_script) debian/prerm debian/tmp/DEBIAN/
+
+       $(install_dir) debian/tmp/usr/share/keyrings/
+       $(install_file) keyrings/carnet-keyring.gpg debian/tmp/usr/share/keyrings/
+       $(install_file) keyrings/carnet-removed-keys.gpg debian/tmp/usr/share/keyrings/
+
+       $(install_dir) debian/tmp/usr/share/doc/carnet-keyring/
+       $(install_file) debian/changelog debian/tmp/usr/share/doc/carnet-keyring/changelog
+
+       dpkg-gencontrol -pcarnet-keyring -isp
+       chown -R root.root debian/tmp
+       chmod -R go=rX debian/tmp
+       dpkg --build debian/tmp ..
+
+binary-arch:
+
+#define checkdir
+#      test -f keyrings/carnet-keyring.gpg
+#      test -f keyrings/carnet-removed-keys.gpg
+#endef
+
+# Below here is fairly generic really
+
+binary:                binary-indep binary-arch
+
+checkroot:
+       $(checkdir)
+       test root = "`whoami`"
+
+.PHONY: binary binary-arch binary-indep clean checkroot
diff --git a/keyrings/carnet-keyring.gpg b/keyrings/carnet-keyring.gpg
new file mode 100644 (file)
index 0000000..6d4e7ed
--- /dev/null
@@ -0,0 +1,16 @@
+-----BEGIN PGP PUBLIC KEY BLOCK-----
+Version: GnuPG v1.4.6 (GNU/Linux)
+
+mQCNAzgAdzoAAAEEALpETN1NAqKxu5Ae7Ke8t7K9yDxpxaUIVly/Xxo6dyUjgEGg
+M6ElB+9d+9Q+AMO+c1UkhvMFKJn95ABxt25z/OvUvJTsu9AyIPRiTY0rDOyytHB/
+ogMEPnRYNHSGkoTJ9SVuIh4lpF3ueyZqZ84kLNVDXqVmGdWvcmsCiZFN+JaFAAUR
+tB9JdmFuIFJha28gPEl2YW4uUmFrb0BDQVJOZXQuaHI+iQCVAwUQOAB3OmsCiZFN
++JaFAQEpfwQAqC9EdBeUgaEQGhTRVdVSKiKyHfg+SRYRHoF+WMd+wbyfUc5/6cMX
+wy/TI5qA6mN6VZwqSRFbolxctXoTN5x3bfIyRl4OauiyhO1X16HbahwtgW/GCp8w
+yD7/M6BIjgmd8KxvRtWvrYv/J0yjAAWTl0TvGYlihz+GrRveBL7kO6m0GUl2YW4g
+UmFrbyA8aXJha29Ac3JjZS5ocj6JAJUDBRNBPvseawKJkU34loUBASI3BACjfUBR
+irnCRQgxGecapCMFdospax0s9lnm4XC6wtGmwJmmv60dJ9evzQvEXbb599q+EZBY
+GJwnHCtyZ0C7uOObfXZpi10kKC1isurdgSAd0wW/NdCRGWxPo1nzpRagib0OddVa
+S2DGTGjGvXh7cTS7XxcX9Th8+ZKjqkvyGXv6zw==
+=/Z2C
+-----END PGP PUBLIC KEY BLOCK-----
diff --git a/keyrings/carnet-removed-keys.gpg b/keyrings/carnet-removed-keys.gpg
new file mode 100644 (file)
index 0000000..e69de29