Handle mailman upgrade.
[carnet-upgrade.git] / debian / rules
index 9316135..2fb76e9 100755 (executable)
@@ -9,15 +9,38 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-build: build-stamp
+# check if locale is available or use a local copy
+ifeq ($(wildcard /usr/share/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8),)
+perlenv = PERL5LIB=../debian/perl5
+endif
 
-build-stamp:
+PKG_VERSION = $(shell dpkg-parsechangelog|sed -n 's/^Version: \(.*:\|\)//p')
+
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
+
+build-stamp: doc/carnet-upgrade-src.sgml
        dh_testdir
 
-       # Build the package.
-       (cd doc; debiandoc2text -l hr_HR.UTF-8 carnet-upgrade.sgml)
-       (cd doc; debiandoc2html -l hr_HR.UTF-8 carnet-upgrade.sgml)
-       (cd doc; debiandoc2pdf  -l hr_HR.UTF-8 carnet-upgrade.sgml)
+       # Update package version in documentation
+       sed -e 's/%PKG_VERSION%/$(PKG_VERSION)/g' doc/carnet-upgrade-src.sgml \
+               > doc/carnet-upgrade.sgml
+
+       # Build txt docs
+       (cd doc; $(perlenv) debiandoc2text -l hr_HR.UTF-8 carnet-upgrade.sgml)
+
+       # Build one page html docs
+       rm -rf doc/carnet-upgrade.html
+       (cd doc; $(perlenv) debiandoc2html -l hr_HR.UTF-8 \
+               -1 carnet-upgrade.sgml)
+       mv doc/carnet-upgrade.html/index.html doc/index.html
+       rmdir doc/carnet-upgrade.html
+       mv doc/index.html doc/carnet-upgrade.html
+
+       # Build pdf docs
+       (cd doc; $(perlenv) debiandoc2pdf -l hr_HR.UTF-8 \
+               -s ../debian/fix_latex carnet-upgrade.sgml)
        rm doc/carnet-upgrade.tpt
 
        touch $@
@@ -28,30 +51,31 @@ clean:
        rm -f build-stamp
 
        # Clean up after the build process.
-       rm -rf doc/carnet-upgrade.{txt,html,pdf,tpt}
+       rm -rf doc/carnet-upgrade.{txt,html,pdf,tpt,sgml}
 
        dh_clean 
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k 
+       dh_clean
        dh_installdirs
 
        # Install the package.
 
 # Build architecture-independent files here.
 binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs 
        dh_installdocs
        dh_installexamples
        dh_install
+       # Update package version in source
+       sed -i -e 's/%PKG_VERSION%/$(PKG_VERSION)/g' \
+               debian/carnet-upgrade/usr/share/carnet-upgrade/cn-upgrade
+       # Remove documentation template
+       rm -f debian/carnet-upgrade/usr/share/doc/carnet-upgrade/carnet-upgrade-src.sgml
 #      dh_installmenu
        dh_installdebconf       
 #      dh_installlogrotate
@@ -75,5 +99,9 @@ binary-arch: build install
        dh_md5sums
        dh_builddeb
 
-binary: binary-indep binary-arch
+# Build architecture-dependent files here.
+binary-arch: build install
+# We have nothing to do here.
+
+binary: binary-indep
 .PHONY: build clean binary-indep binary-arch binary install