Delete empty pages from pdf
[carnet-upgrade.git] / debian / rules
index e827a56..447df9d 100755 (executable)
@@ -1,23 +1,14 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
+# See debhelper(7) (uncomment to enable)
+# output every command that modifies files on the build system.
+#export DH_VERBOSE = 1
 
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
+%:
+       dh $@
 
 PKG_VERSION = $(shell dpkg-parsechangelog|sed -n 's/^Version: \(.*:\|\)//p')
 
-build: build-arch build-indep
-build-arch: build-stamp
-build-indep: build-stamp
-
-build-stamp: doc/carnet-upgrade-src.sgml
-       dh_testdir
-
+override_dh_auto_build:
        # Update package version in documentation
        sed -e 's/%PKG_VERSION%/$(PKG_VERSION)/g' doc/carnet-upgrade-src.sgml \
                > doc/carnet-upgrade.sgml
@@ -33,68 +24,14 @@ build-stamp: doc/carnet-upgrade-src.sgml
        mv doc/index.html doc/carnet-upgrade.html
 
        # Build pdf docs
-       (cd doc; debiandoc2pdf -l hr_HR.UTF-8 carnet-upgrade.sgml)
+       (cd doc; debiandoc2pdf -l hr_HR.UTF-8 -s ../debian/fix_latex carnet-upgrade.sgml)
        rm doc/carnet-upgrade.tpt
 
-       touch $@
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp
-
-       # Clean up after the build process.
-       rm -rf doc/carnet-upgrade.{txt,html,pdf,tpt,sgml}
-
-       dh_clean 
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean
-       dh_installdirs
-
-       # Install the package.
-
-# Build architecture-independent files here.
-binary-indep: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs 
-       dh_installdocs
-       dh_installexamples
+override_dh_install:
        dh_install
+
        # Update package version in source
        sed -i -e 's/%PKG_VERSION%/$(PKG_VERSION)/g' \
                debian/carnet-upgrade/usr/share/carnet-upgrade/cn-upgrade
        # Remove documentation template
        rm -f debian/carnet-upgrade/usr/share/doc/carnet-upgrade/carnet-upgrade-src.sgml
-#      dh_installmenu
-       dh_installdebconf       
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_python
-#      dh_installinit
-#      dh_installcron
-#      dh_installinfo
-       dh_installman
-       dh_link
-       dh_strip
-       dh_compress
-       dh_fixperms
-#      dh_perl
-#      dh_makeshlibs
-       dh_installdeb
-       dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-# Build architecture-dependent files here.
-binary-arch: build install
-# We have nothing to do here.
-
-binary: binary-indep
-.PHONY: build clean binary-indep binary-arch binary install