Backport hr_HR.UTF-8 debiandoc locale to etch.
[carnet-upgrade.git] / debian / rules
index acf3b06..9beafcd 100755 (executable)
@@ -9,23 +9,31 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
+# check if locale is available or use a local copy
+ifeq ($(wildcard /usr/share/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8),)
+perlenv = PERL5LIB=../debian/perl5
+endif
+
+
 build: build-stamp
 
 build-stamp: doc/carnet-upgrade.sgml
        dh_testdir
 
        # Build txt docs
-       (cd doc; debiandoc2text -l hr_HR.UTF-8 carnet-upgrade.sgml)
+       (cd doc; $(perlenv) debiandoc2text -l hr_HR.UTF-8 carnet-upgrade.sgml)
 
        # Build one page html docs
        rm -rf doc/carnet-upgrade.html
-       (cd doc; debiandoc2html -l hr_HR.UTF-8 -1 carnet-upgrade.sgml)
+       (cd doc; $(perlenv) debiandoc2html -l hr_HR.UTF-8 \
+               -1 carnet-upgrade.sgml)
        mv doc/carnet-upgrade.html/index.html doc/index.html
        rmdir doc/carnet-upgrade.html
        mv doc/index.html doc/carnet-upgrade.html
 
        # Build pdf docs
-       (cd doc; debiandoc2pdf -l hr_HR.UTF-8 -s ../debian/fix_latex carnet-upgrade.sgml)
+       (cd doc; $(perlenv) debiandoc2pdf -l hr_HR.UTF-8 \
+               -s ../debian/fix_latex carnet-upgrade.sgml)
        rm doc/carnet-upgrade.tpt
 
        touch $@