Fix pdf build on jessie
authorValentin Vidic <Valentin.Vidic@CARNet.hr>
Fri, 22 Sep 2017 11:57:29 +0000 (13:57 +0200)
committerValentin Vidic <Valentin.Vidic@CARNet.hr>
Fri, 22 Sep 2017 11:57:29 +0000 (13:57 +0200)
12 files changed:
debian/control
debian/fix_latex [deleted file]
debian/perl5/DebianDoc_SGML/Locale/Alias.pm [deleted file]
debian/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8/HTML [deleted file]
debian/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8/LaTeX [deleted file]
debian/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8/SGML [deleted file]
debian/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8/Texinfo [deleted file]
debian/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8/Text [deleted file]
debian/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8/TextOV [deleted file]
debian/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8/Wiki [deleted file]
debian/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8/XML [deleted file]
debian/rules

index 04380e2..e162a06 100644 (file)
@@ -4,7 +4,7 @@ Priority: extra
 Maintainer: Grupa za izradu paketa <paketi@carnet.hr>
 Uploaders: Valentin Vidic <Valentin.Vidic@CARNet.hr>, Zeljko Boros <Zeljko.Boros@carnet.hr>
 Build-Depends: debhelper (>= 7), po-debconf, debiandoc-sgml, texlive,
- texlive-latex-extra, ghostscript
+ texlive-latex-extra, texlive-lang-european, ghostscript
 Standards-Version: 3.9.6
 
 Package: carnet-upgrade
diff --git a/debian/fix_latex b/debian/fix_latex
deleted file mode 100755 (executable)
index 96179e0..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
-#!/bin/sh
-
-if [ "$1" = "-l" ]; then
-    # ignore lang settings
-    shift 2
-fi
-
-# prevent latex from adding empty pages
-sed '1s|^\(\\documentclass\[.*\)\(\]{book}\)|\1,openany\2|' <$1 >$2
diff --git a/debian/perl5/DebianDoc_SGML/Locale/Alias.pm b/debian/perl5/DebianDoc_SGML/Locale/Alias.pm
deleted file mode 100644 (file)
index 03f1f8c..0000000
+++ /dev/null
@@ -1,198 +0,0 @@
-## -*- perl -*-
-## ----------------------------------------------------------------------
-## DebianDoc_SGML/Locale/Alias.pm: locale aliases for i18n support
-## ----------------------------------------------------------------------
-## Copyright (C) 1998-2004 Ardo van Rangelrooij
-##
-## This is free software; see the GNU General Public Licence
-## version 2 or later for copying conditions.  There is NO warranty.
-## ----------------------------------------------------------------------
-
-## ----------------------------------------------------------------------
-## package interface definition
-package DebianDoc_SGML::Locale::Alias;
-use strict;
-use vars qw( @ISA @EXPORT );
-use Exporter;
-@ISA = qw( Exporter );
-@EXPORT = qw( %locale_aliases );
-
-## ----------------------------------------------------------------------
-## locale alias definitions
-use vars qw( %locale_aliases );
-%locale_aliases = (
-
-                  'ca'                         => 'ca_ES.ISO8859-1',
-                  'ca_ES'                      => 'ca_ES.ISO8859-1',
-                  'ca_ES.ISO8859-1'            => 'ca_ES.ISO8859-1',
-
-                  'ca_ES@euro'                 => 'ca_ES.ISO8859-15',
-                  'ca_ES.ISO8859-15'           => 'ca_ES.ISO8859-15',
-                  'ca_ES.ISO8859-15@euro'      => 'ca_ES.ISO8859-15',
-
-                  'cs'                         => 'cs_CZ.ISO8859-2',
-                  'cs_CZ'                      => 'cs_CZ.ISO8859-2',
-                  'cs_CZ.ISO8859-2'            => 'cs_CZ.ISO8859-2',
-
-                  'da'                         => 'da_DK.ISO8859-1',
-                  'da_DK'                      => 'da_DK.ISO8859-1',
-                  'da_DK.ISO8859-1'            => 'da_DK.ISO8859-1',
-
-                  'de'                         => 'de_DE.ISO8859-1',
-                  'de_DE'                      => 'de_DE.ISO8859-1',
-                  'de_DE.ISO8859-1'            => 'de_DE.ISO8859-1',
-
-                  'de_DE@euro'                 => 'de_DE.ISO8859-15',
-                  'de_DE.ISO8859-15'           => 'de_DE.ISO8859-15',
-                  'de_DE.ISO8859-15@euro'      => 'de_DE.ISO8859-15',
-
-                  'en'                         => 'en_US.ISO8859-1',
-                  'en_US'                      => 'en_US.ISO8859-1',
-                  'en_US.ISO8859-1'            => 'en_US.ISO8859-1',
-
-                  'es'                         => 'es_ES.ISO8859-1',
-                  'es_ES'                      => 'es_ES.ISO8859-1',
-                  'es_ES.ISO8859-1'            => 'es_ES.ISO8859-1',
-
-                  'es_ES@euro'                 => 'es_ES.ISO8859-15',
-                  'es_ES.ISO8859-15'           => 'es_ES.ISO8859-15',
-                  'es_ES.ISO8859-15@euro'      => 'es_ES.ISO8859-15',
-
-                  'eu'                         => 'eu_ES.ISO8859-1',
-                  'eu_ES'                      => 'eu_ES.ISO8859-1',
-                  'eu_ES.ISO8859-1'            => 'eu_ES.ISO8859-1',
-
-                  'eu_ES@euro'                 => 'eu_ES.ISO8859-15',
-                  'eu_ES.ISO8859-15'           => 'eu_ES.ISO8859-15',
-                  'eu_ES.ISO8859-15@euro'      => 'eu_ES.ISO8859-15',
-
-                  'eu_FR'                      => 'eu_FR.ISO8859-1',
-                  'eu_FR.ISO8859-1'            => 'eu_FR.ISO8859-1',
-
-                  'eu_FR@euro'                 => 'eu_FR.ISO8859-15',
-                  'eu_FR.ISO8859-15'           => 'eu_FR.ISO8859-15',
-                  'eu_FR.ISO8859-15@euro'      => 'eu_FR.ISO8859-15',
-
-                  'fi'                         => 'fi_FI.ISO8859-1',
-                  'fi_FI'                      => 'fi_FI.ISO8859-1',
-                  'fi_FI.ISO8859-1'            => 'fi_FI.ISO8859-1',
-
-                  'fi_FI@euro'                 => 'fi_FI.ISO8859-15',
-                  'fi_FI.ISO8859-15'           => 'fi_FI.ISO8859-15',
-                  'fi_FI.ISO8859-15@euro'      => 'fi_FI.ISO8859-15',
-
-                  'fr'                         => 'fr_FR.ISO8859-1',
-                  'fr_FR'                      => 'fr_FR.ISO8859-1',
-                  'fr_FR.ISO8859-1'            => 'fr_FR.ISO8859-1',
-
-                  'fr_FR@euro'                 => 'fr_FR.ISO8859-15',
-                  'fr_FR.ISO8859-15'           => 'fr_FR.ISO8859-15',
-                  'fr_FR.ISO8859-15@euro'      => 'fr_FR.ISO8859-15',
-
-                  'gl'                         => 'gl_ES.ISO8859-1',
-                  'gl_ES'                      => 'gl_ES.ISO8859-1',
-                  'gl_ES.ISO8859-1'            => 'gl_ES.ISO8859-1',
-
-                  'gl_ES@euro'                 => 'gl_ES.ISO8859-15',
-                  'gl_ES.ISO8859-15'           => 'gl_ES.ISO8859-15',
-                  'gl_ES.ISO8859-15@euro'      => 'gl_ES.ISO8859-15',
-
-                  'hr'                         => 'hr_HR.ISO8859-2',
-                  'hr_HR'                      => 'hr_HR.ISO8859-2',
-                  'hr_HR.ISO8859-2'            => 'hr_HR.ISO8859-2',
-                   'hr.UTF-8'                   => 'hr_HR.UTF-8',
-                   'hr_HR.UTF-8'                => 'hr_HR.UTF-8',
-
-                  'it'                         => 'it_IT.ISO8859-1',
-                  'it_IT'                      => 'it_IT.ISO8859-1',
-                  'it_IT.ISO8859-1'            => 'it_IT.ISO8859-1',
-
-                  'it_IT@euro'                 => 'it_IT.ISO8859-15',
-                  'it_IT.ISO8859-15'           => 'it_IT.ISO8859-15',
-                  'it_IT.ISO8859-15@euro'      => 'it_IT.ISO8859-15',
-
-                  'ja'                         => 'ja_JP.eucJP',
-                  'ja_JP'                      => 'ja_JP.eucJP',
-                  'ja_JP.eucJP'                => 'ja_JP.eucJP',
-                  'ja_JP.ujis'                 => 'ja_JP.eucJP',
-
-                  'ko'                         => 'ko_KR.eucKR',
-                  'ko_KR'                      => 'ko_KR.eucKR',
-                  'ko_KR.eucKR'                => 'ko_KR.eucKR',
-
-                  'lt'                         => 'lt_LT.ISO8859-13',
-                  'lt_LT'                      => 'lt_LT.ISO8859-13',
-                  'lt_LT.ISO8859-13'           => 'lt_LT.ISO8859-13',
-
-                  'nl'                         => 'nl_NL.ISO8859-1',
-                  'nl_NL'                      => 'nl_NL.ISO8859-1',
-                  'nl_NL.ISO8859-1'            => 'nl_NL.ISO8859-1',
-
-                  'nl_NL@euro'                 => 'nl_NL.ISO8859-15',
-                  'nl_NL.ISO8859-15'           => 'nl_NL.ISO8859-15',
-                  'nl_NL.ISO8859-15@euro'      => 'nl_NL.ISO8859-15',
-
-                  'pl'                         => 'pl_PL.ISO8859-2',
-                  'pl_PL'                      => 'pl_PL.ISO8859-2',
-                  'pl_PL.ISO8859-2'            => 'pl_PL.ISO8859-2',
-
-                  'pt'                         => 'pt_PT.ISO8859-1',
-                  'pt_BR'                      => 'pt_BR.ISO8859-1',
-                  'pt_BR.ISO8859-1'            => 'pt_BR.ISO8859-1',
-
-                  'pt_PT'                      => 'pt_PT.ISO8859-1',
-                  'pt_PT.ISO8859-1'            => 'pt_PT.ISO8859-1',
-
-                  'pt_PT@euro'                 => 'pt_PT.ISO8859-15',
-                  'pt_PT.ISO8859-15'           => 'pt_PT.ISO8859-15',
-                  'pt_PT.ISO8859-15@euro'      => 'pt_PT.ISO8859-15',
-
-                  'ro'                         => 'ro_RO.ISO8859-2',
-                  'ro_RO'                      => 'ro_RO.ISO8859-2',
-                  'ro_RO.ISO8859-2'            => 'ro_RO.ISO8859-2',
-
-                  'ru'                         => 'ru_RU.KOI8-R',
-                  'ru_RU'                      => 'ru_RU.KOI8-R',
-                  'ru_RU.KOI8-R'               => 'ru_RU.KOI8-R',
-                  'ru_RU.UTF-8'                => 'ru_RU.UTF-8',
-
-                  'sk'                         => 'sk_SK.ISO8859-2',
-                  'sk_SK'                      => 'sk_SK.ISO8859-2',
-                  'sk_SK.ISO8859-2'            => 'sk_SK.ISO8859-2',
-
-                  'sl'                         => 'sl_SI.ISO8859-2',
-                  'sl_SI'                      => 'sl_SI.ISO8859-2',
-                  'sl_SI.ISO8859-2'            => 'sl_SI.ISO8859-2',
-
-                  'sv'                         => 'sv_SE.ISO8859-1',
-                  'sv_SE'                      => 'sv_SE.ISO8859-1',
-                  'sv_SE.ISO8859-1'            => 'sv_SE.ISO8859-1',
-
-                  'tr'                         => 'tr_TR.ISO8859-9',
-                  'tr_TR'                      => 'tr_TR.ISO8859-9',
-                  'tr_TR.ISO8859-9'            => 'tr_TR.ISO8859-9',
-
-                  'uk'                         => 'uk_UA.UTF-8',
-                  'uk_UA'                      => 'uk_UA.UTF-8',
-                  'uk_UA.UTF-8'                => 'uk_UA.UTF-8',
-
-                  'vi'                         => 'vi_VN.UTF-8',
-                  'vi_VN'                      => 'vi_VN.UTF-8',
-                  'vi_VN.UTF-8'                => 'vi_VN.UTF-8',
-                  
-                  'zh_CN'                      => 'zh_CN.GB2312',
-                  'zh_CN.GB2312'               => 'zh_CN.GB2312',
-
-                  'zh_HK'                      => 'zh_TW.Big5',
-                  'zh_HK.Big5'                 => 'zh_TW.Big5',
-
-                  'zh_TW'                      => 'zh_TW.Big5',
-                  'zh_TW.Big5'                 => 'zh_TW.Big5',
-
-                  );
-
-## ----------------------------------------------------------------------
-## don't forget this
-1;
-
-## ----------------------------------------------------------------------
diff --git a/debian/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8/HTML b/debian/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8/HTML
deleted file mode 100644 (file)
index 8aa13bb..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-## -*- perl -*-
-## ----------------------------------------------------------------------
-## Locale/hr_HR.UTF-8/HTML: locale for Croatian output in HTML format
-## ----------------------------------------------------------------------
-
-## ----------------------------------------------------------------------
-%locale = (
-          'charset' => 'utf-8',
-          'abstract' => 'Sažetak',
-          'copyright notice' => 'Obavijest o autorskim pravima',
-          'contents' => 'Sadržaj',
-          'chapter' => sub { return "Glava $_[0]" },
-          'appendix' => sub { return "Dodatak $_[0]" },
-          'section' => sub { return "Poglavlje $_[0]" },
-          'subsection' => sub { return "Poglavlje $_[0]" },
-          'subsubsection' => sub { return "Poglavlje $_[0]" },
-          'paragraph' => sub { return "Poglavlje $_[0]" },
-          'subparagraph' => sub { return "Poglavlje $_[0]" },
-          'footnotes' => 'Bilješke',
-          'comments' => 'Comments',
-          'next' => 'dalje',
-          'previous' => 'natrag',
-          );
-
-## ----------------------------------------------------------------------
diff --git a/debian/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8/LaTeX b/debian/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8/LaTeX
deleted file mode 100644 (file)
index fc6126b..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-## -*- perl -*-
-## ----------------------------------------------------------------------
-## Locale/hr_HR.UTF-8/LaTeX2e: locale for Croatian output in LaTeX2e format
-## ----------------------------------------------------------------------
-
-## ----------------------------------------------------------------------
-%locale = (
-          'babel' => 'croatian',
-          'inputenc' => 'utf8x',
-          'abstract' => 'Sažetak',
-          'copyright notice' => 'Obavijest o autorskim pravima',
-          'before begin document' => '',
-          'after begin document' => '',
-          'before end document' => '',
-          'pdfhyperref' => 'unicode'
-          );
-
-## ----------------------------------------------------------------------
diff --git a/debian/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8/SGML b/debian/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8/SGML
deleted file mode 100644 (file)
index 1c01767..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-## -*- perl -*-
-## ----------------------------------------------------------------------
-## Locale/en_US.ISO8859-1/SGML: locale for ALL output in SGML format
-## ----------------------------------------------------------------------
-
-## ----------------------------------------------------------------------
-%locale = (
-          'charset' => 'iso-8859-1',
-          'abstract' => 'Abstract',
-          'copyright notice' => 'Copyright Notice',
-          'contents' => 'Contents',
-          'chapter' => sub { return "Chapter $_[0]" },
-          'appendix' => sub { return "Appendix $_[0]" },
-          'section' => sub { return "Section $_[0]" },
-          'subsection' => sub { return "Section $_[0]" },
-          'subsubsection' => sub { return "Section $_[0]" },
-          'paragraph' => sub { return "Section $_[0]" },
-          'subparagraph' => sub { return "Section $_[0]" },
-          'footnotes' => 'Footnotes',
-          'comments' => 'Comments',
-          'next' => 'next',
-          'previous' => 'previous',
-          );
-
-## ----------------------------------------------------------------------
diff --git a/debian/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8/Texinfo b/debian/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8/Texinfo
deleted file mode 100644 (file)
index f2b4885..0000000
+++ /dev/null
@@ -1,18 +0,0 @@
-## -*- perl -*-
-## ----------------------------------------------------------------------
-## Locale/hr_HR.UTF-8/Texinfo: locale for Croatian output in Texinfo format
-## ----------------------------------------------------------------------
-
-## ----------------------------------------------------------------------
-%locale = (
-          'detailed' => 'Detaljni popis čvorova',
-          'chapter' => sub { return "Glava $_[0]" },
-          'appendix' => sub { return "Dodatak $_[0]" },
-          'section' => sub { return "Poglavlje $_[0]" },
-          'subsection' => sub { return "Poglavlje $_[0]" },
-          'subsubsection' => sub { return "Poglavlje $_[0]" },
-          'paragraph' => sub { return "Poglavlje $_[0]" },
-          'subparagraph' => sub { return "Poglavlje $_[0]" },
-          );
-
-## ----------------------------------------------------------------------
diff --git a/debian/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8/Text b/debian/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8/Text
deleted file mode 100644 (file)
index cb35f81..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-## -*- perl -*-
-## ----------------------------------------------------------------------
-## Locale/hr_HR.UTF-8/Text: locale for Croatian output in plain text format
-## ----------------------------------------------------------------------
-
-## ----------------------------------------------------------------------
-%locale = (
-          'abstract' => 'Sažetak',
-          'copyright notice' => 'Obavijest o autorskim pravima',
-          'contents' => 'Sadržaj',
-          'chapter' => sub { return "Glava $_[0]" },
-          'appendix' => sub { return "Dodatak $_[0]" },
-          'section' => sub { return "Poglavlje $_[0]" },
-          'subsection' => sub { return "Poglavlje $_[0]" },
-          'subsubsection' => sub { return "Poglavlje $_[0]" },
-          'paragraph' => sub { return "Poglavlje $_[0]" },
-          'subparagraph' => sub { return "Poglavlje $_[0]" },
-          );
-
-## ----------------------------------------------------------------------
diff --git a/debian/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8/TextOV b/debian/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8/TextOV
deleted file mode 100644 (file)
index 8caafa7..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-## -*- perl -*-
-## ----------------------------------------------------------------------
-## Locale/hr_HR.UTF-8/TextOV: locale for Croatian output in overstrike text format
-## ----------------------------------------------------------------------
-
-## ----------------------------------------------------------------------
-%locale = (
-          'abstract' => 'Sažetak',
-          'copyright notice' => 'Obavijest o autorskim pravima',
-          'contents' => 'Sadržaj',
-          'chapter' => sub { return "Glava $_[0]" },
-          'appendix' => sub { return "Dodatak $_[0]" },
-          'section' => sub { return "Poglavlje $_[0]" },
-          'subsection' => sub { return "Poglavlje $_[0]" },
-          'subsubsection' => sub { return "Poglavlje $_[0]" },
-          'paragraph' => sub { return "Poglavlje $_[0]" },
-          'subparagraph' => sub { return "Poglavlje $_[0]" },
-          );
-
-## ----------------------------------------------------------------------
diff --git a/debian/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8/Wiki b/debian/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8/Wiki
deleted file mode 100644 (file)
index 04361f1..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-## -*- perl -*-
-## ----------------------------------------------------------------------
-## Locale/Wiki: locale independent (English) output in Wiki format
-## ----------------------------------------------------------------------
-
-## ----------------------------------------------------------------------
-%locale = (
-          'abstract' => 'Abstract',
-          'copyright notice' => 'Copyright Notice',
-          'contents' => 'Contents',
-          'chapter' => sub { return "Chapter $_[0]" },
-          'appendix' => sub { return "Appendix $_[0]" },
-          'section' => sub { return "Section $_[0]" },
-          'subsection' => sub { return "Section $_[0]" },
-          'subsubsection' => sub { return "Section $_[0]" },
-          'paragraph' => sub { return "Section $_[0]" },
-          'subparagraph' => sub { return "Section $_[0]" },
-          );
-
-## ----------------------------------------------------------------------
diff --git a/debian/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8/XML b/debian/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8/XML
deleted file mode 100644 (file)
index 0d802f1..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-## -*- perl -*-
-## ----------------------------------------------------------------------
-## Locale/en_US.ISO8859-1/XML: locale for ALL output in XML format
-## ----------------------------------------------------------------------
-
-## ----------------------------------------------------------------------
-%locale = (
-          'charset' => 'utf-8',
-          'abstract' => 'Abstract',
-          'copyright notice' => 'Copyright Notice',
-          'contents' => 'Contents',
-          'chapter' => sub { return "Chapter $_[0]" },
-          'appendix' => sub { return "Appendix $_[0]" },
-          'section' => sub { return "Section $_[0]" },
-          'subsection' => sub { return "Section $_[0]" },
-          'subsubsection' => sub { return "Section $_[0]" },
-          'paragraph' => sub { return "Section $_[0]" },
-          'subparagraph' => sub { return "Section $_[0]" },
-          'footnotes' => 'Footnotes',
-          'comments' => 'Comments',
-          'next' => 'next',
-          'previous' => 'previous',
-          );
-
-## ----------------------------------------------------------------------
index 2fb76e9..e827a56 100755 (executable)
@@ -9,11 +9,6 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-# check if locale is available or use a local copy
-ifeq ($(wildcard /usr/share/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8),)
-perlenv = PERL5LIB=../debian/perl5
-endif
-
 PKG_VERSION = $(shell dpkg-parsechangelog|sed -n 's/^Version: \(.*:\|\)//p')
 
 build: build-arch build-indep
@@ -28,19 +23,17 @@ build-stamp: doc/carnet-upgrade-src.sgml
                > doc/carnet-upgrade.sgml
 
        # Build txt docs
-       (cd doc; $(perlenv) debiandoc2text -l hr_HR.UTF-8 carnet-upgrade.sgml)
+       (cd doc; debiandoc2text -l hr_HR.UTF-8 carnet-upgrade.sgml)
 
        # Build one page html docs
        rm -rf doc/carnet-upgrade.html
-       (cd doc; $(perlenv) debiandoc2html -l hr_HR.UTF-8 \
-               -1 carnet-upgrade.sgml)
+       (cd doc; debiandoc2html -l hr_HR.UTF-8 -1 carnet-upgrade.sgml)
        mv doc/carnet-upgrade.html/index.html doc/index.html
        rmdir doc/carnet-upgrade.html
        mv doc/index.html doc/carnet-upgrade.html
 
        # Build pdf docs
-       (cd doc; $(perlenv) debiandoc2pdf -l hr_HR.UTF-8 \
-               -s ../debian/fix_latex carnet-upgrade.sgml)
+       (cd doc; debiandoc2pdf -l hr_HR.UTF-8 carnet-upgrade.sgml)
        rm doc/carnet-upgrade.tpt
 
        touch $@