r17: - fix monitrc in postinst, send alert mail only if !changed
authorDinko Korunic <Dinko.Korunic@CARNet.hr>
Thu, 17 Jan 2008 17:46:20 +0000 (17:46 +0000)
committerDinko Korunic <Dinko.Korunic@CARNet.hr>
Thu, 17 Jan 2008 17:46:20 +0000 (17:46 +0000)
- fix cp_sed_check for startup=1...

debian/changelog
debian/postinst
monit-cn/monitrc

index b074ff3..e288167 100644 (file)
@@ -1,3 +1,10 @@
+monit-cn (1:4.8.1-3) stable; urgency=low
+
+  * salji root@localhost mail u svim slucajevima, osim ako je servis
+    "changed", odnosno ako se PID promijenio (nocno rotiranje logova)
+
+ -- Dinko Korunic <kreator@carnet.hr>  Thu, 17 Jan 2008 17:18:08 +0100
+
 monit-cn (1:4.8.1-2) stable; urgency=low
 
   * promijeni (root|monit)@localhost u (root|monit)@fqdn u monitrc
index e5edbbb..f08d307 100755 (executable)
@@ -56,12 +56,19 @@ if grep -q '@localhost' /etc/monit/monitrc; then
         /etc/monit/monitrc || true
 fi
 
+# if alert for "changed" is enabled, disable it ASAP
+# we're waiting for "but not on { changed }" to enter in official
+# package...
+cp_check_and_sed '^set alert [^[:space:]]*@[^[:space:]]*$' \
+    's/^set alert \([^[:space:]]*@[^[:space:]]*\)$/set alert \1 only on { uid, gid, size, nonexist, data, icmp, instance, invalid, exec, timeout, resource, checksum, match, timestamp, connection, permission }/g' \
+    /etc/monit/monitrc || true
+
 # (re)generate monit.d files
 update-monit.d || true
 
 # disable monit startup
-cp_check_and_sed '^startup=1/#startup=1/g' /etc/default/monit \
-    || true
+cp_check_and_sed '^startup[[:space:]]*=[[:space:]]*1' \
+    '^startup[[:space:]]*=.*/startup=0/g' /etc/default/monit || true
 
 # systemv part
 echo "CN: Disabling monit SystemV script"
index d626e79..b18d4e9 100644 (file)
@@ -9,7 +9,7 @@ set mail-format {
     message: monit $ACTION $SERVICE at $DATE on $HOST
     }
 set mailserver 127.0.0.1
-set alert root@localhost
+set alert root@localhost but not on { changed }
 
 #set httpd port 2812 and use address 127.0.0.1
 #allow localhost