lintian izmjene, plus zastarjele opcije squeeze debian/2%5.1.49.2
authorIvan Rako <irako@nekkar.carnet.hr>
Fri, 27 Apr 2012 15:36:42 +0000 (17:36 +0200)
committerIvan Rako <irako@nekkar.carnet.hr>
Fri, 27 Apr 2012 15:36:42 +0000 (17:36 +0200)
debian/changelog
debian/compat
debian/control
debian/postinst

index bdfad2d..8f9ae61 100644 (file)
@@ -1,3 +1,10 @@
+mysql-cn (2:5.1.49.2) stable; urgency=low
+
+  * Izmjene za lintian
+  * Iskljuceje zastarjele opcije skip-bdb i skip-networking
+
+ -- Ivan Rako <Ivan.Rako@CARNet.hr>  Fri, 27 Apr 2012 17:31:40 +0200
+
 mysql-cn (2:5.1.49-1) stable; urgency=low
 
   * Prva verzija za squeeze
index b8626c4..45a4fb7 100644 (file)
@@ -1 +1 @@
-4
+8
index 0980120..d3fb648 100644 (file)
@@ -2,12 +2,12 @@ Source: mysql-cn
 Section: net
 Priority: optional
 Maintainer: Ivan Rako <Ivan.Rako@CARNet.hr>
-Build-Depends: debhelper (>= 4.0.0)
-Standards-Version: 3.6.1
+Build-Depends: debhelper (>= 8)
+Standards-Version: 3.9.1
 
 Package: mysql-cn
 Architecture: all
-Depends: mysql-client-5.1 (>= 5.1.49), mysql-server-5.1 (>= 5.1.49), makepasswd, carnet-tools-cn (>= 2.4)
+Depends: mysql-client-5.1 (>= 5.1.49), mysql-server-5.1 (>= 5.1.49), makepasswd, carnet-tools-cn (>= 2.4), ${misc:Depends}
 Description: MySQL database server
  MySQL is a fast, stable and true multi-user, multi-threaded SQL database
  server. SQL (Structured Query Language) is the most popular database query
index 8cf13b8..e959c3d 100755 (executable)
@@ -11,7 +11,7 @@ PKG="mysql-cn"
 . /usr/share/carnet-tools/functions.sh
 
 if [ -f /etc/mysql/my.cnf ]; then
-  # ukljuci networking, da mysql visi na portu 3306
+  # iskljuci zastarjelu opciju
   cp_check_and_sed '^skip-networking' \
                    's/^skip-networking$/#skip-networking/' \
                    /etc/mysql/my.cnf && restart=yes || true
@@ -25,6 +25,11 @@ if [ -f /etc/mysql/my.cnf ]; then
   cp_check_and_sed '^log.*mysql.log' \
                    "s,^\([\t ]*log[\t ]*=\),#\1," \
                    /etc/mysql/my.cnf && restart=yes || true
+
+  # iskljuci zastarjeli skip-bdb
+  cp_check_and_sed '^skip-bdb' \
+                   's/^skip-bdb$/#skip-bdb/' \
+                   /etc/mysql/my.cnf && restart=yes || true
 fi
 
 # pristup samo sa lokalne mreze, preko tcp-wrappera...
@@ -62,3 +67,5 @@ if [ -x /usr/sbin/invoke-rc.d ]; then
 else
   [ -x /etc/init.d/mysql ] && /etc/init.d/mysql restart
 fi
+
+#DEBHELPER#