novi debian/rules i novi debian/copyright
[ntp-cn.git] / debian / postinst
index 0f3ecb6..58fa1da 100755 (executable)
@@ -1,5 +1,7 @@
 #!/bin/sh
 
+set -e
+
 [ "$1" = "configure" ] || exit 0
 [ "$DEBIAN_SCRIPT_DEBUG" ] && set -vx
 
@@ -12,14 +14,14 @@ konfiguriraj() {
     cp -p /etc/default/ntp-servers /etc/default/ntp-servers.dpkg-old
   fi
 
-  cp /usr/share/doc/ntp-cn/ntp.conf.tmpl /etc
+  cp /usr/share/doc/ntp-cn/ntp.conf.tmpl /etc/ntp.conf
 
   # Load CARNet Tools
   . /usr/share/carnet-tools/functions.sh
 
   cp_check_and_sed 'NTPSERVERS' \
                    "s/^.*NTPSERVERS.*/NTPSERVERS=\"zg1.ntp.carnet.hr ri.ntp.carnet.hr zg2.ntp.carnet.hr st.ntp.carnet.hr os.ntp.carnet.hr 127.127.1.0\"/g" \
-                   /etc/default/ntpservers || true
+                   /etc/default/ntpdate || true
 }
 
 if [ -f /usr/share/doc/ntp-cn/ntp.conf.tmpl -a -f /etc/ntp.conf ]; then