- #10234: debian/rules clean
[ossec-hids.git] / debian / rules
index d22c464..415895d 100755 (executable)
@@ -30,6 +30,14 @@ clean:
        # Add here commands to clean up after the build process.
        $(MAKE) -C $(SRCDIR) clean
 
+       # additional clean
+       rm -f $(SRCDIR)/Config.OS \
+               $(SRCDIR)/analysisd/compiled_rules/compiled_rules.h \
+               $(SRCDIR)/analysisd/ossec-logtest \
+               $(SRCDIR)/isbigendian \
+               $(SRCDIR)/isbigendian.c \
+       rm -rf $(CURDIR)/bin
+
        dh_clean
 
 install: build
@@ -73,8 +81,9 @@ install: build
        fi
        install -m 440 etc/ossec-*.conf $(DESTDIR)/etc
        cp -r etc/rules/* $(DESTDIR)/rules
+       find $(DESTDIR)/rules -type f -exec chmod 640 '{}' ';'
        install -m 750 src/agentlessd/scripts/* $(DESTDIR)/agentless
-       install -m 755 bin/* $(DESTDIR)/bin
+       install -s -m 755 bin/* $(DESTDIR)/bin
        install -m 755 src/init/ossec-*.sh $(DESTDIR)/bin
        ln -s ossec-local.sh $(DESTDIR)/bin/ossec-control
        install -m 755 active-response/*.sh $(DESTDIR)/active-response/bin