- patchevi od Valentina Vidica:
[ossec-hids.git] / debian / rules
index f1b0e62..db885c7 100755 (executable)
@@ -55,8 +55,8 @@ install: build
        install -m 644 etc/internal_options.conf $(DESTDIR)/etc
        install -m 644 etc/decoder.xml $(DESTDIR)/etc
        install -m 644 src/rootcheck/db/*.txt $(DESTDIR)/etc/shared
-       if [ -e etc/ossec.mc ]; then \
-               install -m 440 etc/ossec.mc $(DESTDIR)/etc/ossec.conf; \
+       if [ -e ossec-debian.conf ]; then \
+               install -m 440 ossec-debian.conf $(DESTDIR)/etc/ossec.conf; \
        else \
                install -m 440 etc/ossec-local.conf $(DESTDIR)/etc/ossec.conf; \
        fi
@@ -110,7 +110,7 @@ install: build
        # system ossec-init
        echo "DIRECTORY=\"/var/ossec\""      >  $(PKGDIR)/etc/ossec-init.conf
        echo "VERSION=\"`cat src/VERSION`\"" >> $(PKGDIR)/etc/ossec-init.conf
-       echo "DATE=\"`date --utc`\""         >> $(PKGDIR)/etc/ossec-init.conf
+       echo "DATE=\"$(date --utc -d "$(dpkg-parsechangelog | sed -ne 's/Date: //p')")\""       >> $(PKGDIR)/etc/ossec-init.conf
        echo "TYPE=\"local\""                >> $(PKGDIR)/etc/ossec-init.conf
 
 # Build architecture-independent files here.