Merge commit 'v2.5.1'
[ossec-hids.git] / src / Makefile
index e971e17..976c594 100755 (executable)
@@ -12,9 +12,12 @@ none:
                @echo "\"make clean\" to clean anything built."
                @echo "\"make setagent\" to set agent install."
                @echo "\"make setlocal\" to set local install."
+               @echo "\"make setclang\" to use clang for building ossec."
+               @echo "\"make unsetclang\" to use gcc for building ossec."
                @echo "\"make setprelude\" to enable prelude output."
                @echo "\"make setdb\" to enable database support."
                @echo "\"make unsetdb\" to disable database support."
+               @echo "\"make setoneway\" to enable one-way connection to the manager."
 
 clean:
                @/bin/sh ./Makeall clean
@@ -42,6 +45,12 @@ agent:
 setagent:
                @echo "CEXTRA=-DCLIENT" >> ./Config.OS
 
+setclang:
+               @sed -i '' -e "s/^CC=.*/CC=clang/g" LOCATION
+
+unsetclang:
+               @sed -i '' -e "s/^CC=.*/CC=gcc/g" LOCATION
+
 setprelude:
                @echo "CPRELUDE=-DPRELUDE -lprelude `libprelude-config --pthread-cflags` `libprelude-config --libs`" >> ./Config.OS
         
@@ -56,3 +65,5 @@ setlocal:
 
 setfullsubject:
                @echo "FEXTRA=-DCLEANFULL" >> ./Config.OS
+setoneway:
+               @echo "FEXTRA=-DONEWAY" >> ./Config.OS