- #19996: popravljeni bugovi iz lintian reporta (Valentin Vidic) v2.5.1-2
authorDinko Korunic <kreator@carnet.hr>
Mon, 21 Mar 2011 11:48:12 +0000 (12:48 +0100)
committerDinko Korunic <kreator@carnet.hr>
Mon, 21 Mar 2011 11:48:12 +0000 (12:48 +0100)
debian/changelog
debian/compat
debian/control
debian/rules

index 849b74a..a28698c 100644 (file)
@@ -1,3 +1,9 @@
+ossec-hids (2.5.1-2) stable; urgency=low
+
+  * #19996: popravljeni bugovi iz lintian reporta (Valentin Vidic)
+
+ -- Dinko Korunic <kreator@carnet.hr>  Mon, 21 Mar 2011 12:43:23 +0100
+
 ossec-hids (2.5.1-1) stable; urgency=low
 
   * new upstream release (2.5.1)
index b8626c4..7f8f011 100644 (file)
@@ -1 +1 @@
-4
+7
index a04e4bd..4af5ace 100644 (file)
@@ -2,12 +2,13 @@ Source: ossec-hids
 Section: admin
 Priority: extra
 Maintainer: Dinko Korunic <kreator@carnet.hr>
-Build-Depends: debhelper (>= 4)
-Standards-Version: 3.8.0
+Build-Depends: debhelper (>= 7)
+Standards-Version: 3.9.1
 
 Package: ossec-hids
 Architecture: any
-Depends: postfix | mail-transport-agent, expect (>= 5.43.0-17), adduser (>= 3.110), libc6 (>= 2.7-18lenny2)
+Depends: postfix | mail-transport-agent, expect (>= 5.43.0-17), 
+ adduser (>= 3.110), ${misc:Depends}, ${shlibs:Depends}
 Priority: extra
 Section: admin
 Description: OSSEC HIDS
index 6150881..4e01349 100755 (executable)
@@ -44,7 +44,7 @@ clean:
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        dh_installdirs
 
        # ugly directory creation
@@ -94,7 +94,7 @@ install: build
        chmod 550 $(DESTDIR)/bin/*
        chmod 440 $(DESTDIR)/etc/ossec.conf
 
-    # fixups: no need for execute bits on files there
+       # fixups: no need for execute bits on files there
        find $(DESTDIR)/rules -type f -exec chmod ugo-x '{}' ';'
        find $(DESTDIR)/etc -type f -exec chmod ugo-x '{}' ';'
 
@@ -116,6 +116,10 @@ install: build
 
 # Build architecture-independent files here.
 binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
        dh_testdir
        dh_testroot
        dh_installchangelogs
@@ -139,13 +143,10 @@ binary-indep: build install
 #      dh_perl
 #      dh_python
        dh_installdeb
+       dh_shlibdeps
        dh_gencontrol
        dh_md5sums
        dh_builddeb
 
-# Build architecture-dependent files here.
-binary-arch: build install
-# We have nothing to do by default.
-
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary install