ovisnost o alpine, sredjuje alternatives, itd...
authorIvan Rako <irako@bagan.srce.hr>
Tue, 29 Apr 2008 13:48:28 +0000 (15:48 +0200)
committerIvan Rako <irako@bagan.srce.hr>
Tue, 29 Apr 2008 13:48:28 +0000 (15:48 +0200)
README.CARNet
debian/changelog
debian/control
debian/postinst
debian/prerm

index a63a54b..aca5187 100644 (file)
@@ -1,9 +1,8 @@
 pine-cn
 ~~~~~~~
 
-Ovaj paket donosi dodatnu konfiguraciju za pine paket pripremljen iz Debian
-source paketa, i povlaci instalaciju "nano" paketa, editora vrlo slicnog
-pico, ali je za razliku od njega dio standardne Debian distribucije.
+Ovaj paket povlaci instalaciju paketa "alpine", zamjene za paket "pine"
+koji zbog svoje licence nije standardni dio Debian distribucije.
 
  -- Zoran Dzelajlija <jelly+paketi@srce.hr>  Tue, 21 Oct 2003 21:40:37 +0200
- -- Ivan Rako <Ivan.Rako@CARNet.hr>  Tue, 30 Oct 2007 00:53:45 +0100
+ -- Ivan Rako <Ivan.Rako@CARNet.hr>  Sun, 27 Jan 2008 15:12:40 +0100
index 5874f5d..42d944e 100644 (file)
@@ -1,3 +1,10 @@
+pine-cn (3:1.0) stable; urgency=low
+
+  * Paket povlaci paket alpine, koji je zamjena za pine
+  * Dodaje u /etc/pine.conf direktivu smtp-server=localhost, ako ne postoji
+
+ -- Ivan Rako <Ivan.Rako@CARNet.hr>  Sun, 27 Jan 2008 15:14:04 +0100
+
 pine-cn (2:4.64-1) stable; urgency=low
 
   * Prva verzija za Etch
index bf2ef22..f2485a3 100644 (file)
@@ -7,19 +7,15 @@ Standards-Version: 3.6.1
 
 Package: pine-cn
 Architecture: all
-Depends: pine (>= 4.64), nano
-Provides: mail-reader
-Description: An e-mail reader with MIME and IMAP support
- Pine is a mail-user-agent that provides features for viewing e-mail.
+Depends: alpine (>= 1.0), alpine-pico (>= 1.0)
+Conflicts: pine
+Provides: mail-reader, alpine-cn
+Description: Text-based email client, friendly for novices but powerful
+ Alpine is an upgrade of the well-known PINE email client.  Alpine is currently
+ in alpha.  Its name derives from the use of the Apache License and its ties to
+ PINE.
  .
- Some form of mail-transport-agent is desirable for obtaining mail. However
- fetchmail is sufficient in some cases to deal with the delivery. There are
- several mail-transport-agents available, including smail, sendmail and others.
+ It features a full suite of support for mail protocols like IMAP and SMTP and
+ security protocols like TLS.  It uses curses for its interface.
  .
- Pine needs no mail-transport-agent for sending mail, as it provides SMTP for
- this purpose.
- .
- In addition to mail viewing, Pine provides features for viewing and creating
- news group postings.
- .
- This is a metapackage depending on pine and nano packages.
+ This is a metapackage depending on alpine and alpine-pine packages.
index e653912..68fa9f1 100755 (executable)
@@ -1,6 +1,16 @@
 #!/bin/sh -e
 
 if [ "$1" = "configure" ]; then
-  update-alternatives --install /usr/bin/pico pico /usr/bin/nano 50 \
-    --slave /usr/share/man/man1/pico.1.gz pico.1.gz /usr/share/man/man1/nano.1.gz
+  update-alternatives --install /usr/bin/pine pine /usr/bin/alpine 50 \
+    --slave /usr/share/man/man1/pine.1.gz pine.1.gz /usr/share/man/man1/alpine.1.gz
+fi
+
+if [ ! -f /etc/pine.conf ]; then
+  echo "CN: Creating configuration file /etc/pine.conf..."
+  touch /etc/pine.conf
+fi
+
+if ! grep -q ^smtp-server /etc/pine.conf; then
+  echo "CN: Adding smtp-server to /etc/pine.conf..."
+  echo smtp-server=localhost >> /etc/pine.conf
 fi
index 13a1b1c..64c0256 100755 (executable)
@@ -1,5 +1,5 @@
 #!/bin/sh -e
 
 if [ "$1" != "upgrade" ]; then
-  update-alternatives --remove pico /usr/bin/nano
+  update-alternatives --remove pine /usr/bin/alpine
 fi