novi debian/rules i novi debian/copyright
[postfix-cn.git] / debian / postinst
index 80c04dc..110ec6c 100755 (executable)
@@ -274,22 +274,18 @@ $fqdn
 root@$mailname
 +
   ln -sf "$cert.pem" `openssl x509 -noout -hash < "$cert.pem"`.0
-  chown root.root "/etc/ssl/certs/$cert.pem"
+  chown root:root "/etc/ssl/certs/$cert.pem"
   chmod 0640 "/etc/ssl/certs/$cert.pem"
 fi
 
 # TLS stuff
 postconf -e smtp_use_tls="yes"
-postconf -e smtp_tls_key_file="\$smtp_tls_cert_file"
 postconf -e smtp_tls_session_cache_database="sdbm:/var/lib/postfix/smtp_scache"
 postconf -e smtp_tls_session_cache_timeout="3600s"
 postconf -e smtpd_use_tls="yes"
-postconf -e smtpd_tls_key_file="\$smtpd_tls_cert_file"
 postconf -e smtpd_tls_session_cache_database="sdbm:/var/lib/postfix/smtpd_scache"
 postconf -e smtpd_tls_session_cache_timeout="3600s"
 postconf -e tls_random_source="dev:/dev/urandom"
-postconf -e smtpd_tls_mandatory_protocols="SSLv3, TLSv1"
-postconf -e smtpd_tls_mandatory_ciphers="medium, high"
 postconf -e smtpd_tls_exclude_ciphers="aNULL"
 postconf -e smtpd_tls_mandatory_exclude_ciphers="aNULL"
 # ako je postavljen neki drugi certifikat, ne diraj
@@ -301,6 +297,14 @@ smtpd_tls_cert_file="`postconf -h smtpd_tls_cert_file`"
 if [ -z "$smtpd_tls_cert_file" ]; then
   postconf -e smtpd_tls_cert_file="/etc/ssl/certs/$cert.pem"
 fi
+smtp_tls_key_file="`postconf -h smtp_tls_key_file`"
+if [ -z "$smtp_tls_key_file" ]; then
+  postconf -e smtp_tls_key_file="\$smtp_tls_cert_file"
+fi
+smtpd_tls_key_file="`postconf -h smtpd_tls_key_file`"
+if [ -z "$smtpd_tls_key_file" ]; then
+  postconf -e smtpd_tls_key_file="\$smtpd_tls_cert_file"
+fi
 
 # prije bilo u /etc/postfix/, od verzije 2.1.5-2 je u /var/spool/postfix
 [ -f /etc/postfix/smtp_scache.dir ] && rm -f /etc/postfix/smtp_scache.dir