novi debian/rules i novi debian/copyright
[postfix-cn.git] / debian / postinst
index eab468e..110ec6c 100755 (executable)
@@ -81,14 +81,17 @@ postconf -e mynetworks="$mynetworks"
 
 # obrisati $mydomain, ako je upgrade sa starije verzije
 # te srediti mydestination
-if dpkg --compare-versions "$2" lt 2.3.8-1; then
+if dpkg --compare-versions "$2" lt 2.3.8-2; then
   mydestination="`postconf -h mydestination`"
   if echo $mydestination | grep -q ", \$mydomain"; then
     mydestination="`echo $mydestination | sed 's/, \$mydomain//g'`"
   fi
-  if echo $mydestination | grep -q "localhost.\$mydomain"; then
+  if ! echo $mydestination | grep -q "localhost.\$mydomain"; then
     mydestination="$mydestination, localhost.\$mydomain"
   fi
+  if ! echo $mydestination | grep -q "\$myhostname"; then
+    mydestination="\$myhostname, $mydestination"
+  fi
   postconf -e mydestination="$mydestination"
 fi
 
@@ -168,8 +171,8 @@ if [ "$rbl" ]; then
   done
 fi
 
-# dodaj check_policy_service i permit na kraj
-smtpd_recipient_restrictions="$smtpd_recipient_restrictions, check_policy_service inet:127.0.0.1:60000, permit"
+# dodaj permit na kraj
+smtpd_recipient_restrictions="$smtpd_recipient_restrictions, permit"
 postconf -e smtpd_recipient_restrictions="$smtpd_recipient_restrictions"
 
 # SASL stuff
@@ -271,20 +274,20 @@ $fqdn
 root@$mailname
 +
   ln -sf "$cert.pem" `openssl x509 -noout -hash < "$cert.pem"`.0
-  chown root.root "/etc/ssl/certs/$cert.pem"
+  chown root:root "/etc/ssl/certs/$cert.pem"
   chmod 0640 "/etc/ssl/certs/$cert.pem"
 fi
 
 # TLS stuff
 postconf -e smtp_use_tls="yes"
-postconf -e smtp_tls_key_file="\$smtp_tls_cert_file"
-postconf -e smtp_tls_session_cache_database="sdbm:/var/spool/postfix/smtp_scache"
+postconf -e smtp_tls_session_cache_database="sdbm:/var/lib/postfix/smtp_scache"
 postconf -e smtp_tls_session_cache_timeout="3600s"
 postconf -e smtpd_use_tls="yes"
-postconf -e smtpd_tls_key_file="\$smtpd_tls_cert_file"
-postconf -e smtpd_tls_session_cache_database="sdbm:/var/spool/postfix/smtpd_scache"
+postconf -e smtpd_tls_session_cache_database="sdbm:/var/lib/postfix/smtpd_scache"
 postconf -e smtpd_tls_session_cache_timeout="3600s"
 postconf -e tls_random_source="dev:/dev/urandom"
+postconf -e smtpd_tls_exclude_ciphers="aNULL"
+postconf -e smtpd_tls_mandatory_exclude_ciphers="aNULL"
 # ako je postavljen neki drugi certifikat, ne diraj
 smtp_tls_cert_file="`postconf -h smtp_tls_cert_file`"
 if [ -z "$smtp_tls_cert_file" ]; then
@@ -294,12 +297,25 @@ smtpd_tls_cert_file="`postconf -h smtpd_tls_cert_file`"
 if [ -z "$smtpd_tls_cert_file" ]; then
   postconf -e smtpd_tls_cert_file="/etc/ssl/certs/$cert.pem"
 fi
+smtp_tls_key_file="`postconf -h smtp_tls_key_file`"
+if [ -z "$smtp_tls_key_file" ]; then
+  postconf -e smtp_tls_key_file="\$smtp_tls_cert_file"
+fi
+smtpd_tls_key_file="`postconf -h smtpd_tls_key_file`"
+if [ -z "$smtpd_tls_key_file" ]; then
+  postconf -e smtpd_tls_key_file="\$smtpd_tls_cert_file"
+fi
 
 # prije bilo u /etc/postfix/, od verzije 2.1.5-2 je u /var/spool/postfix
 [ -f /etc/postfix/smtp_scache.dir ] && rm -f /etc/postfix/smtp_scache.dir
 [ -f /etc/postfix/smtp_scache.pag ] && rm -f /etc/postfix/smtp_scache.pag
 [ -f /etc/postfix/smtpd_scache.dir ] && rm -f /etc/postfix/smtpd_scache.dir
 [ -f /etc/postfix/smtpd_scache.pag ] && rm -f /etc/postfix/smtpd_scache.pag
+# prije bilo u /var/spool/postfix/, od verzije 2.5.5 je u /var/lib/postfix
+[ -f /var/spool/postfix/smtp_scache.dir ] && rm -f /var/spool/postfix/smtp_scache.dir
+[ -f /var/spool/postfix/smtp_scache.pag ] && rm -f /var/spool/postfix/smtp_scache.pag
+[ -f /var/spool/postfix/smtpd_scache.dir ] && rm -f /var/spool/postfix/smtpd_scache.dir
+[ -f /var/spool/postfix/smtpd_scache.pag ] && rm -f /var/spool/postfix/smtpd_scache.pag
 
 # debconf stop
 db_go || true
@@ -348,6 +364,12 @@ if ! cmp -s /etc/postfix/main.cf /etc/postfix/main.cf.dpkg-tmp.$$; then
 fi
 rm -f /etc/postfix/main.cf.dpkg-tmp.$$
 
+if ! grep -q "retry     unix  -       -       -       -       -       error" /etc/postfix/master.cf; then
+  echo "CN: Please, add this line in /etc/postfix/master.cf and restart Postfix."
+  echo "retry     unix  -       -       -       -       -       error"
+  echo
+fi
+
 # kreiraj aliases_gecos
 if [ -x /usr/share/postfix-cn/make-aliases-gecos.sh ]; then
   if [ "$matchgecos" = "true" ]; then