dodavanje ipv6 localhost adrese u mynetworks
authorIvan Rako <irako@nekkar.carnet.hr>
Fri, 20 Dec 2013 12:12:52 +0000 (13:12 +0100)
committerIvan Rako <irako@nekkar.carnet.hr>
Fri, 20 Dec 2013 12:12:52 +0000 (13:12 +0100)
debian/changelog
debian/postinst

index ab58e66..a39e70f 100644 (file)
@@ -1,3 +1,9 @@
+postfix-cn (2.9.6~cn1) stable; urgency=medium
+
+  * Dodavanje IPv6 localhost adrese u mynetworks
+
+ -- Ivan Rako <Ivan.Rako@CARNet.hr>  Fri, 20 Dec 2013 13:12:29 +0100
+
 postfix-cn (2.9.6~cn0) stable; urgency=medium
 
   * Prva verzija za wheezy
index fe02c15..f59a5df 100755 (executable)
@@ -81,9 +81,9 @@ postconf -e myorigin="$mailname"
 postconf -e append_dot_mydomain="yes"
 postconf -e append_at_myorigin="yes"
 
-# dodaj 127.0.0.0/8 i netaddr
+# dodaj 127.0.0.0/8, netaddr i ipv6-localhost
 mynetworks="`postconf -h mynetworks`"
-for i in "127.0.0.0/8" "$netaddr"; do
+for i in "127.0.0.0/8" "$netaddr" "[::1]/128"; do
   if ! echo $mynetworks | grep -q $i; then
    mynetworks="$mynetworks, $i"
   fi