neke izmjene za SASL
authorIvan Rako <irako@nekkar.carnet.hr>
Sat, 11 Jun 2011 11:30:01 +0000 (13:30 +0200)
committerIvan Rako <irako@nekkar.carnet.hr>
Sat, 11 Jun 2011 11:30:01 +0000 (13:30 +0200)
debian/changelog
debian/postinst

index fe2e1f4..99f6029 100644 (file)
@@ -1,6 +1,7 @@
 postfix-cn (2.7.1-1) stable; urgency=medium
 
   * Prva verzija za squeeze
+  * Izmjene za SASL (drugacije opcije u /etc/default/saslauthd)
 
  -- Ivan Rako <Ivan.Rako@CARNet.hr>  Wed, 13 Apr 2011 15:08:39 +0200
 
index 110ec6c..8b4eb47 100755 (executable)
@@ -60,7 +60,7 @@ if [ -f /etc/postfix/master.cf ]; then
                    /etc/postfix/master.cf || true
 fi
 
-# ovo  manje/vise uzima kao default, ali u slucaju da je multihomed stroj,
+# ovo manje/vise uzima kao default, ali u slucaju da je multihomed stroj,
 # i eventualno je sprckan, mozda nesto nece raditi kako spada pa cemo konfigurirati
 postconf -e myhostname="$fqdn"
 postconf -e mydomain="$domain"
@@ -107,10 +107,10 @@ if [ "$mx_domain" != "$fqdn" ]; then
   postconf -e relay_domains="\$mydestination"
   if [ "$mx_domain" != "$domain" ]; then
     if dpkg --compare-versions "$2" lt 2.1.5-8; then
-      cp_echo "CN: This host is MX for more than one domain!  postfix-cn package will"
-      cp_echo "CN  only set up $mx_domain, you HAVE TO add the other domains manually"
-      cp_echo "CN  to mydestination variable in /etc/postfix/main.cf, if you haven't"
-      cp_echo "CN  done that already or you may lose mail."
+      cp_echo "CN: This host is MX for more than one domain! postfix-cn package will"
+      cp_echo "CN: only set up $mx_domain, you HAVE TO add the other domains manually"
+      cp_echo "CN: to mydestination variable in /etc/postfix/main.cf, if you haven't"
+      cp_echo "CN: done that already or you may lose mail."
     fi
   fi
 fi
@@ -203,22 +203,17 @@ if [ -f /etc/default/saslauthd ]; then
     echo "START=yes" >> /etc/default/saslauthd
     restart_saslauthd="yes"
   fi
-  if ! grep -q "^PARAMS.*/var/spool/postfix/var/run/saslauthd" /etc/default/saslauthd; then
-    echo "PARAMS=\"-m /var/spool/postfix/var/run/saslauthd\"" >> /etc/default/saslauthd
-    restart_saslauthd="yes"
-  fi
-  if ! grep -q "^PIDFILE.*/var/spool/postfix/var/run/saslauthd/saslauthd.pid" /etc/default/saslauthd; then
-    echo "PIDFILE=\"/var/spool/postfix/var/run/saslauthd/saslauthd.pid\"" >> /etc/default/saslauthd
-    restart_saslauthd="yes"
-  fi
-  if ! grep -q "^PWDIR.*/var/spool/postfix/var/run/saslauthd" /etc/default/saslauthd; then
-    echo "PWDIR=\"/var/spool/postfix/var/run/saslauthd\"" >> /etc/default/saslauthd
+
+  if ! grep -q "^OPTIONS.*/var/spool/postfix/var/run/saslauthd" /etc/default/saslauthd; then
+    echo "OPTIONS=\"-c -m /var/spool/postfix/var/run/saslauthd\"" >> /etc/default/saslauthd
     restart_saslauthd="yes"
   fi
+
   if ! grep -q "&& ln -s" /etc/default/saslauthd; then
     echo "[ ! -L /var/run/saslauthd -a -d /var/spool/postfix/var/run/saslauthd -a ! -d /var/run/saslauthd ] && ln -s /var/spool/postfix/var/run/saslauthd /var/run/saslauthd || true" >> /etc/default/saslauthd
     restart_saslauthd="yes"
   fi
+
   if [ ! -L /var/run/saslauthd ]; then
     mkdir -p /var/spool/postfix/var/run/
     if [ -d /var/run/saslauthd -a ! -d /var/spool/postfix/var/run/saslauthd ]; then
@@ -226,18 +221,18 @@ if [ -f /etc/default/saslauthd ]; then
     elif [ -d /var/run/saslauthd -a -d /var/spool/postfix/var/run/saslauthd ]; then
       rm -rf /var/run/saslauthd/
     fi
-
     # XXX jos kad bi ln -s u /var/run/ radio (bootclean.sh)
     if [ -d /var/spool/postfix/var/run/saslauthd -a ! -d /var/run/saslauthd ]; then
       ln -s /var/spool/postfix/var/run/saslauthd /var/run/saslauthd
     fi
-
     restart_saslauthd="yes"
   fi
+
   if [ ! -d /var/spool/postfix/var/run/saslauthd ]; then
     mkdir -p /var/spool/postfix/var/run/saslauthd
     restart_saslauthd="yes"
   fi
+
   if ! dpkg-statoverride --list /var/spool/postfix/var/run/saslauthd > /dev/null; then
     dpkg-statoverride --update --add root sasl 710 /var/spool/postfix/var/run/saslauthd
   fi