r3: - noninteractive ssl cert create etch
authorDinko Korunic <Dinko.Korunic@CARNet.hr>
Wed, 31 Oct 2007 17:21:40 +0000 (17:21 +0000)
committerDinko Korunic <Dinko.Korunic@CARNet.hr>
Wed, 31 Oct 2007 17:21:40 +0000 (17:21 +0000)
debian/changelog
debian/postinst

index 6ee69a6..59e1d93 100644 (file)
@@ -1,6 +1,7 @@
 proftpd-cn (2:1.3.0-3) stable; urgency=low
 
   * popravljen debconf problem sa interaktivnom skriptom (openssl)
+  * slozeno neinteraktivno generiranje SSL certifikata
 
  -- Dinko Korunic <kreator@carnet.hr>  Wed, 31 Oct 2007 15:14:01 +0100
 
index 988e081..955e496 100755 (executable)
@@ -138,7 +138,19 @@ make_ssl_cert()
     if [ ! -f $SSL_CERT ] ; then
         cd $(dirname $SSL_CERT)
         echo "CN: Generating SSL certificate ... "
-        openssl req -new -x509 -days 365 -nodes -out $(basename $SSL_CERT) -keyout $(basename $SSL_KEY)
+        HOSTNAME=`hostname -s`
+        FQDN=`hostname -f`
+        MAILNAME=`cat /etc/mailname 2> /dev/null || hostname -f`
+        (openssl req -new -x509 -days 365 -nodes -out $(basename $SSL_CERT) -keyout $(basename $SSL_KEY) >/dev/null 2>&1 <<EOF
+.
+.
+.
+FTP server
+$hostname.$domainname
+$fqdn
+root@$mailname
+EOF
+)
         echo "CN: Self-signed SSL certificate generated in $SSL_CERT."
         echo "CN: Please note that the certificate will expire in one year."
     fi