novi debian/rules i novi debian/copyright
[samba-cn.git] / debian / postinst
index eeb7068..1ea1c59 100755 (executable)
@@ -1,42 +1,31 @@
-#!/bin/sh
+#!/bin/sh -e
 
 [ "$1" = "configure" ] || exit 0
+[ "$DEBIAN_SCRIPT_DEBUG" ] && set -vx
 
-konfiguriraj() {
-  if [ -f /etc/ntp.conf ]; then
-    cp -p /etc/ntp.conf /etc/ntp.conf.dpkg-old
-  fi
+# Load CARNet Tools
+. /usr/share/carnet-tools/functions.sh
 
-  if [ -f /etc/default/ntp-servers ]; then
-    cp -p /etc/default/ntp-servers /etc/default/ntp-servers.dpkg-old
-  fi
+cp_check_and_sed '#[[:space:]]*security = user' \
+                 's/#[[:space:]]*security = user/   security = user/g' \
+                /etc/samba/smb.conf || true
 
-  cp /usr/share/doc/ntp-cn/ntp.conf.tmpl /etc
+cp_check_and_sed ';[[:space:]]*security = user' \
+                 's/;[[:space:]]*security = user/   security = user/g' \
+                /etc/samba/smb.conf || true
 
-  cat > /etc/default/ntp-servers <<EOF
-NTPSERVERS="zg1.ntp.carnet.hr ri.ntp.carnet.hr zg2.ntp.carnet.hr 127.127.1.0"
-EOF
-}
-
-if [ -f /usr/share/doc/ntp-cn/ntp.conf.tmpl -a -f /etc/ntp.conf ]; then
-  if ! cmp -s /usr/share/doc/ntp-cn/ntp.conf.tmpl /etc/ntp.conf; then
-    konfiguriraj
-  fi
+cp_get_netaddr || true
+net="$RET"
+if ! grep -q '^[[:space:]]*hosts allow' /etc/samba/smb.conf; then
+        echo "   hosts allow = $net 127.0.0.1" >> /etc/samba/smb.conf
+fi
+if ! grep -q '^[[:space:]]*hosts deny' /etc/samba/smb.conf; then
+        echo "   hosts deny = ALL" >> /etc/samba/smb.conf
 fi
 
-# restartaj sve
-if [ -x /etc/init.d/ntp ]; then
-  if [ -x /usr/sbin/invoke-rc.d ]; then
-    invoke-rc.d ntp stop
-    for i in 1 2 3 4 5 6 7 8 9 0; do
-      pgrep -u root -f /usr/sbin/ntpd >/dev/null && sleep 1 || break
-    done
-    invoke-rc.d ntp start
-  else
-    /etc/init.d/ntp stop
-    for i in 1 2 3 4 5 6 7 8 9 0; do
-      pgrep -u root -f /usr/sbin/ntpd >/dev/null && sleep 1 || break
-    done
-    /etc/init.d/ntp start
-  fi
+# restart 
+if [ -x /usr/sbin/invoke-rc.d ]; then
+  [ -x /etc/init.d/samba ] && invoke-rc.d samba restart
+else
+  [ -x /etc/init.d/samba ] && /etc/init.d/samba restart
 fi