* depends o novoj inacici SpamAssassin paketa (backportana iz Lennyja,
authorDinko Korunic <kreator@carnet.hr>
Fri, 16 Jan 2009 14:23:53 +0000 (15:23 +0100)
committerDinko Korunic <kreator@carnet.hr>
Fri, 16 Jan 2009 14:23:53 +0000 (15:23 +0100)
  dependa o modulima iz Etcha)
* micanje preostalih DCC i Razor2 postavki
* cleanup AWL baze ako je veca od 50MB (reset na 0)
* rotiranje sa-update.log na tjednoj bazi, kao sto radi i savelog za ostale
  Debian pakete

debian/changelog
debian/control
debian/postinst
etc-default-spamassassin-non-root
etc-default-spamassassin-root
spamassassin-cn

index c83b68f..a53e89b 100644 (file)
@@ -1,3 +1,14 @@
+spamassassin-cn (2:3.2.5-2) stable; urgency=low
+
+  * depends o novoj inacici SpamAssassin paketa (backportana iz Lennyja,
+    dependa o modulima iz Etcha)
+  * micanje preostalih DCC i Razor2 postavki
+  * cleanup AWL baze ako je veca od 50MB (reset na 0)
+  * rotiranje sa-update.log na tjednoj bazi, kao sto radi i savelog za ostale
+    Debian pakete
+
+ -- Dinko Korunic <kreator@carnet.hr>  Fri, 16 Jan 2009 13:47:08 +0100
+
 spamassassin-cn (2:3.1.7-4) stable; urgency=low
 
   * izbacivanje DCC s obzirom da vise nije u Debian repozitorijima zbog
index 7c9086f..2e689b3 100644 (file)
@@ -7,7 +7,7 @@ Standards-Version: 3.7.2
 
 Package: spamassassin-cn
 Architecture: all
-Depends: spamassassin (>= 3.1.7-1~bpo.1), razor (>= 2.670-1sarge2), libnet-dns-perl, carnet-tools-cn (>= 2.0), gnupg (>= 1.4.1-1.sarge7), libmail-dkim-perl (>= 0.19-3), libcrypt-openssl-bignum-perl (>= 0.03-1), ${misc:Depends}
+Depends: spamassassin (>= 3.2.5-2~bpo40+1), razor (>= 2.810-2), libnet-dns-perl, carnet-tools-cn (>= 2.0), gnupg (>= 1.4.6-2), libmail-dkim-perl (>= 0.19-3), libcrypt-openssl-bignum-perl (>= 0.03-1), libmail-spf-query-perl (>= 1.999.1-2), ${misc:Depends}
 Recommends: amavis
 Description: Perl-based spam filter using text analysis
  SpamAssassin is a very powerful and fully configurable spam filter
index 29e233c..c546d27 100755 (executable)
@@ -302,10 +302,18 @@ fi
 
 # cleanup the AWL
 if getent passwd amavis >/dev/null 2>&1; then
-  if [ -s ~amavis/.spamassassin/auto-whitelist ]; then
+  AWL=~amavis/.spamassassin/auto-whitelist
+  if [ -s $AWL ]; then
     echo "CN: Cleaning the Amavis auto-whitelist"
     su -c '/usr/bin/check_whitelist --clean' - amavis >/dev/null 2>&1 \
       || true
+
+    # see if size is still unacceptable
+    SIZE=$(du -ks $AWL | awk '{print $1}')
+    if [ $SIZE -ge 51200 ]; then
+        echo "CN: Size of AWL database > 50MB, doing full cleanup"
+        cp /dev/null $AWL
+    fi
   fi
 fi
 
index 13bda3b..f665527 100644 (file)
@@ -10,9 +10,9 @@ ENABLED=1
 # Options
 # See man spamd for possible options. The -d option is automatically added.
 
-# NOTE: version 3.0.x has switched to a "preforking" model, so you
-# need to make sure --max-children is not set to anything higher than
-# 5, unless you know what you're doing.
+# SpamAssassin uses a preforking model, so be careful! You need to
+# make sure --max-children is not set to anything higher than 5,
+# unless you know what you're doing.
 
 OPTIONS="--create-prefs --max-children 5 --helper-home-dir --username=spamd"
 
@@ -24,3 +24,8 @@ PIDFILE="/var/run/spamd/spamd.pid"
 
 # Set nice level of spamd
 #NICE="--nicelevel 15"
+
+# Cronjob
+# Set to anything but 0 to enable the cron job to automatically update
+# spamassassin's rules on a nightly basis
+CRON=0
index 0c7267a..dc44da0 100644 (file)
@@ -10,9 +10,9 @@ ENABLED=1
 # Options
 # See man spamd for possible options. The -d option is automatically added.
 
-# NOTE: version 3.0.x has switched to a "preforking" model, so you
-# need to make sure --max-children is not set to anything higher than
-# 5, unless you know what you're doing.
+# SpamAssassin uses a preforking model, so be careful! You need to
+# make sure --max-children is not set to anything higher than 5,
+# unless you know what you're doing.
 
 OPTIONS="--create-prefs --max-children 5 --helper-home-dir"
 
@@ -24,3 +24,8 @@ PIDFILE="/var/run/spamd.pid"
 
 # Set nice level of spamd
 #NICE="--nicelevel 15"
+
+# Cronjob
+# Set to anything but 0 to enable the cron job to automatically update
+# spamassassin's rules on a nightly basis
+CRON=0
index 90b33cb..3b2d600 100644 (file)
@@ -1,7 +1,7 @@
 /var/log/sa-update.log {
      weekly
      missingok
-     rotate 12
+     rotate 7
      compress
      delaycompress
      create 640 root root