koristi se service umjesto systemctl u postinstu
authorIvan Rako <irako@nekkar.carnet.hr>
Tue, 4 Apr 2017 14:46:59 +0000 (16:46 +0200)
committerIvan Rako <irako@nekkar.carnet.hr>
Tue, 4 Apr 2017 14:46:59 +0000 (16:46 +0200)
debian/changelog
debian/postinst

index 1b49f82..e4517a5 100644 (file)
@@ -1,3 +1,9 @@
+spamassassin-cn (2:3.4.0-3) stable; urgency=low
+
+  * Koristi se service umjesto systemctl u postinstu
+
+ -- Ivan Rako <Ivan.Rako@CARNet.hr>  Tue, 04 Apr 2017 16:46:38 +0200
+
 spamassassin-cn (2:3.4.0-2) stable; urgency=low
 
   * Ispravke za systemd
index 83bd72f..dae4cb2 100755 (executable)
@@ -59,7 +59,7 @@ db_stop || true
 if [ "$run_as_user" = "non-root" ]; then
     if ! grep -q '^OPTIONS=".*username=spamd"' \
             /etc/default/spamassassin; then
-        systemctl stop spamassassin
+        service stop spamassassin
         rstart=yes
     fi
 
@@ -87,7 +87,7 @@ if [ "$run_as_user" = "non-root" ]; then
 elif [ "$run_as_user" = "root" ]; then
     if grep -q '^OPTIONS=".*username=spamd"' \
             /etc/default/spamassassin; then
-        systemctl stop spamassassin
+        service stop spamassassin
         restart=yes
     fi
 
@@ -400,12 +400,12 @@ echo "CN: SpamAssassin updates are now logged at /var/log/sa-update.log"
 # restart the spamasassin
 if [ "x$restart" = "xyes" ]; then
     pkill -f /usr/sbin/spamd || true
-    systemctl restart spamassassin
+    service restart spamassassin
 fi
 
 # restart the amavis
 if [ "x$restart" = "xyes" -a -x /etc/init.d/amavis ]; then
-    systemctl restart amavis
+    service restart amavis
 fi
 
 # dh_installdeb will replace this with shell code automatically