r14: - defaultni local.cf -- izbaci chi2, izbaci Pyzor, izbaci ok_languages,
authorDinko Korunic <Dinko.Korunic@CARNet.hr>
Tue, 16 Oct 2007 18:11:44 +0000 (18:11 +0000)
committerDinko Korunic <Dinko.Korunic@CARNet.hr>
Tue, 16 Oct 2007 18:11:44 +0000 (18:11 +0000)
  pali bayesian*
- depend o libcrypt-openssl-bignum-perl
- gasi Pyzor plugin za SA

debian/changelog
debian/control
debian/postinst
local.cf

index d231fce..b39a228 100644 (file)
@@ -1,3 +1,12 @@
+spamassassin-cn (2:3.1.7-3) stable; urgency=low
+
+  * gasenje ok_languages, bayes_use_chi2_combining i pyzor opcija koje se u
+    novom SA ne koriste
+  * dodatni depend na libcrypt-openssl-bignum-perl kojeg koristi DKIM modul
+  * po defaultu pali Bayes, ali sa razumnim vrijednostima
+
+ -- Dinko Korunic <kreator@carnet.hr>  Tue, 16 Oct 2007 19:48:24 +0200
+
 spamassassin-cn (2:3.1.7-2) stable; urgency=low
 
   * ukljucenje DCC plugina s obzirom na use_dcc odgovor u debconfu
index efbd1ba..b140f65 100644 (file)
@@ -7,8 +7,7 @@ Standards-Version: 3.7.2
 
 Package: spamassassin-cn
 Architecture: all
-Depends: spamassassin (>= 3.1.7-1~bpo.1), razor (>= 2.670-1sarge2), libnet-dns-perl, carnet-tools-cn (>= 2.0), dcc-client (>= 1.2.74-2), gnupg (>= 1.4.1-1.sarge7), libmail-dkim-perl (>= 0.19-3), ${misc:Depends}
-Conflicts: pyzor (<< 1:0.4.0+cvs20030201-3)
+Depends: spamassassin (>= 3.1.7-1~bpo.1), razor (>= 2.670-1sarge2), libnet-dns-perl, carnet-tools-cn (>= 2.0), dcc-client (>= 1.2.74-2), gnupg (>= 1.4.1-1.sarge7), libmail-dkim-perl (>= 0.19-3), libcrypt-openssl-bignum-perl (>= 0.03-1), ${misc:Depends}
 Recommends: amavis
 Description: Perl-based spam filter using text analysis
  SpamAssassin is a very powerful and fully configurable spam filter
index 36ac9ec..85f6874 100755 (executable)
@@ -191,6 +191,12 @@ if [ -f $examdir/local.cf ]; then
             $confdir/local.cf.$$ || true
     done
 
+    # remove obsolete options from old SA
+    egrep -v '^(bayes_use_chi2_combining|ok_languages|pyzor)' \
+        $confdir/local.cf.$$ > $confdir/local.cf.$$.$$ && \
+            mv -f $confdir/local.cf.$$.$$ $confdir/local.cf.$$
+    rm -f $confdir/local.cf.$$.$$
+
     # different than template
     if ! cmp -s $confdir/local.cf.$$ $confdir/local.cf; then
         # backup if not zero size
@@ -232,6 +238,16 @@ for i in $list; do
         mv -f $i.$$ $i
     fi
     rm -f $i.$$
+
+    # disable Pyzor
+    cp -f $i $i.$$
+    plugin="loadplugin Mail::SpamAssassin::Plugin::Pyzor"
+    cp_check_and_sed "^$plugin.*$" \
+        "s/^$plugin.*$/#$plugin/g" $i.$$ || true
+    if ! cmp -s $i.$$ $i; then
+        mv -f $i.$$ $i
+    fi
+    rm -f $i.$$
 done
 
 # check and replace /etc/default/spamasassin if needed
index 42d2d27..ee39262 100644 (file)
--- a/local.cf
+++ b/local.cf
@@ -4,15 +4,12 @@
 ###########################################################################
 
 # Bayes database configuration
-# By default no Bayes, since it requires much administrator intervention (ie.
-# feeding hams and spams until mature, regular retraining, etc)
-use_bayes 0
-use_bayes_rules 0
-bayes_auto_learn 0
+use_bayes 1
+use_bayes_rules 1
+bayes_auto_learn 1
 bayes_auto_learn_threshold_nonspam -0.001
 bayes_auto_learn_threshold_spam 10.0
 bayes_use_hapaxes 1
-bayes_use_chi2_combining 1
 bayes_auto_expire 1
 bayes_ignore_header ReSent-Date
 bayes_ignore_header ReSent-From
@@ -51,13 +48,6 @@ dcc_body_max 999999
 dcc_fuz1_max 999999
 dcc_fuz2_max 999999
 
-# Pyzor options!
-# We don't use it -- the project seems dead
-use_pyzor 0
-pyzor_timeout 10
-pyzor_max 5
-pyzor_path /usr/bin/pyzor
-
 # Auto-whitelist to track long-term average score for sender
 # AWL should be cleaned from time to time with check_whitelist program
 use_auto_whitelist 1
@@ -69,11 +59,6 @@ fold_headers 1
 # We don't change e-mail except adding X-Spam headers
 report_safe 0
 
-# Mail using languages used in these country codes will not be marked
-# as being possibly spam in a foreign language.
-# - english, croatian, bosnian, finnish, german, slovenian
-ok_languages en hr bs fi de sl
-
 # Privileged options
 allow_user_rules 0