Ignoriranje datoteka ciji nazivi zavrsavaju s ~, .old, .staro i slicno
authorDragan Dosen <Dragan.Dosen@CARNet.hr>
Thu, 6 Oct 2016 10:13:08 +0000 (12:13 +0200)
committerDragan Dosen <Dragan.Dosen@CARNet.hr>
Thu, 6 Oct 2016 10:13:08 +0000 (12:13 +0200)
debian/changelog
debian/postinst

index 3fe84a8..c8edafd 100644 (file)
@@ -4,6 +4,8 @@ apache2-cn (2.4.10+2) UNRELEASED; urgency=low
   * Koristi Require u predloscima, umjesto Order i Allow direktiva.
   * Default vrijednost za Options direktivu u predloscima (kao primjer).
   * Aktivacija modula access_compat.
+  * Ignoriranje datoteka ciji nazivi zavrsavaju s ~, .old, .staro,
+    .bkp, .bak, .swp, .tmp, .dpkg-* i .cn-*.
 
  -- Dragan Dosen <Dragan.Dosen@CARNet.hr>  Thu, 06 Oct 2016 10:51:58 +0200
 
index 50f920e..abc7092 100755 (executable)
@@ -288,7 +288,7 @@ backup_conf () {
         cp_echo "CN: Doing backup for all files in $dir"
         for file in ${dir}/*; do
             if [ -f "$file" ]; then
-                if [ -z "$(echo $file | egrep '^/.*~')" ]; then
+                if [ -z "$(echo "$file" | egrep '^/.*(~|(\.(old|staro|bkp|bak|swp|tmp|dpkg-.+|cn-.+)))$')" ]; then
                     backup_dir="$BACKUPDIR/$(basename $(dirname "$file"))"
                     cp_backup_conffile -d "$backup_dir" -p "$file"
                 fi
@@ -330,6 +330,7 @@ move_conf () {
     if [ -d "${dir}" ] && [ -n "$(ls -A ${dir}/)" ]; then
         mkdir -p "$newdir"
         for file in ${dir}/*; do
+            [ -z "$(echo "$file" | egrep '^/.*(~|(\.(old|staro|bkp|bak|swp|tmp|dpkg-.+|cn-.+)))$')" ] || continue
             newfile="${newdir}/$(basename "$file" .conf).conf"
             if [ ! -e "$newfile" ]; then
                 cp_echo "CN: Preserving changes to $newfile (renamed from $file)."
@@ -369,6 +370,8 @@ rename_conf () {
     if [ -d "${edir}" ] && [ -n "$(ls -A ${edir}/)" ]; then
         mkdir -p "$adir"
         for efile in ${edir}/*; do
+            [ -z "$(echo "$efile" | egrep '^/.*(~|(\.(old|staro|bkp|bak|swp|tmp|dpkg-.+|cn-.+)))$')" ] || continue
+
             [ ! -e "${edir}/$(basename "$efile" .conf).conf" ] || continue
 
             afile="$(readlink -q -m "$efile")"