Prva inacica za buster
authorZeljko Boros <Zeljko.Boros@carnet.hr>
Wed, 12 Aug 2020 12:13:10 +0000 (14:13 +0200)
committerZeljko Boros <Zeljko.Boros@carnet.hr>
Wed, 12 Aug 2020 12:13:10 +0000 (14:13 +0200)
README.CARNet
debian/changelog
debian/control
debian/postinst
install-carnet-sources.list
sources.list

index 3aaef71..6c2b219 100644 (file)
@@ -1,10 +1,16 @@
 apt-cn
 +----+
 
-Paket donosi ispravan popis repozitorija paketa za CARNet Debian 8.0.
+Ovaj paket donosi preporučeni i ispravni popis repozitorija paketa za 
+CARNET-ovu distribuciju Debiana 10 (buster).
 
-Ako zelite koristiti samo sources.list preporucen od CARNeta, pokrenite:
+Ukoliko želite rabiti samo ove repozitorije, pokrenite naredbu:
 
 # install-carnet-sources.list
 
- -- Zeljko Boros <Zeljko.Boros@CARNet.hr>  Tue, 18 Oct 2016 15:52:49 +0200
+Ova naredba će prepisati datoteku /etc/apt/sources.list s potpuno novim 
+sadržajem, pa napravite backup datoteke ukoliko imate upisane dodatne 
+repozitorije ili ih prebacite u zasebne datoteke unutar direktorija 
+/etc/apt/sources.list.d.
+
+ -- Zeljko Boros <Zeljko.Boros@CARNet.hr>  Wed, 12 Aug 2020 13:58:47 +0200
index a6bc51a..678025a 100644 (file)
@@ -1,3 +1,9 @@
+apt-cn (10.0.0) stable; urgency=low
+
+  * Prva inacica za Debian 10 (buster)
+
+ -- Zeljko Boros <Zeljko.Boros@CARNet.hr>  Wed, 12 Aug 2020 13:46:36 +0200
+
 apt-cn (9.0.2) stable; urgency=low
 
   * fix sources.list
index bb4915f..640e0cc 100644 (file)
@@ -9,5 +9,5 @@ Standards-Version: 3.9.8
 Package: apt-cn
 Architecture: all
 Depends: carnet-tools-cn (>= 3.1.0), apt, carnet-keyring, ${misc:Depends}
-Description: CARNet sources.list
- This package contains the sources.list used for CARNet Debian.
+Description: CARNET-ov /etc/apt/sources.list
+ Ovaj paket sadrži važeću datoteku sources.list za distribuciju CARNET Debian.
index b3b9e4a..8344168 100755 (executable)
@@ -6,16 +6,16 @@ set -e
 [ "$DEBIAN_SCRIPT_DEBUG" ] && set -vx
 
 repos_regexp="
-^deb .*tp://security.debian.org.*stretch/updates main contrib non-free
-^deb .*tp://ftp.hr.debian.org/.*debian.*stretch main contrib non-free
-^deb .*tp://ftp.hr.debian.org/.*debian.*stretch-updates main contrib non-free
-^deb .*tp://ftp.carnet.hr/carnet-debian.*stretch main non-free"
+^deb .*tp://security.debian.org.*buster/updates main contrib non-free
+^deb .*tp://ftp.hr.debian.org/.*debian.*buster main contrib non-free
+^deb .*tp://ftp.hr.debian.org/.*debian.*buster-updates main contrib non-free
+^deb .*tp://ftp.carnet.hr/carnet-debian.*buster main non-free"
 
 repos="
-1 deb http://security.debian.org/ stretch/updates main contrib non-free
-2 deb http://ftp.hr.debian.org/debian/ stretch main contrib non-free
-3 deb http://ftp.hr.debian.org/debian/ stretch-updates main contrib non-free
-4 deb http://ftp.carnet.hr/carnet-debian/ carnet-stretch main non-free"
+1 deb http://security.debian.org/ buster/updates main contrib non-free
+2 deb http://ftp.hr.debian.org/debian/ buster main contrib non-free
+3 deb http://ftp.hr.debian.org/debian/ buster-updates main contrib non-free
+4 deb http://ftp.carnet.hr/carnet-debian/ carnet-buster main non-free"
 
 notneeded_repos_regexp="^deb.*tp://.*debian-non-US"
 
@@ -31,19 +31,19 @@ for i in $repos_regexp; do
 done
 
 if grep -q "$notneeded_repos_regexp" /etc/apt/sources.list; then
-  echo "CN: Following repositories are obsolete:"
+  echo "CN: Sljedeci repozitoriji nisu vise potrebni:"
   grep "$notneeded_repos_regexp" /etc/apt/sources.list
   echo ""
 fi
 
 if [ ! -z "$needed" ]; then
-  echo "CN: Following repositories are not found in your sources list:"
+  echo "CN: Ovi repozitoriji nisu pronadjeni u vasoj datoteci sources list:"
   IFS=" "
   for i in $needed; do
     echo $repos | grep ^$i | cut -c3-300
   done
   echo ""
-  echo "CN: You can add the above to /etc/apt/sources.list or just:"
+  echo "CN: Gornje repozitorije mozete rucno dodati u /etc/apt/sources.list ili samo pokrenuti:"
   echo "CN: # install-carnet-sources.list"
 fi
 
index 2b2eb31..7926e13 100755 (executable)
@@ -2,15 +2,15 @@
 
 if ! cmp -s /usr/share/doc/apt-cn/sources.list /etc/apt/sources.list; then
   . /usr/share/carnet-tools/functions.sh
-  echo "CN: Backing up old /etc/apt/sources.list to /var/backups/."
-  echo "CN: Installing new /etc/apt/sources.list."
+  echo "CN: Kopiram datoteku /etc/apt/sources.list u /var/backups/."
+  echo "CN: Postavljam novu datoteku /etc/apt/sources.list."
   echo ""
   cp_backup_conffile /etc/apt/sources.list
   cp /usr/share/doc/apt-cn/sources.list /etc/apt/sources.list
   apt-get update
 else
-  echo "CN: Valid CARNet's /etc/apt/sources.list already exists."
-  echo "CN: Nothing to do."
+  echo "CN: Ispravna datoteka /etc/apt/sources.list već postoji."
+  echo "CN: Izlazim."
   echo ""
 fi
 
index 4afd0a4..2fcfeac 100644 (file)
@@ -1,26 +1,26 @@
 # Standardni Debianov repozitorij za pakete
-deb http://ftp.hr.debian.org/debian stretch main contrib non-free
+deb http://ftp.hr.debian.org/debian buster main contrib non-free
 
 # Sigurnosne nadogradnje za pakete
-deb http://security.debian.org/ stretch/updates main contrib non-free
+deb http://security.debian.org/ buster/updates main contrib non-free
 
 # Repozitorij za pakete osvježene izmedju dva point releasea
-deb http://ftp.hr.debian.org/debian stretch-updates main contrib non-free
+deb http://ftp.hr.debian.org/debian buster-updates main contrib non-free
 
 # Repozitorij za CARNET-Debian
-deb http://ftp.carnet.hr/carnet-debian carnet-stretch main
+deb http://ftp.carnet.hr/carnet-debian carnet-buster main
 
 # Repozitorij za podrsku sustavu AAI@EduHr
-deb http://ftp.srce.hr/srce-debian srce-stretch main
+deb http://ftp.srce.hr/srce-debian srce-buster main
 
 # Repozitorij za pakete iz stabla Backports
 # Vise na https://sysportal.carnet.hr/node/52
-#deb http://ftp.hr.debian.org/debian stretch-backports main
+#deb http://ftp.hr.debian.org/debian buster-backports main
 
 # Odkomentirajte ukoliko zelite instalirati pakete s izvornim kodom
-#deb-src http://ftp.hr.debian.org/debian stretch main contrib non-free
-#deb-src http://ftp.hr.debian.org/debian stretch-updates main contrib non-free
-#deb-src http://security.debian.org/ stretch/updates main contrib non-free
-#deb-src http://ftp.carnet.hr/carnet-debian carnet-stretch main non-free
-#deb-src http://ftp.srce.hr/srce-debian srce-stretch main
-#deb-src http://ftp.hr.debian.org/debian stretch-backports main
+#deb-src http://ftp.hr.debian.org/debian buster main contrib non-free
+#deb-src http://ftp.hr.debian.org/debian buster-updates main contrib non-free
+#deb-src http://security.debian.org/ buster/updates main contrib non-free
+#deb-src http://ftp.carnet.hr/carnet-debian carnet-buster main non-free
+#deb-src http://ftp.srce.hr/srce-debian srce-buster main
+#deb-src http://ftp.hr.debian.org/debian buster-backports main