Prepare bacula-geant version of the package. geant
authorValentin Vidic <Valentin.Vidic@CARNet.hr>
Tue, 14 Apr 2015 12:12:40 +0000 (14:12 +0200)
committerValentin Vidic <Valentin.Vidic@CARNet.hr>
Tue, 14 Apr 2015 12:22:53 +0000 (14:22 +0200)
debian/changelog
debian/config
debian/control
debian/default
debian/po/templates.pot
debian/postinst
debian/postrm
debian/templates

index 125ec5f..ec03a3e 100644 (file)
@@ -1,3 +1,9 @@
+bacula-geant (20150414) unstable; urgency=medium
+
+  * Prepare bacula-geant version of the package.
+
+ -- Valentin Vidic <Valentin.Vidic@CARNet.hr>  Tue, 14 Apr 2015 14:13:09 +0200
+
 bacula-cn (20141028) unstable; urgency=medium
 
   * Try to get hostname.
index eb026c6..cea6081 100644 (file)
@@ -9,13 +9,13 @@ if [ -z "$HOST" ]; then
     HOST=localhost
 fi
 
-db_get bacula-cn/hostname || true
+db_get bacula-geant/hostname || true
 if [ -z "$RET" ]; then
-    db_set bacula-cn/hostname "$HOST"
+    db_set bacula-geant/hostname "$HOST"
 fi
 
 # Guess default ip
-db_get bacula-cn/ip || true
+db_get bacula-geant/ip || true
 if [ -z "$RET" ]; then
     # default via 161.53.55.1 dev eth0
     DEV=$( ip route show to exact 0/0 \
@@ -25,23 +25,23 @@ if [ -z "$RET" ]; then
         IP=$( ip address show dev $DEV scope global \
               | awk '$1 == "inet" { sub("/[^ ]+", ""); print $2; nextfile }' )
         if [ "$IP" ]; then
-            db_set bacula-cn/ip "$IP"
+            db_set bacula-geant/ip "$IP"
         fi
     fi
 fi
 
 # Sample contact
-db_get bacula-cn/contact || true
+db_get bacula-geant/contact || true
 if [ -z "$RET" ]; then
-    db_set bacula-cn/contact "Ime Prezime <korisnik@$HOST>"
+    db_set bacula-geant/contact "First Last Name <user@$HOST>"
 fi
 
 # Check hostname
 while true; do
-    ! db_input high bacula-cn/hostname && [ $? -eq 30 ] && break
+    ! db_input high bacula-geant/hostname && [ $? -eq 30 ] && break
     db_go || true
 
-    db_get bacula-cn/hostname
+    db_get bacula-geant/hostname
     [ -z "$RET" ] && continue
     echo "$RET" | grep -Eqi '^[a-z0-9-]+(\.[a-z0-9.-]+)+$' || continue
 
@@ -50,10 +50,10 @@ done
 
 # Check ip
 while true; do
-    ! db_input high bacula-cn/ip && [ $? -eq 30 ] && break
+    ! db_input high bacula-geant/ip && [ $? -eq 30 ] && break
     db_go || true
 
-    db_get bacula-cn/ip
+    db_get bacula-geant/ip
     [ -z "$RET" ] && continue
     echo "$RET" | grep -Eqi '^[0-9]{1,3}(\.[0-9]{1,3}){3}$' || continue
 
@@ -62,10 +62,10 @@ done
 
 # Check contact
 while true; do
-    ! db_input high bacula-cn/contact && [ $? -eq 30 ] && break
+    ! db_input high bacula-geant/contact && [ $? -eq 30 ] && break
     db_go || true
 
-    db_get bacula-cn/contact
+    db_get bacula-geant/contact
     [ -z "$RET" ] && continue
     echo "$RET" | grep -Eqi '^([^@]*<)?[a-z0-9.+-]+@[a-z0-9-]+(\.[a-z0-9.-]+)+>?$' || continue
 
index 585c07f..8d2197a 100644 (file)
@@ -1,7 +1,7 @@
-Source: bacula-cn
+Source: bacula-geant
 Section: admin
 Priority: extra
-Maintainer: Grupa za izradu paketa <paketi@carnet.hr>
+Maintainer: Packages group <paketi@carnet.hr>
 Uploaders: Valentin Vidic <Valentin.Vidic@CARNet.hr>
 Build-Depends-Indep: debhelper (>= 7), po-debconf
 Standards-Version: 3.9.4
@@ -9,11 +9,11 @@ Bugs: mailto:paketi@carnet.hr
 Vcs-Git: http://ftp.carnet.hr/carnet-debian/scm/bacula-cn.git
 Vcs-Browser: http://ftp.carnet.hr/carnet-debian/scm/?p=bacula-cn.git;a=summary
 
-Package: bacula-cn
+Package: bacula-geant
 Architecture: all
 Depends: bacula-fd (>= 5), bacula-console (>= 5), openssl, curl,
  ca-certificates, debconf (>= 0.5) | debconf-2.0, ${misc:Depends}
 Suggests: mysql-client, postgresql-client-common, mail-transport-agent
-Description: Network backup configuration for CARNet members
+Description: Network backup configuration for CARNet backup service
  This package install Bacula client daemon and configures it for use
  with CARNet backup service for member institutions.
index 7d1eec4..6009735 100644 (file)
@@ -1,3 +1,3 @@
 # Directory for dumping databases prior to backup
 # To avoid dumping the databases set this to an empty string
-DUMP_DIR=/var/backups/bacula-cn
+DUMP_DIR=/var/backups/bacula-geant
index bf4edfc..4c97499 100644 (file)
@@ -6,9 +6,9 @@
 #, fuzzy
 msgid ""
 msgstr ""
-"Project-Id-Version: bacula-cn\n"
-"Report-Msgid-Bugs-To: bacula-cn@packages.debian.org\n"
-"POT-Creation-Date: 2014-10-09 15:02+0200\n"
+"Project-Id-Version: bacula-geant\n"
+"Report-Msgid-Bugs-To: bacula-geant@packages.debian.org\n"
+"POT-Creation-Date: 2015-04-14 14:05+0200\n"
 "PO-Revision-Date: YEAR-MO-DA HO:MI+ZONE\n"
 "Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
 "Language-Team: LANGUAGE <LL@li.org>\n"
@@ -20,76 +20,74 @@ msgstr ""
 #. Type: string
 #. Description
 #: ../templates:1001
-msgid "Naziv posluzitelja:"
+msgid "Server hostname:"
 msgstr ""
 
 #. Type: string
 #. Description
 #: ../templates:1001
-msgid ""
-"Unesite puno ime posluzitelja koji se dodaje u backup sustav. Najcesce se "
-"koristi oblik ime.ustanova.hr."
+msgid "Fully qualified hostname of the server to add into the backup service."
 msgstr ""
 
 #. Type: string
 #. Description
 #: ../templates:2001
-msgid "IP adresa posluzitelja:"
+msgid "Server IP address:"
 msgstr ""
 
 #. Type: string
 #. Description
 #: ../templates:2001
 msgid ""
-"Unesite javnu IP adresu posluzitelja.  Putem ove adrese obavljat ce se "
-"backup posluzitelja."
+"Public IP address of this server.  Bacula backup will be initiated through "
+"this address."
 msgstr ""
 
 #. Type: string
 #. Description
 #: ../templates:3001
-msgid "Kontakt adresa:"
+msgid "Contact email:"
 msgstr ""
 
 #. Type: string
 #. Description
 #: ../templates:3001
-msgid "Unesite ime i kontakt adresu administratora posluzitelja u obliku:"
+msgid "Server administrator name and email address in the form:"
 msgstr ""
 
 #. Type: string
 #. Description
 #: ../templates:3001
-msgid "Ime Prezime <moj.kontakt@ustanova.hr>"
+msgid "First Last Name <my.name@domain.eu>"
 msgstr ""
 
 #. Type: string
 #. Description
 #: ../templates:3001
 msgid ""
-"Ova adresa koristit ce se prilikom slanja zahtjeva za pokretanje usluge "
-"backupa i za kontakt u slucaju problema. Zbog toga molimo da unesete radecu "
-"mail adresu."
+"This address will be used for sending the backup service request form and "
+"for contacting the server admins in case of problems, so please enter a "
+"valid email address."
 msgstr ""
 
 #. Type: error
 #. Description
 #: ../templates:4001
-msgid "Greska prilikom slanja zahtjeva."
+msgid "Error while sending the service request form."
 msgstr ""
 
 #. Type: error
 #. Description
 #: ../templates:4001
 msgid ""
-"Automatsko slanje zahtjeva za pokretanje usluge backupa posluzitelja nije "
-"uspjelo."
+"Automatic sending of the request form for the server backup service has "
+"failed."
 msgstr ""
 
 #. Type: error
 #. Description
 #: ../templates:4001
 msgid ""
-"Provjerite vezu prema posluzitelju https://sysbackup.carnet.hr i ponovo "
-"instalirajte paket."
+"Please check this server's connection to the backup service on https://"
+"sysbackup.carnet.hr and try reinstalling this package."
 msgstr ""
index 03b2c5e..18903d7 100644 (file)
@@ -1,5 +1,5 @@
 #!/bin/sh
-# postinst script for bacula-cn
+# postinst script for bacula-geant
 #
 # see: dh_installdeb(1)
 
@@ -175,7 +175,7 @@ random_string() {
 
 send_request() {
     # cleanup gpg files
-    rm -rf /var/lib/bacula-cn
+    rm -rf /var/lib/bacula-geant
 
     if [ -e $REQUEST_FILE ]; then
         echo Config has not changed, skipping request.
@@ -183,17 +183,17 @@ send_request() {
     fi
 
     # report disk sizes
-    DF_FILE=$(mktemp bacula-cn.XXXXXXXXXX)
+    DF_FILE=$(mktemp bacula-geant.XXXXXXXXXX)
     df -h > $DF_FILE
 
     # report database sizes
-    DB_FILE=$(mktemp bacula-cn.XXXXXXXXXX)
+    DB_FILE=$(mktemp bacula-geant.XXXXXXXXXX)
     if [ -d /var/lib/mysql -o -d /var/lib/postgresql ]; then
         du -sh /var/lib/mysql /var/lib/postgresql >$DB_FILE 2>/dev/null || true
     fi
 
     # generate client config
-    FD_FILE=$(mktemp bacula-cn.XXXXXXXXXX)
+    FD_FILE=$(mktemp bacula-geant.XXXXXXXXXX)
     cat >> $FD_FILE <<EOF
 # Requested by $CONTACT on $DATE
 Client {
@@ -227,7 +227,7 @@ Messages {
 EOF
 
     # client certificate
-    PEM_FILE=$(mktemp bacula-cn.XXXXXXXXXX)
+    PEM_FILE=$(mktemp bacula-geant.XXXXXXXXXX)
     sed -n '/BEGIN CERTIFICATE/,/END CERTIFICATE/p' \
         /etc/bacula/bacula-fd.pem > $PEM_FILE
 
@@ -253,19 +253,19 @@ EOF
 
     # report problems
     if [ ! -e $REQUEST_FILE ]; then
-        db_input high bacula-cn/request-failed || true
+        db_input high bacula-geant/request-failed || true
         db_go || true
     fi
 }
 
 load_config() {
-    db_get bacula-cn/hostname
+    db_get bacula-geant/hostname
     HOST=$RET
 
-    db_get bacula-cn/ip
+    db_get bacula-geant/ip
     IP=$RET
 
-    db_get bacula-cn/contact
+    db_get bacula-geant/contact
     CONTACT=$RET
     EMAIL=${CONTACT#*<}
     EMAIL=${EMAIL%>*}
index 7e64384..3502028 100644 (file)
@@ -1,5 +1,5 @@
 #!/bin/sh
-# postrm script for bacula-cn
+# postrm script for bacula-geant
 #
 # see: dh_installdeb(1)
 
@@ -19,7 +19,7 @@ set -e
 # the debian-policy package
 
 clean_gpg() {
-    rm -rf /var/lib/bacula-cn/
+    rm -rf /var/lib/bacula-geant/
 }
 
 case "$1" in
index 5be901d..fa2be10 100644 (file)
@@ -1,31 +1,31 @@
-Template: bacula-cn/hostname
+Template: bacula-geant/hostname
 Type: string
-_Description: Naziv posluzitelja:
- Unesite puno ime posluzitelja koji se dodaje u backup sustav.
- Najcesce se koristi oblik ime.ustanova.hr.
+_Description: Server hostname:
+ Fully qualified hostname of the server to add into the
+ backup service.
 
-Template: bacula-cn/ip
+Template: bacula-geant/ip
 Type: string
-_Description: IP adresa posluzitelja:
- Unesite javnu IP adresu posluzitelja.  Putem ove adrese obavljat
- ce se backup posluzitelja.
+_Description: Server IP address:
+ Public IP address of this server.  Bacula backup will be initiated
+ through this address.
 
-Template: bacula-cn/contact
+Template: bacula-geant/contact
 Type: string
-_Description: Kontakt adresa:
- Unesite ime i kontakt adresu administratora posluzitelja u obliku:
+_Description: Contact email:
+ Server administrator name and email address in the form:
  .
- Ime Prezime <moj.kontakt@ustanova.hr>
+ First Last Name <my.name@domain.eu>
  .
- Ova adresa koristit ce se prilikom slanja zahtjeva za pokretanje
- usluge backupa i za kontakt u slucaju problema. Zbog toga molimo
- da unesete radecu mail adresu.
+ This address will be used for sending the backup service request
+ form and for contacting the server admins in case of problems, so
+ please enter a valid email address.
 
-Template: bacula-cn/request-failed
+Template: bacula-geant/request-failed
 Type: error
-_Description: Greska prilikom slanja zahtjeva.
- Automatsko slanje zahtjeva za pokretanje usluge backupa posluzitelja
- nije uspjelo.
+_Description: Error while sending the service request form.
+ Automatic sending of the request form for the server backup service
+ has failed.
  .
- Provjerite vezu prema posluzitelju https://sysbackup.carnet.hr i
- ponovo instalirajte paket.
+ Please check this server's connection to the backup service on
+ https://sysbackup.carnet.hr and try reinstalling this package.