- nadogradnja na Squeeze
authorDinko Korunic <kreator@carnet.hr>
Wed, 27 Apr 2011 12:46:54 +0000 (14:46 +0200)
committerDinko Korunic <kreator@carnet.hr>
Wed, 27 Apr 2011 12:46:54 +0000 (14:46 +0200)
- dependsi, postavke..
- lintian fixevi
- copyright, update dokumentacije..

README.CARNet
README.examples
changelog.CARNet [deleted symlink]
debian/changelog
debian/compat
debian/control
debian/docs
debian/postinst
debian/postrm
debian/rules

index 00ee3ef..1c3174a 100644 (file)
@@ -9,4 +9,4 @@ razloga jer je to neprakticno i uglavnom nemoguce, vec se sistemci upucuju
 na iscitavanje primjera izgeneriranih konfiguracijskih datoteka koji se
 nalaze u examples/ direktoriju.
 
- -- Dinko Korunic <kreator@CARNet.hr>  Sun, 12 Apr 2009 16:00:33 +0200
+ -- Dinko Korunic <kreator@CARNet.hr>  Wed, 27 Apr 2011 13:08:24 +0200
index 701e3ee..caab83e 100644 (file)
@@ -39,4 +39,4 @@ Bind9 posluzitelja i njihova znacenja:
   zaduzeno za sebe - pa to unosimo sa 127.0.0.1 adresom), kao i lokalnu
   domenu u kojem se racunalo nalazi.
 
- -- Dinko Korunic <kreator@CARNet.hr>  Sun, 12 Apr 2009 16:00:46 +0200
+ -- Dinko Korunic <kreator@CARNet.hr>  Wed, 27 Apr 2011 13:08:33 +0200
diff --git a/changelog.CARNet b/changelog.CARNet
deleted file mode 120000 (symlink)
index 194579e..0000000
+++ /dev/null
@@ -1 +0,0 @@
-changelog.Debian
\ No newline at end of file
index ca3a030..160131f 100644 (file)
@@ -1,3 +1,15 @@
+bind9-cn (2:9.7.3) stable; urgency=low
+
+  * lintian fixevi
+
+ -- Dinko Korunic <kreator@carnet.hr>  Wed, 27 Apr 2011 13:45:48 +0200
+
+bind9-cn (2:9.7.2) stable; urgency=low
+
+  * novi paket za Squeeze
+
+ -- Dinko Korunic <kreator@carnet.hr>  Tue, 26 Apr 2011 13:45:37 +0200
+
 bind9-cn (2:9.5.1-3) stable; urgency=low
 
   * ispravan epoch depend (ispravlja bug #6848)
index b8626c4..7f8f011 100644 (file)
@@ -1 +1 @@
-4
+7
index 3376d24..b766f25 100644 (file)
@@ -2,13 +2,13 @@ Source: bind9-cn
 Section: net
 Priority: optional
 Maintainer: Dinko Korunic <kreator@CARNet.hr>
-Build-Depends: debhelper (>= 4)
-Standards-Version: 3.7.2
+Build-Depends: debhelper (>= 7)
+Standards-Version: 3.9.1
 
 Package: bind9-cn
 Architecture: all
-Depends: bind9 (>= 1:9.5.1.dfsg.P1-2), carnet-tools-cn (>= 2.8.1)
-Recommends: bind9-doc (>= 1:9.5.1.dfsg.P1-2), bind9-host (>= 1:9.5.1.dfsg.P1-2), dnsutils, dnswalk, nslint
+Depends: bind9 (>= 1:9.7.3.dfsg-1~squeeze1), carnet-tools-cn (>= 2.8.1), ${misc:Depends}
+Recommends: bind9-doc (>= 1:9.7.3.dfsg-1~squeeze1), bind9-host (>= 1:9.7.3.dfsg-1~squeeze1), dnsutils, dnswalk, nslint
 Description: Internet Domain Name Server
  The Berkeley Internet Name Domain (BIND) implements an Internet domain
  name server. BIND is the most widely-used name server software on the
index ef5ce6c..8f6e250 100644 (file)
@@ -1,2 +1 @@
-changelog.CARNet
 README.CARNet
index 7eee7e4..1a86e14 100755 (executable)
@@ -44,6 +44,8 @@ CARNET_REV=`echo $CARNET_IPADDR | awk -F. '{ print $3 "." $2 "." $1 ".in-addr.ar
 SERNO=`date +%Y%m%d01`
 BROJ=`echo $CARNET_IPADDR | cut -d. -f4`
 
+echo "CN: Generating Bind9 examples in /usr/share/doc/bind9-cn/examples"
+
 # make example named.conf.local
 cat > /usr/share/doc/bind9-cn/examples/named.conf.local <<EOF
 zone "$CARNET_DOMAINNAME" in {
@@ -144,7 +146,8 @@ EOF
 cat > /usr/share/doc/bind9-cn/examples/resolv.conf <<EOF
 search $CARNET_DOMAINNAME
 nameserver 127.0.0.1
-nameserver 161.53.2.70
+nameserver 161.53.123.3
+nameserver 161.53.160.3
 EOF
 
 # check if named.conf has lame server logging
index 09d278f..a113687 100755 (executable)
@@ -32,7 +32,8 @@ esac
 
 # remove our block
 if [ -e /etc/bind/named.conf.options ]; then
-  cp-update -r bind9-cn /etc/bind/named.conf.options
+    echo "CN: Removing bind9-cn leftovers from named.conf.options" 
+    cp-update -r bind9-cn /etc/bind/named.conf.options
 fi
 
 # dh_installdeb will replace this with shell code automatically
index 3206f91..cbe925d 100755 (executable)
@@ -1,73 +1,3 @@
 #!/usr/bin/make -f
-# Sample debian/rules that uses debhelper. 
-# This file is public domain software, originally written by Joey Hess.
-#
-# This version is for packages that are architecture independent.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-build: build-stamp
-build-stamp:
-       dh_testdir
-
-       # Add here commands to compile the package.
-       #$(MAKE)
-
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp
-
-       # Add here commands to clean up after the build process.
-       #-$(MAKE) clean
-       #-$(MAKE) distclean
-
-       dh_clean
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-
-       # Add here commands to install the package into debian/<packagename>.
-       #$(MAKE) prefix=`pwd`/debian/`dh_listpackages`/usr install
-
-# Build architecture-independent files here.
-binary-indep: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs
-       dh_installdocs
-       dh_installexamples
-#      dh_installmenu
-#      dh_installdebconf
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installcatalogs
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installinfo
-#      dh_undocumented
-       dh_installman
-       dh_link
-       dh_compress
-       dh_fixperms
-#      dh_perl
-#      dh_python
-       dh_installdeb
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-# Build architecture-dependent files here.
-binary-arch: build install
-# We have nothing to do by default.
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install
+%:
+       dh $@