ispravak lintian upozorenja debian/6.0.3
authorValentin Vidic <Valentin.Vidic@CARNet.hr>
Tue, 13 Sep 2011 10:27:29 +0000 (12:27 +0200)
committerValentin Vidic <Valentin.Vidic@CARNet.hr>
Wed, 14 Sep 2011 08:31:25 +0000 (10:31 +0200)
debian/changelog
debian/compat
debian/config
debian/control
debian/po/POTFILES.in [new file with mode: 0644]
debian/po/templates.pot [new file with mode: 0644]
debian/postinst
debian/postrm [deleted file]
debian/templates

index 9453afc..83e55c9 100644 (file)
@@ -1,3 +1,9 @@
+carnet-debian (6.0.3) stable; urgency=low
+
+  * Ispravak lintian upozorenja
+
+ -- Valentin Vidic <Valentin.Vidic@CARNet.hr>  Tue, 13 Sep 2011 11:22:03 +0200
+
 carnet-debian (6.0.2) stable; urgency=medium
 
   * Koristi se apt-get umjesto aptitude
index b8626c4..45a4fb7 100644 (file)
@@ -1 +1 @@
-4
+8
index 3a6967f..67dd655 100755 (executable)
@@ -5,3 +5,54 @@ set -e
 # Load debconf
 . /usr/share/debconf/confmodule
 db_version 2.0
+
+# Rewrite pine-cn to alpine-cn
+db_fget carnet-debian/packages seen
+if [ "$RET" = "true" ]; then
+  db_get carnet-debian/packages
+  packages="$RET"
+  if echo $packages | grep -qw pine-cn; then
+    packages=$( echo $packages | sed 's/pine-cn/alpine-cn/' )
+    db_set carnet-debian/packages "$packages"
+  fi
+fi
+
+# Show dialogs if started from postinst
+if [ "$CN_POSTINST" ]; then
+  db_fset carnet-debian/packages seen false
+  db_fset carnet-debian/note seen false
+  db_go || true
+fi
+
+while true; do
+  db_input critical carnet-debian/packages || true
+  db_go || true
+
+  db_get carnet-debian/packages
+  packages="$RET"
+  if echo $packages | grep -q vsftpd-cn; then
+    vsftpd="yes"
+  else
+    vsftpd="no"
+  fi
+
+  if echo $packages | grep -q proftpd-cn; then
+    proftpd="yes"
+  else
+    proftpd="no"
+  fi
+
+  if [ "$proftpd" = "yes" -a "$vsftpd" = "yes" ]; then
+    db_fset carnet-debian/ftpd seen false
+    db_fset carnet-debian/packages seen false
+    db_go || true
+    db_input critical carnet-debian/ftpd || true
+  else
+    break
+  fi
+done
+
+db_input critical carnet-debian/note || true
+
+db_go || true
+db_stop || true
index a09e25e..8950f46 100644 (file)
@@ -2,12 +2,12 @@ Source: carnet-debian
 Section: misc
 Priority: optional
 Maintainer: Ivan Rako <Ivan.Rako@CARNet.hr>
-Build-Depends: debhelper (>= 4.0.0)
-Standards-Version: 3.6.1
+Build-Depends: debhelper (>= 8), po-debconf
+Standards-Version: 3.9.1
 
 Package: carnet-debian
 Provides: carnet-debian-cn
 Architecture: all
-Depends: debconf, apt-cn, aptitude
+Depends: debconf, apt-cn, aptitude, ${misc:Depends}
 Description: Installer for CARNet Debian packages
  This is packages installer for CARNet Debian distribution. 
diff --git a/debian/po/POTFILES.in b/debian/po/POTFILES.in
new file mode 100644 (file)
index 0000000..cef83a3
--- /dev/null
@@ -0,0 +1 @@
+[type: gettext/rfc822deb] templates
diff --git a/debian/po/templates.pot b/debian/po/templates.pot
new file mode 100644 (file)
index 0000000..c5ec72a
--- /dev/null
@@ -0,0 +1,64 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
+# This file is distributed under the same license as the PACKAGE package.
+# FIRST AUTHOR <EMAIL@ADDRESS>, YEAR.
+#
+#, fuzzy
+msgid ""
+msgstr ""
+"Project-Id-Version: PACKAGE VERSION\n"
+"Report-Msgid-Bugs-To: carnet-debian@packages.debian.org\n"
+"POT-Creation-Date: 2011-09-13 11:13+0200\n"
+"PO-Revision-Date: YEAR-MO-DA HO:MI+ZONE\n"
+"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
+"Language-Team: LANGUAGE <LL@li.org>\n"
+"Language: \n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=CHARSET\n"
+"Content-Transfer-Encoding: 8bit\n"
+
+#. Type: multiselect
+#. Description
+#: ../templates:1001
+msgid "Koje pakete zelite?"
+msgstr ""
+
+#. Type: multiselect
+#. Description
+#: ../templates:1001
+msgid ""
+"CARNet Debian donosi pakete za laksu konfiguraciju servisa na CARNetovom "
+"cvornom racunalu."
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../templates:2001
+msgid "Instalacija CARNetovih paketa"
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../templates:2001
+msgid "CARNetove pakete za Debian mozete instalirati slijedecom naredbom:"
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../templates:2001
+msgid "# install-carnet-debian"
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../templates:3001
+msgid "ProFTPD vs. vsftpd"
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../templates:3001
+msgid ""
+"Odabrali ste oba FTP daemona, morate izabrati samo jedan (ili vsftpd-cn ili "
+"proftpd-cn)."
+msgstr ""
index 9035bf7..30f9544 100755 (executable)
@@ -4,42 +4,12 @@ set -e
 
 [ "$1" = "configure" ] || exit 0
 
+# Always show dialogs from postinst
+# unless this is a fresh install (dialogs already show by preconfigure)
+[ "$2" ] && export CN_POSTINST=1
+
 # Load debconf
 . /usr/share/debconf/confmodule
 db_version 2.0
 
-while true; do
-  db_fset carnet-debian/packages seen false
-  db_go || true
-  db_input critical carnet-debian/packages || true
-  db_go || true
-
-  db_get carnet-debian/packages
-  packages="$RET"
-  if echo $packages | grep -q vsftpd-cn; then
-    vsftpd="yes"
-  else
-    vsftpd="no"
-  fi
-
-  if echo $packages | grep -q proftpd-cn; then
-    proftpd="yes"
-  else
-    proftpd="no"
-  fi
-
-  if [ "$proftpd" = "yes" -a "$vsftpd" = "yes" ]; then
-    db_fset carnet-debian/ftpd seen false
-    db_go || true
-    db_input critical carnet-debian/ftpd || true
-  else
-    break
-  fi
-done
-
-db_fset carnet-debian/note seen false
-db_go || true
-db_input critical carnet-debian/note || true
-
-db_go || true
-db_stop || true
+#DEBHELPER#
diff --git a/debian/postrm b/debian/postrm
deleted file mode 100755 (executable)
index b6dcb1f..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-#!/bin/sh -e
-
-set -e
-
-[ "$1" = "purge" ] || exit 0
-
-# Load debconf
-. /usr/share/debconf/confmodule
-
-db_purge || true
index ca48bca..b3fb024 100644 (file)
@@ -2,19 +2,19 @@ Template: carnet-debian/packages
 Type: multiselect
 Choices: alpine-cn, amavisd-cn, apache2-cn, apt-cn, bind9-cn, carnet-tools-cn, clamav-cn, dovecot-cn, fail2ban-cn, iptables-cn, jre-cn, kernel-2.6-cn, mailman-cn, monit-cn, munin-cn, mysql-cn, ntp-cn, openssh-cn, ossec-hids-cn, php5-cn, php-suhosin-cn, postfix-cn, proftpd-cn, samba-cn, spamassassin-cn, squirrelmail-change-pass-cn, squirrelmail-cn, sysadmin-cn, vsftpd-cn, webalizer-cn, xinetd-cn 
 Default: alpine-cn, amavisd-cn, apache2-cn, apt-cn, bind9-cn, carnet-tools-cn, clamav-cn, dovecot-cn, fail2ban-cn, iptables-cn, jre-cn, kernel-2.6-cn, mailman-cn, monit-cn, munin-cn, mysql-cn, ntp-cn, openssh-cn, ossec-hids-cn, php5-cn, php-suhosin-cn, postfix-cn, samba-cn, spamassassin-cn, squirrelmail-change-pass-cn, squirrelmail-cn, sysadmin-cn, vsftpd-cn, webalizer-cn, xinetd-cn 
-Description: Koje pakete zelite?
+_Description: Koje pakete zelite?
  CARNet Debian donosi pakete za laksu konfiguraciju servisa na CARNetovom
  cvornom racunalu.
 
 Template: carnet-debian/note
 Type: note
-Description: Instalacija CARNetovih paketa
+_Description: Instalacija CARNetovih paketa
  CARNetove pakete za Debian mozete instalirati slijedecom naredbom:
  .
  # install-carnet-debian
 
 Template: carnet-debian/ftpd
 Type: note
-Description: ProFTPD vs. vsftpd
+_Description: ProFTPD vs. vsftpd
  Odabrali ste oba FTP daemona, morate izabrati samo jedan (ili vsftpd-cn
  ili proftpd-cn).