r14:
authorIvan Rako <Ivan.Rako@CARNet.hr>
Wed, 31 Oct 2007 09:15:58 +0000 (09:15 +0000)
committerIvan Rako <Ivan.Rako@CARNet.hr>
Wed, 31 Oct 2007 09:15:58 +0000 (09:15 +0000)
debian/control
debian/install
install-carnet-debian

index 1286508..05c24cb 100644 (file)
@@ -8,5 +8,5 @@ Standards-Version: 3.6.1
 Package: carnet-debian
 Provides: carnet-debian-cn
 Architecture: all
-Depends: debconf, apt-cn, carnet-tools-cn (>= 2.8)
+Depends: debconf, apt-cn
 Description: Installer for CARNet Debian packages
index 512664e..f157875 100644 (file)
@@ -1 +1,2 @@
 install-carnet-debian usr/sbin
+carnet-debconf-get usr/sbin
index cbf57df..be124a9 100644 (file)
@@ -2,12 +2,7 @@
 
 set -e
 
-. /usr/share/debconf/confmodule
-. /usr/share/carnet-tools/functions.sh
-
-cp_db_get carnet-debian/packages
-
-packages="`echo $RET | tr -d ','`"
+packages="`debconf-show carnet-debian | awk -F: /packages/'{print $2}' | tr -d ','`"
 
 if [ -z "$packages" ]; then
   echo "CN: No packages for install."