novi copyright, novi debian/rules
[carnet-keyring.git] / debian / rules
index ffb469e..cbe925d 100755 (executable)
@@ -1,61 +1,3 @@
 #!/usr/bin/make -f
-# debian/rules file - for debian/keyring
-# Based on sample debian/rules file - for GNU Hello (1.3).
-# Copyright 1994,1995 by Ian Jackson.
-# Copyright 1998-2003 James Troup
-# I hereby give you perpetual unlimited permission to copy,
-# modify and relicense this file, provided that you do not remove
-# my name from the file itself.  (I assert my moral right of
-# paternity under the Copyright, Designs and Patents Act 1988.)
-# This file may have to be extensively modified
-
-install_dir=install -d -m 755
-install_file=install -m 644
-install_script=install -m 755
-install_binary=install -m 755 -s
-
-VERSION := $(shell dpkg-parsechangelog | grep ^Version: | cut -d' ' -f2)
-
-build:
-
-clean:
-       $(checkdir)
-       -rm -f foo foo.asc *.bak *~ */*~ debian/files* debian/*substvars
-       -rm -rf debian/tmp
-
-binary-indep: checkroot
-       $(checkdir)
-       -rm -rf debian/tmp
-       $(install_dir) debian/tmp/DEBIAN/
-       $(install_script) debian/postinst debian/tmp/DEBIAN/
-       $(install_script) debian/prerm debian/tmp/DEBIAN/
-
-       $(install_dir) debian/tmp/usr/share/keyrings/
-       $(install_file) keyrings/carnet-keyring.gpg debian/tmp/usr/share/keyrings/
-       $(install_file) keyrings/carnet-removed-keys.gpg debian/tmp/usr/share/keyrings/
-
-       $(install_dir) debian/tmp/usr/share/doc/carnet-keyring/
-       $(install_file) debian/changelog debian/tmp/usr/share/doc/carnet-keyring/changelog
-
-       dh_installdocs
-       dpkg-gencontrol -pcarnet-keyring -isp
-       chown -R root.root debian/tmp
-       chmod -R go=rX debian/tmp
-       dpkg --build debian/tmp ..
-
-binary-arch:
-
-#define checkdir
-#      test -f keyrings/carnet-keyring.gpg
-#      test -f keyrings/carnet-removed-keys.gpg
-#endef
-
-# Below here is fairly generic really
-
-binary:                binary-indep binary-arch
-
-checkroot:
-       $(checkdir)
-       test root = "`whoami`"
-
-.PHONY: binary binary-arch binary-indep clean checkroot
+%:
+       dh $@