ispravke za lintian debian/3.0.0
authorIvan Rako <irako@nekkar.carnet.hr>
Fri, 22 Apr 2011 11:11:55 +0000 (13:11 +0200)
committerIvan Rako <irako@nekkar.carnet.hr>
Fri, 22 Apr 2011 11:11:55 +0000 (13:11 +0200)
debian/changelog
debian/control
debian/copyright
debian/rules

index 6e52312..9431ae2 100644 (file)
@@ -159,11 +159,11 @@ carnet-tools (1.2) unstable; urgency=low
 
   * Dodana nova verzija cp-update (v2.2)
  
- -- Nikola Pavkovic <nix@irb.hr> Wed, 25 Feb 2004 21:26:58 +0100
+ -- Nikola Pavkovic <nix@irb.hr>  Wed, 25 Feb 2004 21:26:58 +0100
 
 carnet-tools (1.1-5)  unstable; urgency=low
 
   * Prvo izdanje za Sarge
 
- -- Nikola Pavkovic <nix@irb.hr> Sun, 22 Feb 2004 20:44:52 +0100
+ -- Nikola Pavkovic <nix@irb.hr>  Sun, 22 Feb 2004 20:44:52 +0100
 
index de85bfa..1c96df4 100644 (file)
@@ -7,7 +7,7 @@ Standards-Version: 3.7.2
 
 Package: carnet-tools-cn
 Architecture: all
-Depends: perl, coreutils, debianutils, awk, ipcalc, net-tools
+Depends: perl, coreutils (>= 6.10), debianutils (>= 2.30), gawk, ipcalc, net-tools
 Suggests: mail-transport-agent
 Conflicts: carnet-tools
 Provides: carnet-tools
index e3933e7..28add9f 100644 (file)
@@ -1,7 +1,7 @@
-This package is copyright (c) by CARNet <paketi@carnet.hr>.
+Copyright 2006 CARNet <paketi@carnet.hr>
 
-You are free to distribute this software under the terms of
-the GNU General Public License.
+You are free to distribute this software package under the terms of the
+GNU General Public License.
 
 On Debian systems, the complete text of the GNU General Public
 License can be found in the file /usr/share/common-licenses/GPL.
index 36b93a9..cbe925d 100755 (executable)
@@ -1,87 +1,3 @@
 #!/usr/bin/make -f
-# -*- makefile -*-
-# Sample debian/rules that uses debhelper.
-# This file was originally written by Joey Hess and Craig Small.
-# As a special exception, when this file is copied by dh-make into a
-# dh-make output file, you may use that output file without restriction.
-# This special exception was added by Craig Small in version 0.37 of dh-make.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-configure: configure-stamp
-configure-stamp:
-       dh_testdir
-       # Add here commands to configure the package.
-
-       touch configure-stamp
-
-
-build: build-stamp
-
-build-stamp: configure-stamp 
-       dh_testdir
-
-       # Add here commands to compile the package.
-       # $(MAKE)
-       # pod2man debian/carnet-tools-cn/usr/sbin/cp-update > cp-update.1
-
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp configure-stamp
-
-       # Add here commands to clean up after the build process.
-       # -$(MAKE) clean
-
-       dh_clean 
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k 
-       dh_installdirs
-
-       # Add here commands to install the package into debian/carnet-tools-cn.
-       # $(MAKE) install DESTDIR=$(CURDIR)/debian/carnet-tools-cn
-
-
-# Build architecture-independent files here.
-binary-indep: build install
-# We have nothing to do by default.
-
-# Build architecture-dependent files here.
-binary-arch: build install
-       dh_testdir
-       dh_testroot
-       dh_installchangelogs -k
-       dh_installdocs
-#      dh_installexamples
-       dh_install
-#      dh_installmenu
-#      dh_installdebconf       
-#      dh_installlogrotate
-#      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
-#      dh_installcron
-#      dh_installinfo
-       dh_installman
-#      dh_link
-#      dh_strip
-#      dh_compress
-       dh_fixperms
-#      dh_perl
-#      dh_python
-#      dh_makeshlibs
-       dh_installdeb
-#      dh_shlibdeps
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary install configure
+%:
+       dh $@