Build documentation when creating package.
[carnet-upgrade.git] / debian / rules
index 19795a6..9316135 100755 (executable)
@@ -14,9 +14,11 @@ build: build-stamp
 build-stamp:
        dh_testdir
 
-       # Add here commands to compile the package.
-       #$(MAKE)
-       #docbook-to-man debian/carnet-upgrade.sgml > carnet-upgrade.1
+       # Build the package.
+       (cd doc; debiandoc2text -l hr_HR.UTF-8 carnet-upgrade.sgml)
+       (cd doc; debiandoc2html -l hr_HR.UTF-8 carnet-upgrade.sgml)
+       (cd doc; debiandoc2pdf  -l hr_HR.UTF-8 carnet-upgrade.sgml)
+       rm doc/carnet-upgrade.tpt
 
        touch $@
 
@@ -25,8 +27,8 @@ clean:
        dh_testroot
        rm -f build-stamp
 
-       # Add here commands to clean up after the build process.
-       #$(MAKE) clean
+       # Clean up after the build process.
+       rm -rf doc/carnet-upgrade.{txt,html,pdf,tpt}
 
        dh_clean 
 
@@ -36,9 +38,7 @@ install: build
        dh_clean -k 
        dh_installdirs
 
-       # Add here commands to install the package into debian/carnet-upgrade.
-       #$(MAKE) DESTDIR=$(CURDIR)/debian/carnet-upgrade install
-
+       # Install the package.
 
 # Build architecture-independent files here.
 binary-indep: build install