Build documentation when creating package.
authorValentin Vidic <vvidic@carnet.hr>
Fri, 11 Jan 2008 13:11:42 +0000 (14:11 +0100)
committerValentin Vidic <vvidic@carnet.hr>
Fri, 11 Jan 2008 13:11:42 +0000 (14:11 +0100)
debian/control
debian/rules

index 4671f9c..d63a0a3 100644 (file)
@@ -2,7 +2,7 @@ Source: carnet-upgrade
 Section: carnet
 Priority: extra
 Maintainer: Valentin Vidic <vvidic@carnet.hr>
-Build-Depends: debhelper (>= 5)
+Build-Depends: debhelper (>= 5), debiandoc-sgml, texlive
 Standards-Version: 3.7.2
 
 Package: carnet-upgrade
index 19795a6..9316135 100755 (executable)
@@ -14,9 +14,11 @@ build: build-stamp
 build-stamp:
        dh_testdir
 
-       # Add here commands to compile the package.
-       #$(MAKE)
-       #docbook-to-man debian/carnet-upgrade.sgml > carnet-upgrade.1
+       # Build the package.
+       (cd doc; debiandoc2text -l hr_HR.UTF-8 carnet-upgrade.sgml)
+       (cd doc; debiandoc2html -l hr_HR.UTF-8 carnet-upgrade.sgml)
+       (cd doc; debiandoc2pdf  -l hr_HR.UTF-8 carnet-upgrade.sgml)
+       rm doc/carnet-upgrade.tpt
 
        touch $@
 
@@ -25,8 +27,8 @@ clean:
        dh_testroot
        rm -f build-stamp
 
-       # Add here commands to clean up after the build process.
-       #$(MAKE) clean
+       # Clean up after the build process.
+       rm -rf doc/carnet-upgrade.{txt,html,pdf,tpt}
 
        dh_clean 
 
@@ -36,9 +38,7 @@ install: build
        dh_clean -k 
        dh_installdirs
 
-       # Add here commands to install the package into debian/carnet-upgrade.
-       #$(MAKE) DESTDIR=$(CURDIR)/debian/carnet-upgrade install
-
+       # Install the package.
 
 # Build architecture-independent files here.
 binary-indep: build install