Fix pdf build on jessie
[carnet-upgrade.git] / debian / rules
index 15f214a..e827a56 100755 (executable)
@@ -9,11 +9,19 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-build: build-stamp
+PKG_VERSION = $(shell dpkg-parsechangelog|sed -n 's/^Version: \(.*:\|\)//p')
 
-build-stamp: doc/carnet-upgrade.sgml
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
+
+build-stamp: doc/carnet-upgrade-src.sgml
        dh_testdir
 
+       # Update package version in documentation
+       sed -e 's/%PKG_VERSION%/$(PKG_VERSION)/g' doc/carnet-upgrade-src.sgml \
+               > doc/carnet-upgrade.sgml
+
        # Build txt docs
        (cd doc; debiandoc2text -l hr_HR.UTF-8 carnet-upgrade.sgml)
 
@@ -25,7 +33,7 @@ build-stamp: doc/carnet-upgrade.sgml
        mv doc/index.html doc/carnet-upgrade.html
 
        # Build pdf docs
-       (cd doc; debiandoc2pdf  -l hr_HR.UTF-8 carnet-upgrade.sgml)
+       (cd doc; debiandoc2pdf -l hr_HR.UTF-8 carnet-upgrade.sgml)
        rm doc/carnet-upgrade.tpt
 
        touch $@
@@ -36,14 +44,14 @@ clean:
        rm -f build-stamp
 
        # Clean up after the build process.
-       rm -rf doc/carnet-upgrade.{txt,html,pdf,tpt}
+       rm -rf doc/carnet-upgrade.{txt,html,pdf,tpt,sgml}
 
        dh_clean 
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k 
+       dh_clean
        dh_installdirs
 
        # Install the package.
@@ -56,6 +64,11 @@ binary-indep: build install
        dh_installdocs
        dh_installexamples
        dh_install
+       # Update package version in source
+       sed -i -e 's/%PKG_VERSION%/$(PKG_VERSION)/g' \
+               debian/carnet-upgrade/usr/share/carnet-upgrade/cn-upgrade
+       # Remove documentation template
+       rm -f debian/carnet-upgrade/usr/share/doc/carnet-upgrade/carnet-upgrade-src.sgml
 #      dh_installmenu
        dh_installdebconf       
 #      dh_installlogrotate