Fix pdf build on jessie
[carnet-upgrade.git] / debian / rules
index 2fb76e9..e827a56 100755 (executable)
@@ -9,11 +9,6 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-# check if locale is available or use a local copy
-ifeq ($(wildcard /usr/share/perl5/DebianDoc_SGML/Locale/hr_HR.UTF-8),)
-perlenv = PERL5LIB=../debian/perl5
-endif
-
 PKG_VERSION = $(shell dpkg-parsechangelog|sed -n 's/^Version: \(.*:\|\)//p')
 
 build: build-arch build-indep
@@ -28,19 +23,17 @@ build-stamp: doc/carnet-upgrade-src.sgml
                > doc/carnet-upgrade.sgml
 
        # Build txt docs
-       (cd doc; $(perlenv) debiandoc2text -l hr_HR.UTF-8 carnet-upgrade.sgml)
+       (cd doc; debiandoc2text -l hr_HR.UTF-8 carnet-upgrade.sgml)
 
        # Build one page html docs
        rm -rf doc/carnet-upgrade.html
-       (cd doc; $(perlenv) debiandoc2html -l hr_HR.UTF-8 \
-               -1 carnet-upgrade.sgml)
+       (cd doc; debiandoc2html -l hr_HR.UTF-8 -1 carnet-upgrade.sgml)
        mv doc/carnet-upgrade.html/index.html doc/index.html
        rmdir doc/carnet-upgrade.html
        mv doc/index.html doc/carnet-upgrade.html
 
        # Build pdf docs
-       (cd doc; $(perlenv) debiandoc2pdf -l hr_HR.UTF-8 \
-               -s ../debian/fix_latex carnet-upgrade.sgml)
+       (cd doc; debiandoc2pdf -l hr_HR.UTF-8 carnet-upgrade.sgml)
        rm doc/carnet-upgrade.tpt
 
        touch $@