Make HTML documentation single page.
authorValentin Vidic <vvidic@carnet.hr>
Wed, 23 Jan 2008 13:20:03 +0000 (14:20 +0100)
committerValentin Vidic <vvidic@carnet.hr>
Wed, 23 Jan 2008 13:20:03 +0000 (14:20 +0100)
debian/rules

index a1c4f89..06a0a0a 100755 (executable)
@@ -14,9 +14,12 @@ build: build-stamp
 build-stamp: doc/carnet-upgrade.sgml
        dh_testdir
 
-       # Build the package.
+       # Build the documentation
        (cd doc; debiandoc2text -l hr_HR.UTF-8 carnet-upgrade.sgml)
-       (cd doc; debiandoc2html -l hr_HR.UTF-8 carnet-upgrade.sgml)
+       (cd doc; debiandoc2html -l hr_HR.UTF-8 -1 carnet-upgrade.sgml)
+       mv doc/carnet-upgrade.html/index.html doc/index.html
+       rmdir doc/carnet-upgrade.html
+       mv doc/index.html doc/carnet-upgrade.html
        (cd doc; debiandoc2pdf  -l hr_HR.UTF-8 carnet-upgrade.sgml)
        rm doc/carnet-upgrade.tpt