Fixed documentation building.
authorValentin Vidic <vvidic@carnet.hr>
Mon, 28 Jan 2008 15:36:15 +0000 (16:36 +0100)
committerValentin Vidic <vvidic@carnet.hr>
Mon, 28 Jan 2008 15:36:15 +0000 (16:36 +0100)
debian/rules

index 06a0a0a..15f214a 100755 (executable)
@@ -14,12 +14,17 @@ build: build-stamp
 build-stamp: doc/carnet-upgrade.sgml
        dh_testdir
 
-       # Build the documentation
+       # Build txt docs
        (cd doc; debiandoc2text -l hr_HR.UTF-8 carnet-upgrade.sgml)
+
+       # Build one page html docs
+       rm -rf doc/carnet-upgrade.html
        (cd doc; debiandoc2html -l hr_HR.UTF-8 -1 carnet-upgrade.sgml)
        mv doc/carnet-upgrade.html/index.html doc/index.html
        rmdir doc/carnet-upgrade.html
        mv doc/index.html doc/carnet-upgrade.html
+
+       # Build pdf docs
        (cd doc; debiandoc2pdf  -l hr_HR.UTF-8 carnet-upgrade.sgml)
        rm doc/carnet-upgrade.tpt