Install ocsinventory-agent-cn. debian/5.0.1
authorValentin Vidic <Valentin.Vidic@CARNet.hr>
Thu, 2 Jul 2009 08:45:58 +0000 (10:45 +0200)
committerValentin Vidic <Valentin.Vidic@CARNet.hr>
Thu, 2 Jul 2009 08:45:58 +0000 (10:45 +0200)
debian/changelog
src/actions/main.queue
src/actions/post_upgrade.queue
src/data.sh
src/functions.sh

index ce69429..c3b0861 100644 (file)
@@ -1,3 +1,9 @@
+carnet-upgrade (5.0.1) stable; urgency=low
+
+  * Install packages introduced in this release.
+
+ -- Valentin Vidic <Valentin.Vidic@CARNet.hr>  Thu, 02 Jul 2009 09:54:36 +0200
+
 carnet-upgrade (5.0.0) stable; urgency=low
 
   * Etch->Lenny version of upgrade scripts.
index 4dac0a7..11160b0 100644 (file)
@@ -47,6 +47,7 @@ true                          upgrade first           # neki paketi moraju rucno
 true                           upgrade second          # neke pakete zelimo ranije
 true                           remove_orphaned         # ocisti stare libove nakon sto su cn paketi nadogradjeni
 true                           dist_upgrade            # instaliraj ostatak
+true                           install_new             # instaliraj nove
 # i ostatak
 true                           add_group_proc          # za oidentd
 true                           pkgadd monit-cn
index f7d8518..695ea4e 100644 (file)
@@ -4,9 +4,9 @@
 # dodavati naknadne instalacije/upgrade paketa koje mozda nisu upgradeane sa
 # 2.1-1, tj. nije ih bilo u packages_first popisu a dist-upgrade ih nije
 # instalirao.  To se mozda odnosi na ntp-cn, pa je za svaki slucaj dodan.
-
 true                           debconf_priority reset
 true                           add_group_proc          # + restart oidentd ako treba
+true                           install_new
 pkg kernel-2.6-cn              dpkg-reconfigure kernel-2.6-cn
 # ovo bi trebalo biti predzadnje na popisu
 #  - izvrsi sve uvjetne post_upgrade akcije
index a91325d..cc9189c 100644 (file)
@@ -118,6 +118,11 @@ libsnmp9
 libsensors3
 '
 
+# new packages to be installed
+new_packages='
+ocsinventory-agent-cn
+'
+
 # Check if these services are running after upgrade
 # package-cn           user            proces (pazi, regexp)                   nice name
 services_to_check='
index c5156e6..ecac67b 100644 (file)
@@ -603,6 +603,13 @@ upgrade () {
   pkgadd_if_installed $packages
 }
 
+# install packages introduced in this release
+install_new () {
+  if [ "$new_packages" ]; then
+    pkgadd $new_packages
+  fi
+}
+
 # funkcija utrpa ispravan sources.list
 create_sources_list () {
     local sl sl_new