Fix lintian warnings.
authorValentin Vidic <Valentin.Vidic@CARNet.hr>
Fri, 30 Sep 2011 11:09:03 +0000 (13:09 +0200)
committerValentin Vidic <Valentin.Vidic@CARNet.hr>
Fri, 30 Sep 2011 11:09:03 +0000 (13:09 +0200)
debian/compat
debian/control
debian/links
debian/postinst
debian/rules

index 7ed6ff8..7f8f011 100644 (file)
@@ -1 +1 @@
-5
+7
index fcb271b..6e7ef5c 100644 (file)
@@ -3,14 +3,15 @@ Section: admin
 Priority: extra
 Maintainer: Grupa za izradu paketa <paketi@carnet.hr>
 Uploaders: Valentin Vidic <Valentin.Vidic@CARNet.hr>
-Build-Depends: debhelper (>= 5), debiandoc-sgml, texlive, texlive-latex-extra, gs-gpl | gs
-Standards-Version: 3.7.3
+Build-Depends: debhelper (>= 7), debiandoc-sgml, texlive, texlive-latex-extra,
+ ghostscript
+Standards-Version: 3.9.1
 
 Package: carnet-upgrade
 Architecture: all
 Depends: dialog, wget, ${misc:Depends}
 Description: CARNet distribution upgrade script
- This package provides cn-upgrade, a helper script
+ This package provides carnet-upgrade, a helper script
  to facilitate upgrades between different versions
  of CARNet Debian Linux distributions, by resolving
  various issues that keep apt-get dist-upgrade from
index 0b4576d..e2e40e2 100644 (file)
@@ -1,2 +1 @@
-usr/share/carnet-upgrade/cn-upgrade usr/sbin/cn-upgrade
-usr/sbin/cn-upgrade usr/sbin/carnet-upgrade
+usr/share/carnet-upgrade/cn-upgrade usr/sbin/carnet-upgrade
index 3981790..589daf7 100644 (file)
@@ -35,7 +35,7 @@ if [ "$1" = "configure" ] && [ -e /usr/share/debconf/confmodule ]; then
     . /usr/share/debconf/confmodule
 
     # clear old cached values
-    if dpkg --compare-versions "$2" lt 5.0; then
+    if dpkg --compare-versions "$2" lt 6.0; then
         db_set carnet-upgrade/debconf-priority ""
         db_set carnet-upgrade/check-services   ""
 
index b7a9059..2fb76e9 100755 (executable)
@@ -16,7 +16,9 @@ endif
 
 PKG_VERSION = $(shell dpkg-parsechangelog|sed -n 's/^Version: \(.*:\|\)//p')
 
-build: build-stamp
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
 
 build-stamp: doc/carnet-upgrade-src.sgml
        dh_testdir
@@ -56,7 +58,7 @@ clean:
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k 
+       dh_clean
        dh_installdirs
 
        # Install the package.