Minor fixes to documentation and code. debian/4.0.3
authorValentin Vidic <Valentin.Vidic@CARNet.hr>
Mon, 23 Jun 2008 13:57:21 +0000 (15:57 +0200)
committerValentin Vidic <Valentin.Vidic@CARNet.hr>
Mon, 23 Jun 2008 13:57:21 +0000 (15:57 +0200)
debian/changelog
doc/carnet-upgrade.sgml
src/cn-upgrade
src/functions.sh

index bd0bc0c..b11ce43 100644 (file)
@@ -1,3 +1,17 @@
+carnet-upgrade (4.0.3) stable; urgency=low
+
+  * Remove X if installed.
+  * Check for free space in / for kernel upgrade.
+  * Check for free space in /var for package download.
+  * Update package versions.
+  * Use hr_HR localization in dialog.
+  * Ignore autogenerated debhelper.log.
+  * Added section on "/ full" to documentation.
+  * Display short installation notice in postinst.
+  * Upgrade oidentd before kernel-2.6-cn.
+
+ -- Valentin Vidic <Valentin.Vidic@CARNet.hr>  Mon, 23 Jun 2008 12:43:39 +0200
+
 carnet-upgrade (4.0.2) stable; urgency=low
 
   * Added login.defs to documentation.
index 1564de6..4ef1565 100644 (file)
@@ -8,7 +8,7 @@
         <name>Grupa za izradu paketa</name>
         <email>paketi@carnet.hr</email>
       </author>
-      <version>Verzija 4.0.2</version>
+      <version>Verzija 4.0.3</version>
 
       <abstract>
         CARNet Debian <em>etch</em> je treća generacija CARNet Debian
@@ -506,10 +506,10 @@ CN: run_actions (main) started...
         <p>
         Ukoliko imate malu <file>/</file> particiju moguće je da instalacija
         kernel paketa neće uspjeti. Paket <package>kernel-2.6-cn</package>
-        donosi čak četiri inačice kernela i zauzima preko 100 MB. Zbog
-        sigurnosti stare inačice kernela se ne brišu iz <file>/boot</file>
-        direktorija što može nakon nekoliko iteracija dovesti do zapunjenja
-        particije.  Rješenje je brisanje starih nekorištenih kernela iz
+        donosi čak četiri inačice kernela i zauzima preko 100 MB.  Stare
+        inačice kernela se ne brišu iz <file>/boot</file> direktorija što
+        nakon nekoliko iteracija može dovesti do zapunjenja particije.
+        Rješenje je brisanje starih nekorištenih kernela iz
         <file>/boot</file> direktorija i pripadnih modula iz
         <file>/lib/modules</file> direktorija.  Detaljnije upute
         nalaze se na <url name="portalu za sistemce"
index 4072425..3c81d79 100755 (executable)
@@ -2,7 +2,7 @@
 # last update: 2005-01-07
 # Zoran 'jelly' Dzelajlija <jelly@srce.hr>
 # Ivan 'ico' Rako <irako@srce.hr>
-version="carnet-upgrade v4.0.2"
+version="carnet-upgrade v4.0.3"
 
 # restart upgrade under script for logging purposes
 if [ "$1" == "--no-script" ]; then
index 3830ea5..0af728b 100644 (file)
@@ -865,7 +865,7 @@ download_size() {
   size=$(LC_ALL=C apt-get --yes --print-uris "$@" \
          | sed -n '/^Need to get / {s///; s/B\/.*//; p}')
 
-  size_to_mb $size
+  size_to_mb "${size}B"
 }
 
 installed_size() {
@@ -874,7 +874,7 @@ installed_size() {
   size=$(apt-cache show $package \
          | awk '$1 == "Installed-Size:" {print $2; exit}')
 
-  size_to_mb "${size}k"
+  size_to_mb "${size}kB"
 }
 
 size_to_mb() {
@@ -884,16 +884,16 @@ size_to_mb() {
     size=0;
   fi
 
-  if [ "${size%k}" != "$size" ]; then
-    size=$(round ${size%k})
+  if [ "${size%kB}" != "$size" ]; then
+    size=$(round ${size%kB})
     size=$(($size/1024+1))
-  elif [ "${size%M}" != "$size" ]; then
-    size=$(round ${size%M})
-  elif [ "${size%G}" != "$size" ]; then
-    size=$(round ${size%G})
+  elif [ "${size%MB}" != "$size" ]; then
+    size=$(round ${size%MB})
+  elif [ "${size%GB}" != "$size" ]; then
+    size=$(round ${size%GB})
     size=$(($size*1024))
-  elif [ "${size%[0-9]}" != "$size" ]; then
-    size=$(round $size)
+  elif [ "${size%[0-9]B}" != "$size" ]; then
+    size=$(round ${size%B})
     size=$(($size/1024/1024+1))
   else
     log "unrecognized size unit: $size"