* Non-Maintainer Upload debian/1%2.2.27_cn1
authorZeljko Boros <Zeljko.Boros@carnet.hr>
Tue, 30 Jun 2020 14:11:33 +0000 (16:11 +0200)
committerZeljko Boros <Zeljko.Boros@carnet.hr>
Tue, 30 Jun 2020 14:11:33 +0000 (16:11 +0200)
  * Izbačene SSLv2 vrijednosti koje izbacuju grešku

debian/changelog
debian/control
debian/postinst

index ece34fd..dcd05bf 100644 (file)
@@ -1,3 +1,10 @@
+dovecot-cn (1:2.2.27~cn1) stable; urgency=medium
+
+  * Non-Maintainer Upload
+  * Izbačene SSLv2 vrijednosti koje izbacuju grešku
+
+ -- Zeljko Boros <Zeljko.Boros@carnet.hr>  Fri, 26 Jun 2020 14:51:36 +0200
+
 dovecot-cn (1:2.2.27~cn0) stable; urgency=medium
 
   * Prva verzija za stretch
index 52083e8..be883b9 100644 (file)
@@ -2,6 +2,7 @@ Source: dovecot-cn
 Section: net
 Priority: optional
 Maintainer: Ivan Rako <Ivan.Rako@CARNet.hr>
+Uploaders: Ivan Rako <Ivan.Rako@CARNet.hr>, Zeljko Boros <Zeljko.Boros@carnet.hr>
 Build-Depends: debhelper (>= 9)
 Standards-Version: 3.9.8
 
index 1caedc8..c399682 100755 (executable)
@@ -33,7 +33,12 @@ cp_check_and_sed 'pop3_client_workarounds' \
                 /etc/dovecot/conf.d/20-pop3.conf || true
 
 cp_check_and_sed '#ssl_cipher_list' \
-                 's/#ssl_cipher_list.*/ssl_cipher_list = ALL:!aNULL:!eNULL:!ADH!LOW:!MEDIUM:!EXP:!SSLv2:HIGH/g' \
+                 's/#ssl_cipher_list.*/ssl_cipher_list = ALL:!aNULL:!eNULL:!ADH!LOW:!MEDIUM:!EXP:HIGH/g' \
+                /etc/dovecot/conf.d/10-ssl.conf || true
+
+# izbacujemo SSLv2
+cp_check_and_sed 'ssl_cipher_list' \
+                 's/:\!SSLv2//g' \
                 /etc/dovecot/conf.d/10-ssl.conf || true
 
 # trazio zelja
@@ -64,11 +69,26 @@ fi
 
 
 
-# dodao ico, gasi stare SSL protokole
+# dodao ico, gasi SSLv3 protokol
 cp_check_and_sed '#ssl_protocols =' \
-                's/^#ssl_protocols.*/ssl_protocols = !SSLv2 !SSLv3/g' \
+                's/^#ssl_protocols.*/ssl_protocols = !SSLv3/g' \
+                /etc/dovecot/conf.d/10-ssl.conf || true
+
+# dodao zelja, gasi stare SSL protokole
+cp_check_and_sed 'ssl_protocols =' \
+                's/\!SSLv2 //g' \
                 /etc/dovecot/conf.d/10-ssl.conf || true
 
+# dodao zelja, gasi stare SSL protokole/ciphere u 95-cn9-upgrade.conf ako postoje
+if [ -f /etc/dovecot/conf.d/95-cn9-upgrade.conf ]; then
+       cp_check_and_sed 'ssl_protocols =' \
+                        's/\!SSLv2 //g' \
+                        /etc/dovecot/conf.d/95-cn9-upgrade.conf || true
+       cp_check_and_sed 'ssl_cipher_list' \
+                        's/:\!SSLv2//g' \
+                        /etc/dovecot/conf.d/95-cn9-upgrade.conf || true
+fi
+
 # restart 
 service dovecot restart || true