Dodana config skripta za rjesavanje grub diverta.
authorValentin Vidic <Valentin.Vidic@CARNet.hr>
Wed, 29 Sep 2010 08:56:27 +0000 (10:56 +0200)
committerValentin Vidic <Valentin.Vidic@CARNet.hr>
Wed, 13 Oct 2010 09:25:47 +0000 (11:25 +0200)
debian/config [new file with mode: 0644]
debian/control
debian/po/POTFILES.in [new file with mode: 0644]
debian/po/templates.pot [new file with mode: 0644]
debian/postinst
debian/rules
debian/templates [new file with mode: 0644]

diff --git a/debian/config b/debian/config
new file mode 100644 (file)
index 0000000..b0a9aee
--- /dev/null
@@ -0,0 +1,31 @@
+#!/bin/sh -e
+
+# Source debconf library.
+. /usr/share/debconf/confmodule
+
+exec >&2
+
+sysctl -e -w kernel.exec-shield=0 || true
+
+DIVERT_TO="grub grub-probe"
+for i in $DIVERT_TO; do
+    if [ -e /usr/sbin/$i.real ]; then
+        echo "CN: Undiverting $i"
+
+        if [ -e /usr/sbin/$i ]; then
+            rm -vf /usr/sbin/$i
+        fi
+
+        dpkg-divert --remove --rename --package 'kernel-2.6-cn' \
+            --divert /usr/sbin/$i.real /usr/sbin/$i
+
+        sed -i "/^\/usr\/sbin\/$i/d" /var/lib/dpkg/info/kernel-2.6-cn.list
+    fi
+done
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0
index 23e0269..2d13d34 100644 (file)
@@ -8,7 +8,7 @@ Standards-Version: 3.8.0
 Package: kernel-2.6-cn
 Architecture: all
 Section: admin
-Depends: grub (>= 0.97-47lenny2), procps (>= 1:3.2.7-11), udev (>= 0.125-7+lenny1), carnet-tools-cn (>= 2.8.2), module-init-tools (>= 3.4-1), mount (>= 2.13.1.1-1), e2fsprogs (>= 1.41.3-1), microcode.ctl (>= 1.17-9), irqbalance (>= 0.55-2.4lenny1), mdadm (>= 2.6.7.2-1), firmware-bnx2 (>= 0.14+lenny1), linux-image-686-bigmem | linux-image-amd64
+Depends: grub (>= 0.97-47lenny2), procps (>= 1:3.2.7-11), udev (>= 0.125-7+lenny1), carnet-tools-cn (>= 2.8.2), module-init-tools (>= 3.4-1), mount (>= 2.13.1.1-1), e2fsprogs (>= 1.41.3-1), microcode.ctl (>= 1.17-9), irqbalance (>= 0.55-2.4lenny1), mdadm (>= 2.6.7.2-1), firmware-bnx2 (>= 0.14+lenny1), linux-image-686-bigmem | linux-image-amd64, debconf
 Conflicts: iplogger, kernel-cn, kernel-2.4-cn (<< 2.4.33-2)
 Replaces: kernel-cn, kernel-2.4-cn
 Provides: kernel-cn
diff --git a/debian/po/POTFILES.in b/debian/po/POTFILES.in
new file mode 100644 (file)
index 0000000..cef83a3
--- /dev/null
@@ -0,0 +1 @@
+[type: gettext/rfc822deb] templates
diff --git a/debian/po/templates.pot b/debian/po/templates.pot
new file mode 100644 (file)
index 0000000..42491a3
--- /dev/null
@@ -0,0 +1,29 @@
+# SOME DESCRIPTIVE TITLE.
+# Copyright (C) YEAR THE PACKAGE'S COPYRIGHT HOLDER
+# This file is distributed under the same license as the PACKAGE package.
+# FIRST AUTHOR <EMAIL@ADDRESS>, YEAR.
+#
+#, fuzzy
+msgid ""
+msgstr ""
+"Project-Id-Version: PACKAGE VERSION\n"
+"Report-Msgid-Bugs-To: kernel-2.6-cn@packages.debian.org\n"
+"POT-Creation-Date: 2010-09-29 10:52+0200\n"
+"PO-Revision-Date: YEAR-MO-DA HO:MI+ZONE\n"
+"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
+"Language-Team: LANGUAGE <LL@li.org>\n"
+"MIME-Version: 1.0\n"
+"Content-Type: text/plain; charset=CHARSET\n"
+"Content-Transfer-Encoding: 8bit\n"
+
+#. Type: note
+#. Description
+#: ../templates:1001
+msgid "Dummy template to satisfy lintian"
+msgstr ""
+
+#. Type: note
+#. Description
+#: ../templates:1001
+msgid "Lintian warns if templates file is empty."
+msgstr ""
index a36cf36..e6d7b0a 100755 (executable)
@@ -27,6 +27,9 @@ case "$1" in
     ;;
 esac
 
+# Source debconf library.
+. /usr/share/debconf/confmodule
+
 # import CN-functions
 . /usr/share/carnet-tools/functions.sh
 
@@ -326,7 +329,6 @@ fi
 rm -f /etc/sysctl.conf.$$
 cat > /etc/sysctl.conf.$$ <<'EOF'
 kernel.maps_protect=1
-kernel.exec-shield=0
 net.core.rmem_default=1048576
 net.core.wmem_default=1048576
 net.ipv4.conf.all.accept_redirects=0
index 657559f..cbd1df2 100755 (executable)
@@ -45,7 +45,7 @@ binary-indep: build install
 #      dh_installexamples
        dh_install
 #      dh_installmenu
-#      dh_installdebconf
+       dh_installdebconf
 #      dh_installlogrotate
 #      dh_installemacsen
 #      dh_installcatalogs
diff --git a/debian/templates b/debian/templates
new file mode 100644 (file)
index 0000000..fdf6a3e
--- /dev/null
@@ -0,0 +1,4 @@
+Template: kernel-2.6-cn/dummy
+Type: note
+_Description: Dummy template to satisfy lintian
+ Lintian warns if templates file is empty.