novi debian/rules i novi debian/copyright
[mailman-cn.git] / debian / postrm
index 2bcf4b2..e7ef9b3 100755 (executable)
@@ -8,7 +8,9 @@ if [ /etc/apache2/conf.d/mailman-cn.conf ]; then
   rm -f /etc/apache2/conf.d/mailman-cn.conf
 fi
 
-# restartat apache
-if [ -x /etc/init.d/apache2 ]; then
-  /etc/init.d/apache2 reload || true
+# reload apache2 
+if [ -x /usr/sbin/invoke-rc.d ]; then
+  [ -x /etc/init.d/apache2 ] && invoke-rc.d apache2 reload
+else
+  [ -x /etc/init.d/apache2 ] && /etc/init.d/apache2 reload
 fi