novi debian/rules i novi debian/copyright
authorIvan Rako <irako@nekkar.carnet.hr>
Fri, 22 Apr 2011 11:22:58 +0000 (13:22 +0200)
committerIvan Rako <irako@nekkar.carnet.hr>
Fri, 22 Apr 2011 11:22:58 +0000 (13:22 +0200)
debian/control
debian/postinst
debian/postrm

index ee79eb0..7bbcd76 100644 (file)
@@ -7,7 +7,7 @@ Standards-Version: 3.6.1
 
 Package: mailman-cn
 Architecture: all
-Depends: mailman (>= 1:2.1.11), apache2-cn, carnet-tools-cn (>= 2.4)
+Depends: mailman (>= 1:2.1.11), apache2-cn, carnet-tools-cn (>= 2.4), ucf
 Pre-Depends: pwgen
 Description: Powerful, web-based mailing list manager
  The GNU Mailing List Manager, which manages email discussion lists
index f47332c..777d08b 100755 (executable)
@@ -22,7 +22,7 @@ if [ ! -L /etc/apache2/conf.d/mailman-cn.conf -a ! -f /etc/apache2/conf.d/mailma
   ln -sf /etc/mailman/apache.conf /etc/apache2/conf.d/mailman-cn.conf
 fi
 
-HOSTNAME="`hostname --fqdn`"
+hostname="`hostname --fqdn`"
 
 mmcfg_add () {
   opt="$1"
@@ -56,7 +56,7 @@ cp_backup_conffile -p -d mailman $MM_CFG || true
 
 # ocisti smece od prosle verzije
 if dpkg --compare-versions "$2" lt 2:2.1.5-9; then
-  HN="'$HOSTNAME'"
+  HN="'$hostname'"
   grep -v -E 'DEFAULT_(URL_PATTERN|URL_HOST|EMAIL_HOST) =' $MM_CFG | \
   awk '/^# Default host for web interface of newly created MLs/ { print $0; print "DEFAULT_EMAIL_HOST = '$HN'"; getline } { print $0 }' | \
   awk '/^# Default domain for email addresses of newly created MLs/ { print $0;  print "DEFAULT_URL_HOST = '$HN'"; getline } { print $0 }' \
@@ -74,10 +74,10 @@ mmcfg_add "DEFAULT_URL_PATTERN" "'http://%s/mailman/'"
 mmcfg_add "VIRTUAL_HOST_OVERVIEW" "Off"
 
 # sredi DEFAULT_URL_HOST
-mmcfg_add "DEFAULT_URL_HOST" "'$HOSTNAME'"
+mmcfg_add "DEFAULT_URL_HOST" "'$hostname'"
 
 # sredi DEFAULT_EMAIL_HOST
-mmcfg_add "DEFAULT_EMAIL_HOST" "'$HOSTNAME'"
+mmcfg_add "DEFAULT_EMAIL_HOST" "'$hostname'"
 
 # sredi PRIVATE_ARCHIVE_URL
 mmcfg_add "PRIVATE_ARCHIVE_URL" "'/mailman/private'"
@@ -99,7 +99,7 @@ fi
 
 # kreirati mailman listu
 if [ -z "`list_lists | grep -i mailman`" ]; then
-  newlist -q mailman mailman@$HOSTNAME `pwgen 8 1` > /dev/null
+  newlist -q mailman mailman@$hostname `pwgen 8 1` > /dev/null
 fi
 
 # kreirati aliase
@@ -130,7 +130,7 @@ EOF
 # dodati roota na mailman listu:
 if [ ! "`list_members mailman | wc -l`" -ge 1 ]; then
   add_members -r - mailman <<EOF
-root@$HOSTNAME
+root@$hostname
 EOF
 fi
 
@@ -167,14 +167,16 @@ db_go || true
 db_stop || true
 
 # restart mailman
-if [ "$restart" = "yes" -a -x /etc/init.d/mailman ]; then
-  /etc/init.d/mailman stop
-  /etc/init.d/mailman start
+if [ "$restart" = "yes" -a -x /etc/init.d/mailman -a -x /usr/sbin/invoke-rc.d]; then
+  invoke-rc.d mailman stop
+  invoke-rc.d mailman start
 fi
 
-# restartat apache2
-if [ -x /etc/init.d/apache2 ]; then
-  /etc/init.d/apache2 reload || true
+# reload apache2 
+if [ -x /usr/sbin/invoke-rc.d ]; then
+  [ -x /etc/init.d/apache2 ] && invoke-rc.d apache2 reload
+else
+  [ -x /etc/init.d/apache2 ] && /etc/init.d/apache2 reload
 fi
 
 # promjena passworda
@@ -185,4 +187,4 @@ if [ ! -f /var/lib/mailman/data/adm.pw ]; then
   echo "CN:     # mmsitepass"
   echo "CN:"
 fi
-echo "CN: Web interface is at http://$HOSTNAME/mailman/admin/"
+echo "CN: Web interface is at http://$hostname/mailman/admin/"
index 2bcf4b2..e7ef9b3 100755 (executable)
@@ -8,7 +8,9 @@ if [ /etc/apache2/conf.d/mailman-cn.conf ]; then
   rm -f /etc/apache2/conf.d/mailman-cn.conf
 fi
 
-# restartat apache
-if [ -x /etc/init.d/apache2 ]; then
-  /etc/init.d/apache2 reload || true
+# reload apache2 
+if [ -x /usr/sbin/invoke-rc.d ]; then
+  [ -x /etc/init.d/apache2 ] && invoke-rc.d apache2 reload
+else
+  [ -x /etc/init.d/apache2 ] && /etc/init.d/apache2 reload
 fi