r17:
authorIvan Rako <Ivan.Rako@CARNet.hr>
Mon, 29 Oct 2007 23:46:17 +0000 (23:46 +0000)
committerIvan Rako <Ivan.Rako@CARNet.hr>
Mon, 29 Oct 2007 23:46:17 +0000 (23:46 +0000)
debian/changelog
debian/postinst

index b4dad8d..542b1d4 100644 (file)
@@ -1,4 +1,4 @@
-ntp-cn (2:4.2.2.p4-1) carnet-etch; urgency=low
+ntp-cn (2:4.2.2.p4-1) stable; urgency=low
 
   * izdanje paketa za Etch
   * prva verzija sa source paketom
index e0cc13c..0f3ecb6 100755 (executable)
@@ -14,9 +14,12 @@ konfiguriraj() {
 
   cp /usr/share/doc/ntp-cn/ntp.conf.tmpl /etc
 
-  cat > /etc/default/ntp-servers <<EOF
-NTPSERVERS="zg1.ntp.carnet.hr ri.ntp.carnet.hr zg2.ntp.carnet.hr 127.127.1.0"
-EOF
+  # Load CARNet Tools
+  . /usr/share/carnet-tools/functions.sh
+
+  cp_check_and_sed 'NTPSERVERS' \
+                   "s/^.*NTPSERVERS.*/NTPSERVERS=\"zg1.ntp.carnet.hr ri.ntp.carnet.hr zg2.ntp.carnet.hr st.ntp.carnet.hr os.ntp.carnet.hr 127.127.1.0\"/g" \
+                   /etc/default/ntpservers || true
 }
 
 if [ -f /usr/share/doc/ntp-cn/ntp.conf.tmpl -a -f /etc/ntp.conf ]; then
@@ -28,16 +31,8 @@ fi
 # restartaj sve
 if [ -x /etc/init.d/ntp ]; then
   if [ -x /usr/sbin/invoke-rc.d ]; then
-    invoke-rc.d ntp stop
-    for i in 1 2 3 4 5 6 7 8 9 0; do
-      pgrep -u root -f /usr/sbin/ntpd >/dev/null && sleep 1 || break
-    done
-    invoke-rc.d ntp start
+    invoke-rc.d ntp restart
   else
-    /etc/init.d/ntp stop
-    for i in 1 2 3 4 5 6 7 8 9 0; do
-      pgrep -u root -f /usr/sbin/ntpd >/dev/null && sleep 1 || break
-    done
-    /etc/init.d/ntp start
+    /etc/init.d/ntp restart
   fi
 fi